summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCarl Smedstad2024-04-27 22:48:12 +0200
committerCarl Smedstad2024-04-27 22:49:05 +0200
commitcfab0a7828466b9f552d6077929aa0e701fe29b8 (patch)
treea5bbe01d43a04a0a64c39226f3568025c68660d8
parentd301e0cb1df6bfc6cfcc29597b3e588539af21c8 (diff)
downloadaur-cfab0a7828466b9f552d6077929aa0e701fe29b8.tar.gz
upgpkg: 0.26.3-3: Remove makedep python-pytest-runner
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD13
2 files changed, 9 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a74ad90d729c..a9483f84e077 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = python-pyhanko-certvalidator
pkgdesc = Validates X.509 certificates and paths
pkgver = 0.26.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/MatthiasValvekens/certvalidator
arch = any
license = MIT
@@ -10,7 +10,7 @@ pkgbase = python-pyhanko-certvalidator
checkdepends = python-pytest-asyncio
makedepends = python-build
makedepends = python-installer
- makedepends = python-pytest-runner
+ makedepends = python-setuptools
makedepends = python-wheel
depends = python
depends = python-aiohttp
@@ -19,7 +19,7 @@ pkgbase = python-pyhanko-certvalidator
depends = python-oscrypto
depends = python-requests
depends = python-uritools
- source = python-pyhanko-certvalidator-0.26.3.tar.gz::https://github.com/MatthiasValvekens/certvalidator/archive/refs/tags/v0.26.3.tar.gz
+ source = python-pyhanko-certvalidator-0.26.3.tar.gz::https://github.com/MatthiasValvekens/certvalidator/archive/v0.26.3.tar.gz
sha256sums = 7861efb4259126327d9590703fe4f4316647d3725c32bd49ea67f0810abded1c
pkgname = python-pyhanko-certvalidator
diff --git a/PKGBUILD b/PKGBUILD
index 26285d6bf2af..b3a5c6eb81a0 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,9 +2,9 @@
# Contributor: Michał Wojdyła < micwoj9292 at gmail dot com >
pkgname=python-pyhanko-certvalidator
-_name=certvalidator
+_pkgname=certvalidator
pkgver=0.26.3
-pkgrel=2
+pkgrel=3
pkgdesc="Validates X.509 certificates and paths"
url="https://github.com/MatthiasValvekens/certvalidator"
license=(MIT)
@@ -21,7 +21,7 @@ depends=(
makedepends=(
python-build
python-installer
- python-pytest-runner
+ python-setuptools
python-wheel
)
checkdepends=(
@@ -29,16 +29,15 @@ checkdepends=(
python-pytest
python-pytest-asyncio
)
-
-source=("$pkgname-$pkgver.tar.gz::$url/archive/refs/tags/v$pkgver.tar.gz")
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
sha256sums=('7861efb4259126327d9590703fe4f4316647d3725c32bd49ea67f0810abded1c')
-_archive="$_name-$pkgver"
+_archive="$_pkgname-$pkgver"
build() {
cd "$_archive"
- python -m build --wheel --no-isolation
+ python -m build --wheel --no-isolation --skip-dependency-check
}
check() {