summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorent Ch2018-08-21 09:06:28 +0200
committerFlorent Ch2018-08-21 09:06:28 +0200
commitcfbb4d59d26ddac425d6e0f43c59d832b861f386 (patch)
tree97fadc9709ae3461c0a2f037963a58afae7c262f
downloadaur-cfbb4d59d26ddac425d6e0f43c59d832b861f386.tar.gz
Initial version
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD22
2 files changed, 37 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..25e5278138b5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = xob
+ pkgdesc = A lightweight volume (or anything) bar for the X Window System
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/florentc/xob
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ depends = libx11
+ depends = libconfig
+ source = xob::git+https://github.com/florentc/xob.git#tag=v0.1
+ md5sums = SKIP
+
+pkgname = xob
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..7cc2a48e8dfc
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: Florent Ch. <florentc@tutanota.com>
+pkgname=xob
+pkgver=0.1
+pkgrel=1
+pkgdesc="A lightweight volume (or anything) bar for the X Window System"
+arch=('x86_64')
+url="https://github.com/florentc/xob"
+license=('GPL3')
+depends=('libx11' 'libconfig')
+makedepends=('git')
+source=("${pkgname}::git+${url}.git#tag=v${pkgver}")
+md5sums=('SKIP')
+
+build() {
+ cd "$pkgname"
+ make PREFIX="/usr"
+}
+
+package() {
+ cd "$pkgname"
+ make DESTDIR="$pkgdir/" install
+}