summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOSAMC2023-06-20 20:20:52 +0000
committerChristopher Arndt2023-06-20 20:20:52 +0000
commitcfbbd7c53a18d88432f78a136d0464c3ad168dad (patch)
treed55f6bce338919571e43f836d8c3da05750b5d17
parent551b3782facf094c982c7b3cbbc272f0e7b01cec (diff)
downloadaur-cfbbd7c53a18d88432f78a136d0464c3ad168dad.tar.gz
fix: adapt for changing moduleinfo.json path between vst3sdk versions (#247)
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
2 files changed, 9 insertions, 5 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fcb0dafc30dd..2b1780e593ad 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = uhhyou-plugins
pkgdesc = A collection of synthesizer and effect VST3 plugins
pkgver = 0.56.0
- pkgrel = 1
+ pkgrel = 2
url = https://ryukau.github.io/VSTPlugins/
arch = aarch64
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index ecae55cbdd1b..7244dfceb174 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
_name=VSTPlugins-UhhyouPlugins
pkgname=uhhyou-plugins
pkgver=0.56.0
-pkgrel=1
+pkgrel=2
pkgdesc='A collection of synthesizer and effect VST3 plugins'
arch=(aarch64 x86_64)
url='https://ryukau.github.io/VSTPlugins/'
@@ -62,13 +62,17 @@ package() {
libpango-1.0.so libgobject-2.0.so ttf-croscore)
cd $pkgname-build/VST3/Release
for plugin in *.vst3; do
- # skip vst3sdk samples
- [ ! -f $plugin/Contents/moduleinfo.json ] && continue
# install executable
install -vDm755 $plugin/Contents/$CARCH-linux/*.so -t \
"$pkgdir"/usr/lib/vst3/$plugin/Contents/$CARCH-linux
# install resources
- install -vDm644 $plugin/Contents/moduleinfo.json -t "$pkgdir"/usr/lib/vst3/$plugin/Contents
+ if [[ -f $plugin/Contents/moduleinfo.json ]]; then
+ install -vDm644 $plugin/Contents/moduleinfo.json \
+ -t "$pkgdir"/usr/lib/vst3/$plugin/Contents/Resources
+ else
+ install -vDm644 $plugin/Contents/Resources/moduleinfo.json \
+ -t "$pkgdir"/usr/lib/vst3/$plugin/Contents/Resources
+ fi
[ -f $plugin/Contents/Resources/Snapshots/*.png ] &&
install -vDm644 $plugin/Contents/Resources/Snapshots/*.png -t \
"$pkgdir"/usr/lib/vst3/$plugin/Contents/Resources/Snapshots