summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2022-01-30 14:58:42 +0100
committerAndrea Feletto2022-01-30 14:58:42 +0100
commitcfe926e1c0a45c804ae116b4f981fa81b7aeb40c (patch)
tree6725cbf71541abdb983ea97cbc7c83544e1da92e
parent1067f4a07f618d14192d2a8c3295fccdd9aef4ad (diff)
downloadaur-cfe926e1c0a45c804ae116b4f981fa81b7aeb40c.tar.gz
version 0.8
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD24
2 files changed, 13 insertions, 21 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 427ce6537717..f37c0baaca66 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gmid-bin
pkgdesc = Fast Gemini server written with security in mind.
- pkgver = 1.7.5
- pkgrel = 2
+ pkgver = 1.8
+ pkgrel = 1
url = https://gmid.omarpolo.com
arch = x86_64
license = ISC
@@ -9,9 +9,7 @@ pkgbase = gmid-bin
provides = gmid
conflicts = gmid
conflicts = gmid-git
- source = https://github.com/omar-polo/gmid/releases/download/1.7.5/gmid-1.7.5-binaries.tar.gz
- source = https://raw.githubusercontent.com/omar-polo/gmid/1.7.5/LICENSE
- sha256sums = 97009f8acdc81c1202dd14dfdcaea8e3fd99983ff1e0e4711258d3e75f49ecdc
- sha256sums = f82c1fa80d35427d109a77ed59ecda41474ef46539238750876702fa40579f9f
+ source = https://github.com/omar-polo/gmid/releases/download/1.8/gmid-1.8-binaries.tar.gz
+ sha256sums = 9e517a570f3fb5f68f47b9649cc3501c7c8cfbe86ca5d0447f632739a5db99e0
pkgname = gmid-bin
diff --git a/PKGBUILD b/PKGBUILD
index a633e7b49519..f92f459110f9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,8 +3,8 @@
pkgname=gmid-bin
_pkgname=${pkgname%-*}
-pkgver=1.7.5
-pkgrel=2
+pkgver=1.8
+pkgrel=1
pkgdesc='Fast Gemini server written with security in mind.'
arch=('x86_64')
url='https://gmid.omarpolo.com'
@@ -12,21 +12,15 @@ license=('ISC')
provides=('gmid')
conflicts=('gmid' 'gmid-git')
depends=('libretls')
-source=(
- "https://github.com/omar-polo/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver-binaries.tar.gz"
- "https://raw.githubusercontent.com/omar-polo/$_pkgname/$pkgver/LICENSE"
-)
-sha256sums=(
- '97009f8acdc81c1202dd14dfdcaea8e3fd99983ff1e0e4711258d3e75f49ecdc'
- 'f82c1fa80d35427d109a77ed59ecda41474ef46539238750876702fa40579f9f'
-)
+source=("https://github.com/omar-polo/$_pkgname/releases/download/$pkgver/$_pkgname-$pkgver-binaries.tar.gz")
+sha256sums=('9e517a570f3fb5f68f47b9649cc3501c7c8cfbe86ca5d0447f632739a5db99e0')
package() {
- cd "$srcdir"
- install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
-
- cd "$_pkgname-$pkgver-binaries"
- install -Dm755 "$_pkgname.linux.amd64" "$pkgdir/usr/bin/$_pkgname"
+ cd "$srcdir/$_pkgname-$pkgver-binaries"
+ install -Dm755 "gmid.linux.amd64" "$pkgdir/usr/bin/gmid"
+ install -Dm755 "gg.linux.amd64" "$pkgdir/usr/bin/gg"
install -Dm644 gmid.1 -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 gg.1 -t "$pkgdir/usr/share/man/man1"
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/$_pkgname"
install -Dm644 README.md -t "$pkgdir/usr/share/doc/$_pkgname"
}