summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSlashbunny2009-08-12 22:17:38 -0400
committerSlashbunny2015-06-09 22:54:22 -0400
commitcfec434f4c962aed2487985bc28fb43fbbb010af (patch)
tree2751d5d1073f84163c073e916c14496c6ba68432
downloadaur-cfec434f4c962aed2487985bc28fb43fbbb010af.tar.gz
Initial commit of personal PKGBUILDs for Arch Linux
-rw-r--r--.SRCINFO18
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD51
-rw-r--r--doom3-cdoom.desktop11
-rw-r--r--doom3-cdoom.launcher6
5 files changed, 91 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0079288793d3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = doom3-cdoom
+ pkgdesc = Classic Doom: Doom 1 shareware episode maps recreated for use with Doom 3.
+ pkgver = 1.3.1
+ pkgrel = 1
+ url = http://cdoom.d3files.com/
+ arch = i686
+ license = custom
+ makedepends = unzip
+ depends = doom3
+ source = http://www.slashbunny.com/aur/doom3-cdoom/classic_doom_3_131.zip
+ source = doom3-cdoom.desktop
+ source = doom3-cdoom.launcher
+ md5sums = 7dc67da1a4007e85014de566283d1a41
+ md5sums = fe84fee23843eac65cecdf3e76414184
+ md5sums = bfb9b58d9f2ed85839472848ecfd5a30
+
+pkgname = doom3-cdoom
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..e4f398dc5b3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+src/
+pkg/
+*.pkg.tar.xz
+*.pkg.tar
+*.src.tar.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b06ffa7593ee
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Contributor: Slash <demodevil5 [at] yahoo [dot] com>
+
+pkgname=doom3-cdoom
+pkgver=1.3.1
+pkgrel=1
+pkgdesc="Classic Doom: Doom 1 shareware episode maps recreated for use with Doom 3."
+url="http://cdoom.d3files.com/"
+license=('custom')
+arch=('i686')
+depends=('doom3')
+makedepends=('unzip')
+# Download: http://files.filefront.com/classic+doom+3+131zip/;9003559;/fileinfo.html
+source=('http://www.slashbunny.com/aur/doom3-cdoom/classic_doom_3_131.zip' 'doom3-cdoom.desktop' 'doom3-cdoom.launcher')
+md5sums=('7dc67da1a4007e85014de566283d1a41'
+ 'fe84fee23843eac65cecdf3e76414184'
+ 'bfb9b58d9f2ed85839472848ecfd5a30')
+
+build() {
+ cd $startdir/src
+
+ # Create Destination Directories
+ install -d $startdir/pkg/{usr/bin/,opt/doom3/}
+
+ # Remove Unneeded Files
+ rm $startdir/src/cdoom/{*.url,*.bat}
+
+ # Move Icon
+ mv $startdir/src/cdoom/cdoom.ico $startdir/src/doom3-cdoom.ico
+
+ # Move License
+ mv $startdir/src/cdoom/docs/License.txt $startdir/src/License.txt
+
+ # Move Data to Destination Directory
+ mv $startdir/src/cdoom $startdir/pkg/opt/doom3/
+
+ # Install Launcher (Client)
+ install -D -m 755 $startdir/src/doom3-cdoom.launcher \
+ $startdir/pkg/usr/bin/doom3-cdoom
+
+ # Install License
+ install -D -m 644 $startdir/src/License.txt \
+ $startdir/pkg/usr/share/licenses/$pkgname/License.txt
+
+ # Install Icon
+ install -D -m 644 $startdir/src/doom3-cdoom.ico \
+ $startdir/pkg/usr/share/pixmaps/doom3-cdoom.ico
+
+ # Install Desktop File
+ install -D -m 644 $startdir/src/doom3-cdoom.desktop \
+ $startdir/pkg/usr/share/applications/doom3-cdoom.desktop
+}
diff --git a/doom3-cdoom.desktop b/doom3-cdoom.desktop
new file mode 100644
index 000000000000..d2bc6d47c74a
--- /dev/null
+++ b/doom3-cdoom.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=Doom 3: Classic Doom
+GenericName=Doom 3: Classic Doom
+Comment=Classic Doom mod for Doom 3
+Icon=/usr/share/pixmaps/doom3-cdoom.ico
+Exec=/usr/bin/doom3-cdoom
+Terminal=false
+Type=Application
+Categories=Application;Game
+StartupNotify=false
diff --git a/doom3-cdoom.launcher b/doom3-cdoom.launcher
new file mode 100644
index 000000000000..56bab29ca52b
--- /dev/null
+++ b/doom3-cdoom.launcher
@@ -0,0 +1,6 @@
+#!/bin/sh
+
+cd "/opt/doom3"
+./doom.x86 +set fs_game cdoom +set com_allowConsole 1 $*
+exit $?
+