summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFerdinand Bachmann2021-06-08 13:01:41 +0200
committerFerdinand Bachmann2021-06-08 13:01:41 +0200
commitd00be2d64927ea25e8ca3359f1ea7e3fb1e6396d (patch)
tree4df970d88c66c8bc5cdf4b2f08b4c1d56a2b9ed2
parentc6b487b347ff2364309f03b6760b4826fdb80949 (diff)
downloadaur-d00be2d64927ea25e8ca3359f1ea7e3fb1e6396d.tar.gz
fix color variant glob to search in new location
-rw-r--r--.SRCINFO3
-rw-r--r--PKGBUILD23
2 files changed, 14 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f730044c020f..0d14c40e473d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gtk-theme-numix-solarized-git
pkgdesc = Solarized versions of Numix GTK2 and GTK3 theme, compatible with GTK 3.20
- pkgver = 20200910.b598ade
+ pkgver = 20210524.1181ce0
pkgrel = 1
url = https://github.com/Ferdi265/numix-solarized-gtk-theme
arch = any
@@ -17,4 +17,3 @@ pkgbase = gtk-theme-numix-solarized-git
md5sums = SKIP
pkgname = gtk-theme-numix-solarized-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 6d98ff0ff482..f381068065ef 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: theferdi265 at gmail dot com
pkgname=gtk-theme-numix-solarized-git
-pkgver=20200910.b598ade
+pkgver=20210524.1181ce0
pkgrel=1
pkgdesc="Solarized versions of Numix GTK2 and GTK3 theme, compatible with GTK 3.20"
arch=('any')
@@ -14,17 +14,20 @@ source=('git+https://github.com/Ferdi265/numix-solarized-gtk-theme.git')
md5sums=('SKIP')
pkgver() {
- cd "numix-solarized-gtk-theme"
- local date=$(date --date "$(git show -s --format=%ci)" +%Y%m%d)
- local commit=$(git rev-parse --short HEAD)
- echo $date.$commit
+ cd "numix-solarized-gtk-theme"
+ local date=$(date --date "$(git show -s --format=%ci)" +%Y%m%d)
+ local commit=$(git rev-parse --short HEAD)
+ echo $date.$commit
}
package() {
- cd "numix-solarized-gtk-theme"
- themes=( *.colors )
+ cd "numix-solarized-gtk-theme"
- for theme in ${themes[@]/.colors/}; do
- make -j1 THEME="$theme" DESTDIR="$pkgdir" install
- done
+ pushd colors >/dev/null
+ themes=( *.colors )
+ popd >/dev/null
+
+ for theme in ${themes[@]/.colors/}; do
+ make -j1 THEME="$theme" DESTDIR="$pkgdir" install
+ done
}