summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-06-11 13:20:32 -0600
committerMark Wagie2023-06-11 13:20:32 -0600
commitd0761db7f6645c500b008308507ba31cc72cfa0b (patch)
tree59c9d1893c3b615f768498a3572df2b0fe56c818
parentbc1427fd6e22cef87aa8b5876f1d0a7f7de56b41 (diff)
downloadaur-d0761db7f6645c500b008308507ba31cc72cfa0b.tar.gz
upstream configuration changes
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
-rw-r--r--clight.install2
3 files changed, 25 insertions, 16 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 32961940292c..d629556ddd52 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,12 @@
pkgbase = clight-git
pkgdesc = A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms.
- pkgver = 4.8.r1.g409b255
- pkgrel = 2
+ pkgver = 4.10.r2.gc85b4aa
+ pkgrel = 1
url = https://github.com/FedeDP/Clight
install = clight.install
arch = x86_64
arch = aarch64
- license = GPL
+ license = GPL3
makedepends = git
makedepends = cmake
makedepends = bash-completion
@@ -21,8 +21,17 @@ pkgbase = clight-git
optdepends = clight-gui-git: Clight GUI written in Qt.
provides = clight
conflicts = clight
- backup = etc/default/clight.conf
- source = clight::git+https://github.com/FedeDP/Clight.git
+ backup = etc/clight/clight.conf
+ backup = etc/clight/modules.conf.d/backlight.conf
+ backup = etc/clight/modules.conf.d/daytime.conf
+ backup = etc/clight/modules.conf.d/dimmer.conf
+ backup = etc/clight/modules.conf.d/dpms.conf
+ backup = etc/clight/modules.conf.d/gamma.conf
+ backup = etc/clight/modules.conf.d/inhibit.conf
+ backup = etc/clight/modules.conf.d/keyboard.conf
+ backup = etc/clight/modules.conf.d/screen.conf
+ backup = etc/clight/modules.conf.d/sensor.conf
+ source = git+https://github.com/FedeDP/Clight.git
sha256sums = SKIP
pkgname = clight-git
diff --git a/PKGBUILD b/PKGBUILD
index 48bc01f7d23c..6902ac6649bb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,13 +1,13 @@
# Maintainer: Mark Wagie <mark dot wagie at tutantota dot com>
# Contributor: Federico Di Pierro <nierro92@gmail.com>
pkgname=clight-git
-pkgver=4.8.r1.g409b255
-pkgrel=2
+pkgver=4.10.r2.gc85b4aa
+pkgrel=1
pkgdesc="A C daemon that turns your webcam into a light sensor. It can also change display
gamma temperature, dim your screen and set your dpms."
arch=('x86_64' 'aarch64')
url="https://github.com/FedeDP/Clight"
-license=('GPL')
+license=('GPL3')
depends=('clightd-git' 'gsl' 'hicolor-icon-theme' 'libconfig' 'popt')
makedepends=('git' 'cmake' 'bash-completion')
optdepends=('geoclue: to retrieve user location through geoclue.'
@@ -17,21 +17,21 @@ optdepends=('geoclue: to retrieve user location through geoclue.'
'clight-gui-git: Clight GUI written in Qt.')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
-backup=("etc/default/${pkgname%-git}.conf")
+backup=("etc/${pkgname%-git}/${pkgname%-git}.conf"
+ "etc/${pkgname%-git}/modules.conf.d"/{backlight,daytime,dimmer,dpms,gamma,inhibit,keyboard,screen,sensor}.conf)
install="${pkgname%-git}.install"
-source=("${pkgname%-git}::git+https://github.com/FedeDP/Clight.git")
+source=('git+https://github.com/FedeDP/Clight.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/${pkgname%-git}"
+ cd "$srcdir/Clight"
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cmake -B build -S "${pkgname%-git}" \
- -G "Unix Makefiles" \
- -DCMAKE_BUILD_TYPE=None \
- -DCMAKE_INSTALL_PREFIX=/usr \
+ cmake -B build -S Clight \
+ -DCMAKE_BUILD_TYPE='None' \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
-Wno-dev
cmake --build build
}
diff --git a/clight.install b/clight.install
index e525a677d63e..ef0833a1b58f 100644
--- a/clight.install
+++ b/clight.install
@@ -1,7 +1,7 @@
post_install() {
echo '--> By default, first matching webcam/als device and backlight interface are used.'
echo '--> Therefore, it should work out of the box even without any setup in most cases.'
- echo '--> For any customization, take a look at settings file placed in /etc/default/clight.conf.'
+ echo '--> For any customization, take a look at settings file placed in /etc/clight/clight.conf.'
echo '--> If you are not in a XDG compliant DE, remember to add clight to your autostart script.'
}