summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzxp198210052024-01-25 10:13:39 +0800
committerzxp198210052024-01-25 10:13:39 +0800
commitd0a5f2c8174fc962bf3bc81c4100404fbdedf32b (patch)
tree328c1d35822c9a5b936e35697c12ac8fc655b1cb
parent91b79dd10ab8a8ffa6f0234d9f08c2972732b1bb (diff)
downloadaur-d0a5f2c8174fc962bf3bc81c4100404fbdedf32b.tar.gz
fix errors
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD54
2 files changed, 29 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index adb27fec84bf..fe654cff5907 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,17 @@
pkgbase = mdsilo-bin
- pkgdesc = Local-first, lightweight personal wiki, RSS and podcast client (pre-compiled)
+ pkgdesc = Lightweight Knowledge Base and Feed Reader.
pkgver = 0.5.7
- pkgrel = 2
- url = https://github.com/mdSilo/mdSilo-app
+ pkgrel = 3
+ url = https://mdsilo.com/
arch = x86_64
license = AGPL-3.0-or-later
- depends = cairo
- depends = gcc-libs
- depends = gdk-pixbuf2
- depends = glib2
- depends = glibc
depends = gtk3
depends = hicolor-icon-theme
- depends = libsoup
- depends = openssl
depends = webkit2gtk
- provides = mdsilo
+ depends = libsoup
+ provides = mdsilo=0.5.7
conflicts = mdsilo
- source = https://github.com/mdSilo/mdSilo-app/releases/download/app-v0.5.7/mdsilo_0.5.7_amd64.deb
+ source = mdsilo-0.5.7.deb::https://github.com/mdSilo/mdSilo-app/releases/download/app-v0.5.7/mdsilo_0.5.7_amd64.deb
sha256sums = a70d0fa49072da91a2ddbee28f824620cd9d80d4a267502e7724f4c02175b194
- b2sums = 63eaaf828f2f5befad5dab87238725d92c015b82f37d28f9048f15bac5aa3c0989bf04cf6e9100bb1fd510272fd15af9df580bc21601cc1b159d7a652c6d0ed5
pkgname = mdsilo-bin
diff --git a/PKGBUILD b/PKGBUILD
index 3ec0402ee405..98b85faf137c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,42 +1,34 @@
-# Maintainer: Klaus Alexander Seistrup <klaus@seistrup.dk>
-# -*- sh -*-
-
-pkgname='mdsilo-bin'
-_pkgname="${pkgname%%-bin}"
+# Maintainer: zxp19821005 <zxp19821005 at 163 dot com>
+# Contributor: Klaus Alexander Seistrup <klaus@seistrup.dk>
+pkgname=mdsilo-bin
pkgver=0.5.7
-pkgrel=2
-pkgdesc='Local-first, lightweight personal wiki, RSS and podcast client (pre-compiled)'
+pkgrel=3
+pkgdesc="Lightweight Knowledge Base and Feed Reader."
arch=('x86_64')
-url='https://github.com/mdSilo/mdSilo-app'
+url="https://mdsilo.com/"
+_ghurl="https://github.com/mdSilo/mdSilo-app"
license=('AGPL-3.0-or-later')
+provides=("${pkgname%-bin}=${pkgver}")
+conflicts=("${pkgname%-bin}")
depends=(
- 'cairo'
- 'gcc-libs'
- 'gdk-pixbuf2'
- 'glib2'
- 'glibc'
'gtk3'
'hicolor-icon-theme'
- 'libsoup'
- 'openssl'
'webkit2gtk'
+ 'libsoup'
)
-provides=("$_pkgname")
-conflicts=("$_pkgname")
source=(
- "$url/releases/download/app-v$pkgver/${_pkgname}_${pkgver}_amd64.deb"
+ "${pkgname%-bin}-${pkgver}.deb::${_ghurl}/releases/download/app-v${pkgver}/${pkgname%-bin}_${pkgver}_amd64.deb"
)
-
-package() {
- bsdtar -xf "$srcdir/data.tar.gz" -C "$pkgdir"
- chown -R root:root "$pkgdir/usr"
+sha256sums=('a70d0fa49072da91a2ddbee28f824620cd9d80d4a267502e7724f4c02175b194')
+build() {
+ bsdtar -xf "${srcdir}/data.tar.gz"
+ sed "s|Exec=${pkgname%-bin}|Exec=${pkgname%-bin} %U|g" -i "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop"
}
-
-sha256sums=(
- 'a70d0fa49072da91a2ddbee28f824620cd9d80d4a267502e7724f4c02175b194'
-)
-b2sums=(
- '63eaaf828f2f5befad5dab87238725d92c015b82f37d28f9048f15bac5aa3c0989bf04cf6e9100bb1fd510272fd15af9df580bc21601cc1b159d7a652c6d0ed5'
-)
-
-# eof
+package() {
+ install -Dm755 "${srcdir}/usr/bin/${pkgname%-bin}" -t "${pkgdir}/usr/bin"
+ for _icons in 32x32 128x128 256x256@2;do
+ install -Dm644 "${srcdir}/usr/share/icons/hicolor/${_icons}/apps/${pkgname%-bin}.png" \
+ -t "${pkgdir}/usr/share/icons/hicolor/${_icons%@2}/apps"
+ done
+ install -Dm644 "${srcdir}/usr/share/applications/${pkgname%-bin}.desktop" -t "${pkgdir}/usr/share/applications"
+} \ No newline at end of file