summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBruno Van de Velde2021-11-01 15:50:29 +0100
committerBruno Van de Velde2021-11-01 15:50:29 +0100
commitd0a69f70413acb1172417bd7c2fe7c886adc801c (patch)
tree091abdf347d10ef2108b75f1bdfb8a038ce49af7
parentb3fdf2aa28353b51f0b6b86ceaaba43fe44c5fdf (diff)
downloadaur-d0a69f70413acb1172417bd7c2fe7c886adc801c.tar.gz
Updated branch to 0.10 and build all backends instead of only SFML
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD24
2 files changed, 25 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d4452f4e7e7b..10e580274587 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = tgui-git
- pkgdesc = Cross-platform C++ GUI library for SFML
- pkgver = v0.9.1.r0.g588362edc
+ pkgdesc = Cross-platform modern c++ GUI library
+ pkgver = nightly_build.r0.g6ef550515
pkgrel = 1
url = https://tgui.eu/
arch = i686
@@ -10,10 +10,13 @@ pkgbase = tgui-git
makedepends = doxygen
makedepends = git
depends = sfml
+ depends = sdl2
+ depends = sdl2_ttf
+ depends = glfw-x11
+ depends = freetype2
provides = tgui
conflicts = tgui
- source = git+https://github.com/texus/TGUI.git#branch=0.9
+ source = git+https://github.com/texus/TGUI.git#branch=0.10
sha256sums = SKIP
pkgname = tgui-git
-
diff --git a/PKGBUILD b/PKGBUILD
index c2dcdef4ceb0..faf89886362e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,19 @@
# Maintainer: Bruno Van de Velde <bruno@texus.me>
pkgname=tgui-git
-pkgver=v0.9.1.r0.g588362edc
+pkgver=nightly_build.r0.g6ef550515
pkgrel=1
-pkgdesc="Cross-platform C++ GUI library for SFML"
+pkgdesc="Cross-platform modern c++ GUI library"
arch=('i686' 'x86_64')
url="https://tgui.eu/"
license=('ZLIB')
-depends=('sfml')
+depends=('sfml' 'sdl2' 'sdl2_ttf' 'glfw-x11' 'freetype2')
makedepends=('cmake' 'doxygen' 'git')
provides=('tgui')
conflicts=('tgui')
replaces=()
-source=("git+https://github.com/texus/TGUI.git#branch=0.9")
+source=("git+https://github.com/texus/TGUI.git#branch=0.10")
sha256sums=('SKIP')
pkgver() {
@@ -25,8 +25,20 @@ build() {
cd "$srcdir/TGUI"
cmake -DCMAKE_INSTALL_PREFIX=/usr . \
-DCMAKE_BUILD_TYPE=RelWithDebugInfo \
- -DCMAKE_BUILD_WITH_INSTALL_RPATH=TRUE \
- -DTGUI_BUILD_DOC=true
+ -DCMAKE_BUILD_WITH_INSTALL_RPATH=ON \
+ -DTGUI_CXX_STANDARD=17 \
+ -DTGUI_BUILD_DOC=ON \
+ -DTGUI_BUILD_GUI_BUILDER=ON \
+ -DTGUI_BACKEND=Custom \
+ -DTGUI_HAS_BACKEND_SFML_GRAPHICS=ON \
+ -DTGUI_HAS_BACKEND_SFML_OPENGL3=ON \
+ -DTGUI_HAS_BACKEND_SDL_RENDERER=ON \
+ -DTGUI_HAS_BACKEND_SDL_OPENGL3=ON \
+ -DTGUI_HAS_BACKEND_SDL_GLES2=ON \
+ -DTGUI_HAS_BACKEND_SDL_TTF_OPENGL3=ON \
+ -DTGUI_HAS_BACKEND_SDL_TTF_GLES2=ON \
+ -DTGUI_HAS_BACKEND_GLFW_OPENGL3=ON \
+ -DTGUI_HAS_BACKEND_GLFW_GLES2=ON
make
}