summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12017-08-22 23:11:56 +0800
committerChocobo12017-08-22 23:43:37 +0800
commitd0a9eac25b8eeb0346e1a3a07f98c46e93764751 (patch)
tree7705c2303c7db09e716e4d14d1876cc061d15702
downloadaur-d0a9eac25b8eeb0346e1a3a07f98c46e93764751.tar.gz
newpkg: libshout-git 2.4.1.r22.g2dd6cfb-1
-rw-r--r--.SRCINFO24
-rw-r--r--0001-Fix-build-with-newer-openssl.patch25
-rw-r--r--PKGBUILD57
3 files changed, 106 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..687a26df7cbe
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = libshout-git
+ pkgdesc = Library for accessing a shoutcast/icecast server
+ pkgver = 2.4.1.r22.g2dd6cfb
+ pkgrel = 1
+ url = https://libshout.freedesktop.org/wiki/
+ arch = i686
+ arch = x86_64
+ license = GPL2
+ makedepends = git
+ depends = glibc
+ depends = openssl
+ depends = libtheora
+ depends = libvorbis
+ depends = speex
+ provides = libshout
+ conflicts = libshout
+ options = staticlibs
+ source = git+https://git.xiph.org/icecast-libshout.git
+ source = 0001-Fix-build-with-newer-openssl.patch
+ sha256sums = SKIP
+ sha256sums = 742f1954c21ed5f8344dc1514507c981f445be0a7d4bdd2adaa73b0464f37a75
+
+pkgname = libshout-git
+
diff --git a/0001-Fix-build-with-newer-openssl.patch b/0001-Fix-build-with-newer-openssl.patch
new file mode 100644
index 000000000000..be437f6a0864
--- /dev/null
+++ b/0001-Fix-build-with-newer-openssl.patch
@@ -0,0 +1,25 @@
+From cafc074bc9632712e100a8f9fc76746a1191b716 Mon Sep 17 00:00:00 2001
+From: Chocobo1 <Chocobo1@users.noreply.github.com>
+Date: Tue, 22 Aug 2017 23:39:18 +0800
+Subject: [PATCH] Fix build with newer openssl
+
+---
+ src/tls.c | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/tls.c b/src/tls.c
+index d1af607..5a6b7c4 100644
+--- a/src/tls.c
++++ b/src/tls.c
+@@ -65,7 +65,7 @@ static inline int tls_setup(shout_tls_t *tls)
+
+ SSL_library_init();
+ SSL_load_error_strings();
+- SSLeay_add_all_algorithms();
++ OpenSSL_add_all_algorithms();
+ SSLeay_add_ssl_algorithms();
+
+ meth = TLSv1_client_method();
+--
+2.14.1
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..bb1309376ec3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,57 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=libshout-git
+pkgver=2.4.1.r22.g2dd6cfb
+pkgrel=1
+pkgdesc="Library for accessing a shoutcast/icecast server"
+arch=('i686' 'x86_64')
+url="https://libshout.freedesktop.org/wiki/"
+license=('GPL2')
+depends=('glibc' 'openssl' 'libtheora' 'libvorbis' 'speex' )
+makedepends=('git')
+provides=('libshout')
+conflicts=('libshout')
+options=('staticlibs')
+source=("git+https://git.xiph.org/icecast-libshout.git"
+ "0001-Fix-build-with-newer-openssl.patch")
+sha256sums=('SKIP'
+ '742f1954c21ed5f8344dc1514507c981f445be0a7d4bdd2adaa73b0464f37a75')
+
+
+prepare() {
+ cd "icecast-libshout"
+
+ sed -i 's|url = \.\.|url = https://git.xiph.org|' ".gitmodules"
+ git submodule sync
+ git submodule update --init --recursive
+
+ patch -Np1 -i "$srcdir/0001-Fix-build-with-newer-openssl.patch"
+}
+
+pkgver() {
+ cd "icecast-libshout"
+
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ cd "icecast-libshout"
+
+ ./autogen.sh
+ ./configure --prefix="/usr"
+ make
+}
+
+check() {
+ cd "icecast-libshout"
+
+ make check
+}
+
+package() {
+ cd "icecast-libshout"
+
+ make DESTDIR="$pkgdir" install
+
+ rm "$pkgdir/usr/share/doc/libshout/COPYING"
+}