summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTimothy Rice2015-06-24 04:19:54 +1000
committerTimothy Rice2015-06-24 04:19:54 +1000
commitd0b120c60a94b0f4a215e9225c314754624fca09 (patch)
treebbe419572c7cbc3c661eec616ac935cb9d1f935b
downloadaur-d0b120c60a94b0f4a215e9225c314754624fca09.tar.gz
Initial import.
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore5
-rw-r--r--PKGBUILD30
3 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..14ff2debafb5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = satanic-icon-themes
+ pkgdesc = Icons from Ubuntu Satanic Edition.
+ pkgver = 666.9
+ pkgrel = 1
+ url = http://www.ubuntusatanic.org
+ arch = any
+ license = GPL
+ source = http://www.ubuntusatanic.org/hell/pool/main/s/satanic-icon-themes/satanic-icon-themes_666.9_all.deb
+ md5sums = da67063378ed26a966c6f364e56a1f63
+
+pkgname = satanic-icon-themes
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..9ebe54cdf518
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+satanic-icon-themes-*.tar.*
+satanic-icon-themes*.deb
+*.swp
+src/
+pkg/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..626db9f3bd5f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Tim Rice < t [dot] rice [at] ms [dot] unimelb [dot] edu [dot] au>
+pkgname=satanic-icon-themes
+pkgver=666.9
+pkgrel=1
+pkgdesc="Icons from Ubuntu Satanic Edition."
+url="http://www.ubuntusatanic.org"
+arch=('any')
+license=('GPL')
+depends=()
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=("$url/hell/pool/main/s/${pkgname}/${pkgname}_${pkgver}_all.deb")
+md5sums=('da67063378ed26a966c6f364e56a1f63')
+
+build() {
+ msg "Extracting ... "
+ ar xv ${pkgname}_${pkgver}_all.deb || return 1
+ tar xvf data.tar.gz || return 1
+ msg2 "Done extracting."
+}
+
+package() {
+ msg "Moving files ... "
+ mv $srcdir/usr $pkgdir || return 1
+ msg2 "Done moving files."
+}
+