summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBryan Gilbert2017-04-07 11:54:08 -0400
committerBryan Gilbert2017-04-07 11:54:08 -0400
commitd0babf929ba4f116a00f171b3cf5a498275c5661 (patch)
tree49542f6d1e026695b4d3140456186f4eda8543e3
downloadaur-d0babf929ba4f116a00f171b3cf5a498275c5661.tar.gz
Initial add of collate-notes package
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD28
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a4a6c80f7a11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = collate-notes
+ pkgdesc = A flexible, locally hosted, cross-platform note-taking application
+ pkgver = 0.2.3
+ pkgrel = 1
+ url = https://collatenotes.com
+ arch = x86_64
+ license = Commercial
+ source = https://s3.amazonaws.com/collate/0.2.3/linux/Collate_0.2.3_amd64.deb
+ sha256sums = 4fba82232ca6fc2ed8f61207b71b0c512cd2c32edac5432dc77131b3da3c4db1
+
+pkgname = collate-notes
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d55f53121448
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,28 @@
+# Maintainer: Bryan Gilbert <gilbertw1 at gmail dot com>
+pkgname=collate-notes
+pkgver=0.2.3
+pkgrel=1
+pkgdesc="A flexible, locally hosted, cross-platform note-taking application"
+arch=('x86_64')
+url="https://collatenotes.com"
+license=('Commercial')
+depends=()
+source=("https://s3.amazonaws.com/collate/0.2.3/linux/Collate_0.2.3_amd64.deb")
+sha256sums=('4fba82232ca6fc2ed8f61207b71b0c512cd2c32edac5432dc77131b3da3c4db1')
+
+package() {
+ # Extract the core package
+ tar -xf data.tar.xz -C "${pkgdir}"
+
+ # Setup usr folder
+ chmod -R go-w ${pkgdir}/usr
+ mkdir -p ${pkgdir}/usr/bin
+
+ # Setup the start script and permissions
+ ln -s /opt/Collate/collate ${pkgdir}/usr/bin/collate
+
+ install -d ${pkgdir}/usr/share/applications
+ install -d ${pkgdir}/usr/share/icons
+ install -d ${pkgdir}/usr/share/doc
+ install -d ${pkgdir}/opt/Collate
+}