summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraysky2021-11-30 06:44:16 -0500
committergraysky2021-11-30 06:44:16 -0500
commitd0bb80606749dbf31acf33d31335ecbd1d99376d (patch)
treea6131ed473640bb4115c23701c522a5531b59b6c
parent0d046c9fd6b1629cde6f713e497ae9054740b03e (diff)
downloadaur-d0bb80606749dbf31acf33d31335ecbd1d99376d.tar.gz
Update to 307b9-1
-rw-r--r--.SRCINFO12
-rw-r--r--0001-makefile-fix-build-for-Arch-Linux.patch37
-rw-r--r--PKGBUILD25
-rw-r--r--unfuck_makefile.patch25
4 files changed, 54 insertions, 45 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 081850e49f0e..016f181639ce 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,17 @@
pkgbase = mprime
pkgdesc = A GIMPS, distributed computing project client, dedicated to finding Mersenne primes.
- pkgver = 303b6
+ pkgver = 307b9
pkgrel = 1
url = http://www.mersenne.org
arch = x86_64
license = custom
depends = curl
depends = hwloc
+ depends = boost
conflicts = mprime-bin
- source = http://www.mersenne.org/ftp_root/gimps/p95v303b6.source.zip
- source = unfuck_makefile.patch
- b2sums = c501308cd06f1cb66dd252cced4206ef5338b695d9fc571ea37d19bd23e2ca677c4fdd4f8f94fa5338ba4aee34b051b722d8d8653cfb758ea8354334f5c4653b
- b2sums = d948f4249bcad1d70a156cfa9dcbaf79f035aa41b86337932c79a03f9c30954ac8b21cd627b54ab18e8b7855dc2549eb377cccc3d8060e25df7bceba0c672e38
+ source = http://www.mersenne.org/ftp_root/gimps/p95v307b9.source.zip
+ source = 0001-makefile-fix-build-for-Arch-Linux.patch
+ b2sums = 0902ffb2263fc1da4f4dd17daceaeff211370e3552b9d5d411721fa3d567c36b822cccda85a10262ca5ca162f83066574a45ab2ec7c6277f63d2099c8cc5d85a
+ b2sums = e80b00415ae4dddc03213ddacdb37161984a9c07be2e2a0ed6210c2f9cbe293c74f74c39a1ea81a15d2db502654fbf174cf5adf5839dfba98d8e2c4669d8d814
pkgname = mprime
-
diff --git a/0001-makefile-fix-build-for-Arch-Linux.patch b/0001-makefile-fix-build-for-Arch-Linux.patch
new file mode 100644
index 000000000000..1c141b85ba73
--- /dev/null
+++ b/0001-makefile-fix-build-for-Arch-Linux.patch
@@ -0,0 +1,37 @@
+From 3ee9ae9b0c8efdb356e53a7d36373e906de02f9d Mon Sep 17 00:00:00 2001
+From: graysky <graysky@archlinux.us>
+Date: Tue, 30 Nov 2021 06:27:15 -0500
+Subject: [PATCH] makefile: fix build for Arch Linux
+
+---
+ linux64/makefile | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/linux64/makefile b/linux64/makefile
+index f73ba4f..4ba2517 100644
+--- a/linux64/makefile
++++ b/linux64/makefile
+@@ -18,15 +18,17 @@
+ # LFLAGS = -Wl,-M
+ # LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libhwloc) -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
+
++MPRIME_FLAGS= -I.. -I../gwnum -DX86_64 -O2 -Wno-unused-result -march=x86-64 -DPORT=8
++
+ CC = gcc
+-CFLAGS = -I.. -I../gwnum -I/usr/local/include -std=gnu99 -DX86_64 -Wno-unused-result -O2 -DPORT=8
++CFLAGS = ${MPRIME_FLAGS} -std=gnu99
+
+ CPP = g++
+-CPPFLAGS = -I.. -I../gwnum -I../../boost_1_76_0 -DX86_64 -std=c++11 -O2 -DPORT=8
++CPPFLAGS = ${MPRIME_FLAGS} -std=c++11
+
+ LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
+ #LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
+-LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
++LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc) -lgmp
+
+ FACTOROBJ = factor64.o
+ LINUXOBJS = prime.o menu.o cJSON.o ecm.o pair.o pm1prob.o
+--
+2.34.1
+
diff --git a/PKGBUILD b/PKGBUILD
index 48d6b4a9537f..0153436d8606 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,21 +3,21 @@
# Contributer: TryA - https://bbs.archlinux.org/viewtopic.php?id=114996
pkgname=mprime
-pkgver=303b6
+pkgver=307b9
pkgrel=1
pkgdesc="A GIMPS, distributed computing project client, dedicated to finding Mersenne primes."
-arch=('x86_64')
+arch=(x86_64)
url="http://www.mersenne.org"
license=('custom')
-depends=('curl' 'hwloc')
-conflicts=('mprime-bin')
+depends=(curl hwloc boost)
+conflicts=(mprime-bin)
source=("http://www.mersenne.org/ftp_root/gimps/p95v${pkgver}.source.zip"
-unfuck_makefile.patch)
-b2sums=('c501308cd06f1cb66dd252cced4206ef5338b695d9fc571ea37d19bd23e2ca677c4fdd4f8f94fa5338ba4aee34b051b722d8d8653cfb758ea8354334f5c4653b'
- 'd948f4249bcad1d70a156cfa9dcbaf79f035aa41b86337932c79a03f9c30954ac8b21cd627b54ab18e8b7855dc2549eb377cccc3d8060e25df7bceba0c672e38')
+0001-makefile-fix-build-for-Arch-Linux.patch)
+b2sums=('0902ffb2263fc1da4f4dd17daceaeff211370e3552b9d5d411721fa3d567c36b822cccda85a10262ca5ca162f83066574a45ab2ec7c6277f63d2099c8cc5d85a'
+ 'e80b00415ae4dddc03213ddacdb37161984a9c07be2e2a0ed6210c2f9cbe293c74f74c39a1ea81a15d2db502654fbf174cf5adf5839dfba98d8e2c4669d8d814')
prepare () {
- patch -Np1 -i unfuck_makefile.patch
+ patch -Np1 -i 0001-makefile-fix-build-for-Arch-Linux.patch
}
build() {
@@ -32,10 +32,7 @@ package() {
install -Dm755 linux64/mprime "$pkgdir/usr/bin/mprime"
# license and documentation
- # x86_64 tarball for 279 includes none of these
- #install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/license.txt"
- #install -Dm644 readme.txt "$pkgdir/usr/share/doc/$pkgname/readme.txt"
- #install -Dm644 stress.txt "$pkgdir/usr/share/doc/$pkgname/stress.txt"
- #install -Dm644 undoc.txt "$pkgdir/usr/share/doc/$pkgname/undoc.txt"
- #install -Dm644 whatsnew.txt "$pkgdir/usr/share/doc/$pkgname/whatsnew.txt"
+ install -Dm644 gwnum/readme.txt "$pkgdir/usr/share/doc/$pkgname/readme.txt"
+ install -Dm644 gwnum/tutorial.txt "$pkgdir/usr/share/doc/$pkgname/tutorial.txt"
+ cp -r prime95/hlp "$pkgdir/usr/share/doc/$pkgname"
}
diff --git a/unfuck_makefile.patch b/unfuck_makefile.patch
deleted file mode 100644
index ce270c31beb6..000000000000
--- a/unfuck_makefile.patch
+++ /dev/null
@@ -1,25 +0,0 @@
---- a/linux64/makefile 2020-08-10 20:33:02.000000000 -0400
-+++ b/linux64/makefile 2020-08-11 07:07:32.836699309 -0400
-@@ -20,15 +20,20 @@
- # LFLAGS = -Wl,-M
- # LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic $(shell pkg-config --static --libs libhwloc) -Wl,-Bstatic $(shell pkg-config --static --libs libcurl) -lstdc++ -Wl,-Bdynamic -ldl
-
-+MPRIME_FLAGS= -I.. -I../gwnum -DX86_64 -O2 -Wno-unused-result -march=x86-64
-+
- CC = gcc
--CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -Wno-unused-result -O2
-+#CFLAGS = -I.. -I../gwnum -I/usr/local/include -DX86_64 -Wno-unused-result -O2
-+CFLAGS = ${MPRIME_FLAGS}
-
- CPP = g++
--CPPFLAGS = -I.. -I../gwnum -DX86_64 -O2
-+#CPPFLAGS = -I.. -I../gwnum -DX86_64 -O2
-+CPPFLAGS = ${MPRIME_FLAGS}
-
- LFLAGS = -Wl,-M -Wl,-L/usr/local/lib
- LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -lz -lxml2 -ldl -lgmp
- #LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread -Wl,-Bstatic -lhwloc -Wl,-Bstatic -lcurl -Wl,-Bdynamic -lrt -lstdc++ -ldl -lgmp
-+LIBS = ../gwnum/gwnum.a ../gwnum/gwnum.ld -lm -lpthread $(shell pkg-config --libs libcurl) -lstdc++ $(shell pkg-config --static --libs hwloc) -lgmp
-
- FACTOROBJ = factor64.o
- LINUXOBJS = prime.o menu.o