summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSukanka2022-06-06 21:27:04 +0800
committerSukanka2022-06-06 21:27:04 +0800
commitd0bf0e8d6e281ca75bf88dbfa7602bf6d708f7b9 (patch)
tree6a6d36ad9268f475cea5e0e75b833427cdf208d9
downloadaur-d0bf0e8d6e281ca75bf88dbfa7602bf6d708f7b9.tar.gz
add r-rpref
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD40
2 files changed, 63 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..998eda4a3c2e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = r-rpref
+ pkgdesc = Database Preferences and Skyline Computation
+ pkgver = 1.3
+ pkgrel = 4
+ url = https://cran.r-project.org/package=rPref
+ arch = x86_64
+ license = GPL
+ depends = r
+ depends = r-dplyr
+ depends = r-igraph
+ depends = r-lazyeval
+ depends = r-rcpp
+ depends = r-rcppparallel
+ optdepends = r-ggplot2
+ optdepends = r-graph
+ optdepends = r-knitr
+ optdepends = r-rgraphviz
+ optdepends = r-rmarkdown
+ optdepends = r-testthat
+ source = https://cran.r-project.org/src/contrib/rPref_1.3.tar.gz
+ sha256sums = de285d93cd979fcbec5f372303de64d06c8e8611dc495d02e0cf74e160879f6e
+
+pkgname = r-rpref
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..efd0bc42dd10
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# system requirements: C++11, GNU make, Windows: cmd.exe and cscript.exe
+# Maintainer: Guoyi Zhang <guoyizhang at malacology dot net>
+
+_pkgname=rPref
+_pkgver=1.3
+pkgname=r-${_pkgname,,}
+pkgver=1.3
+pkgrel=4
+pkgdesc='Database Preferences and Skyline Computation'
+arch=('x86_64')
+url="https://cran.r-project.org/package=${_pkgname}"
+license=('GPL')
+depends=(
+ r
+ r-dplyr
+ r-igraph
+ r-lazyeval
+ r-rcpp
+ r-rcppparallel
+)
+optdepends=(
+ r-ggplot2
+ r-graph
+ r-knitr
+ r-rgraphviz
+ r-rmarkdown
+ r-testthat
+)
+source=("https://cran.r-project.org/src/contrib/${_pkgname}_${_pkgver}.tar.gz")
+sha256sums=('de285d93cd979fcbec5f372303de64d06c8e8611dc495d02e0cf74e160879f6e')
+
+build() {
+ R CMD INSTALL ${_pkgname}_${_pkgver}.tar.gz -l "${srcdir}"
+}
+
+package() {
+ install -dm0755 "${pkgdir}/usr/lib/R/library"
+ cp -a --no-preserve=ownership "${_pkgname}" "${pkgdir}/usr/lib/R/library"
+}
+# vim:set ts=2 sw=2 et: