summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluigoalma2019-04-18 03:00:15 +0100
committerluigoalma2019-04-18 03:00:15 +0100
commitd0bf92a7f3001f5f5570038d5080e5888cdaa87e (patch)
tree1e07e5f74cb3b3bdbdf8eea622fd77495891868c
downloadaur-d0bf92a7f3001f5f5570038d5080e5888cdaa87e.tar.gz
Ninfs 1.4
-rw-r--r--.SRCINFO29
-rw-r--r--.gitignore8
-rw-r--r--NinFSGUI.install6
-rw-r--r--PKGBUILD44
4 files changed, 87 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..baf4ea71f7ed
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,29 @@
+pkgbase = ninfs-git
+ pkgdesc = FUSE filesystem Python scripts for Nintendo console files
+ pkgver = 1.4.r0.g996fe4c
+ pkgrel = 1
+ url = https://github.com/ihaveamac/ninfs
+ arch = x86_64
+ license = MIT
+ makedepends = python-setuptools
+ makedepends = python-pycryptodomex
+ makedepends = git
+ options = !strip
+ source = ninfs::git+https://github.com/ihaveamac/ninfs.git
+ sha256sums = SKIP
+
+pkgname = ninfs-git
+ depends = python>=3.6.1
+ depends = python-pycryptodomex
+ depends = fuse2
+ depends = openssl>=1.1
+ provides = ninfs=1.4.r0.g996fe4c-1
+ conflicts = ninfs
+
+pkgname = ninfs-gui-git
+ install = NinFSGUI.install
+ depends = ninfs-git=1.4.r0.g996fe4c-1
+ depends = python-appjar
+ provides = ninfs-gui=1.4.r0.g996fe4c-1
+ conflicts = ninfs-gui
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..527f39f2e63d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+*
+*/
+
+!PKGBUILD
+!.SRCINFO
+!.gitignore
+!*.install
+
diff --git a/NinFSGUI.install b/NinFSGUI.install
new file mode 100644
index 000000000000..07afb2ebbafb
--- /dev/null
+++ b/NinFSGUI.install
@@ -0,0 +1,6 @@
+post_upgrade() {
+ echo " >> You'll need the respective terminal for your DE for gui to open."
+ echo " >> Mate for example uses xterm to open a terminal=true set .desktop."
+ echo " >> XFCE uses xfce4-terminal."
+ echo " >> Check what does your respective DE uses and install it."
+}
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b0ebdcf397d0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,44 @@
+pkgbase=ninfs-git
+pkgname=(ninfs-git ninfs-gui-git)
+pkgver=1.4.r0.g996fe4c
+pkgrel=1
+pkgdesc="FUSE filesystem Python scripts for Nintendo console files"
+arch=($CARCH)
+license=(MIT)
+url='https://github.com/ihaveamac/ninfs'
+makedepends=('python-setuptools' 'python-pycryptodomex' 'git')
+options=(!strip)
+source=("ninfs::git+${url}.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd ninfs
+ git describe --long --tags | sed 's/^v//;s/-/.r/;s/-/./g'
+}
+
+build() {
+ cd "${srcdir}/ninfs"
+ python setup.py build
+}
+
+package_ninfs-git() {
+ depends=("python>=3.6.1" "python-pycryptodomex" "fuse2" "openssl>=1.1")
+ conflicts=(ninfs)
+ provides=("ninfs=$pkgver-$pkgrel")
+ cd "${srcdir}/ninfs"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ rm -f "$pkgdir/usr/bin/ninfs"
+ rm -rf "$pkgdir/usr/share"
+}
+
+package_ninfs-gui-git() {
+ depends=("ninfs-git=$pkgver-$pkgrel" "python-appjar")
+ conflicts=(ninfs-gui)
+ provides=("ninfs-gui=$pkgver-$pkgrel")
+ install="NinFSGUI.install"
+ cd "${srcdir}/ninfs"
+ python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
+ rm -f "$pkgdir/usr/bin/mount_"*
+ rm -rf "$pkgdir/usr/lib"
+ PYTHONPATH="$pkgdir/usr:$PYTHONPATH" python -mninfs --install-desktop-entry "$pkgdir/usr/share"
+}