summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorS Garnica2020-06-09 10:44:20 +0200
committerS Garnica2020-06-09 10:44:20 +0200
commitd0e54112989292b109fd6c7e524d3b447bcf74c6 (patch)
treeca0134f5ede0976999c0a07142c831eb5406a9d3
parent2b720e88df2ac5436739221a401c9c91210e7cfd (diff)
downloadaur-d0e54112989292b109fd6c7e524d3b447bcf74c6.tar.gz
Updated patch
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD4
-rw-r--r--requirements.patch14
3 files changed, 11 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc28e00da045..2fac20504c2f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = esphomeyaml
pkgdesc = Solution for your ESP8266/ESP32 projects with Home Assistant
pkgver = 1.14.4
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/esphome/ESPHome
arch = any
license = MIT
@@ -23,7 +23,7 @@ pkgbase = esphomeyaml
source = https://github.com/esphome/ESPHome/archive/v1.14.4.tar.gz
source = requirements.patch
sha256sums = 78c78c3a5172c0885ebf0fc802c309b7bcdf5f051ec60b727fda1dcd3076aa5c
- sha256sums = 46f3a4fa26ee9a114897e9a69a348ff0b479a11580bfcf8a69ca97593ac8c835
+ sha256sums = ab711b1e1ad83cf3415d1d925a4b17500b48bcf0d16ba25c7998d6cd70c6acc7
pkgname = esphome
diff --git a/PKGBUILD b/PKGBUILD
index 3ee073debc71..9d51ae631553 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgbase=esphomeyaml
pkgname=esphome
pkgver=1.14.4
-pkgrel=1
+pkgrel=2
pkgdesc="Solution for your ESP8266/ESP32 projects with Home Assistant"
url="https://github.com/esphome/ESPHome"
depends=('python-setuptools'
@@ -26,7 +26,7 @@ replaces=('esphomeyaml')
source=("https://github.com/esphome/ESPHome/archive/v${pkgver}.tar.gz"
"requirements.patch")
sha256sums=('78c78c3a5172c0885ebf0fc802c309b7bcdf5f051ec60b727fda1dcd3076aa5c'
- '46f3a4fa26ee9a114897e9a69a348ff0b479a11580bfcf8a69ca97593ac8c835')
+ 'ab711b1e1ad83cf3415d1d925a4b17500b48bcf0d16ba25c7998d6cd70c6acc7')
prepare() {
cd "$srcdir/${pkgname}-${pkgver}"
diff --git a/requirements.patch b/requirements.patch
index cad2e45d8390..8e25bbd22881 100644
--- a/requirements.patch
+++ b/requirements.patch
@@ -6,9 +6,9 @@ diff --unified --recursive --text package.orig/setup.py package.new/setup.py
REQUIRES = [
- 'voluptuous==0.11.7',
-- 'PyYAML==5.1.2',
-- 'paho-mqtt==1.4.0',
-- 'colorlog==4.0.2',
+- 'PyYAML==5.3.1',
+- 'paho-mqtt==1.5.0',
+- 'colorlog==4.1.0',
- 'tornado==5.1.1',
+ 'voluptuous',
+ 'PyYAML',
@@ -16,9 +16,9 @@ diff --unified --recursive --text package.orig/setup.py package.new/setup.py
+ 'colorlog',
+ 'tornado',
'typing>=3.6.6;python_version<"3.6"',
-- 'protobuf==3.10.0',
+- 'protobuf==3.11.3',
- 'tzlocal==2.0.0',
-- 'pytz==2019.3',
+- 'pytz==2020.1',
- 'pyserial==3.4',
- 'ifaddr==0.1.6',
+ 'protobuf',
@@ -33,8 +33,8 @@ diff --unified --recursive --text package.orig/setup.py package.new/setup.py
# This means they have to be in your $PATH.
if os.environ.get('ESPHOME_USE_SUBPROCESS') is None:
REQUIRES.extend([
-- 'platformio==4.0.3',
-- 'esptool==2.7',
+- 'platformio==4.3.4',
+- 'esptool==2.8',
+ 'platformio',
+ 'esptool',
])