summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFabioLolix2021-03-21 12:58:31 +0100
committerFabioLolix2021-03-21 12:58:31 +0100
commitd0e8250ea02d76d01fe4a0ff3d5554d34550c06e (patch)
tree6fe5569efddc565260ed340259feb0d85c1fa470
parent29ad77c2c6a63428e71f29bde43002894debaa79 (diff)
downloadaur-d0e8250ea02d76d01fe4a0ff3d5554d34550c06e.tar.gz
update url
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD52
2 files changed, 35 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0ce742805f28..fd78376a26fa 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = inxi-perl-git
pkgdesc = Pinxi, development branch of inxi, a full featured CLI system information tool
- pkgver = r3858.7dff6f09
+ pkgver = r4153.fe6666c6
pkgrel = 2
- url = https://github.com/smxi/inxi
+ url = https://smxi.org/docs/inxi.htm
arch = any
license = GPL3
makedepends = git
@@ -10,12 +10,15 @@ pkgbase = inxi-perl-git
depends = pciutils
depends = perl
depends = procps-ng
+ optdepends = bluez-tools: bt-adapter: -E bluetooth data (if no hciconfig)
optdepends = bluez-utils-compat: hciconfig: -E bluetooth HCI data
- optdepends = bind-tools: -i wlan IP
+ optdepends = bind: -i wlan IP
optdepends = dmidecode: inxi -M if no sys machine data
optdepends = file: inxi -o unmounted file system
+ optdepends = freeipmi: ipmi-sensors: -s IPMI sensors
optdepends = hddtemp: inxi -Dx show hdd temp
optdepends = iproute2: inxi -i ip lan
+ optdepends = ipmitool: -s IPMI sensors
optdepends = kmod: inxi -Ax,-Nx module version
optdepends = lm_sensors: inxi -s sensors output
optdepends = mesa-demos: inxi -G glx info
@@ -27,6 +30,7 @@ pkgbase = inxi-perl-git
optdepends = systemd-sysvcompat: inxi -I runlevel
optdepends = sudo: inxi -Dx hddtemp-user;-o file-user
optdepends = tree: --debugger 20,21 /sys tree
+ optdepends = upower: -sx attached device battery info
optdepends = usbutils: inxi -A usb audio;-N usb networking
optdepends = wmctrl: -S active window manager (not all wm)
optdepends = xorg-xdpyinfo: inxi -G multi screen resolution
diff --git a/PKGBUILD b/PKGBUILD
index 3f304a388a1a..2ee8174fda09 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,37 +2,41 @@
# Contributor: FadeMind <fademind@gmail.com>
pkgname=inxi-perl-git
-pkgver=r3858.7dff6f09
+pkgver=r4153.fe6666c6
pkgrel=2
pkgdesc="Pinxi, development branch of inxi, a full featured CLI system information tool"
arch=(any)
-url="https://github.com/smxi/inxi"
+url="https://smxi.org/docs/inxi.htm"
license=(GPL3)
depends=(coreutils pciutils perl procps-ng)
makedepends=(git)
optdepends=(
- "bluez-utils-compat: hciconfig: -E bluetooth HCI data"
- "bind-tools: -i wlan IP"
- "dmidecode: inxi -M if no sys machine data"
- "file: inxi -o unmounted file system"
- "hddtemp: inxi -Dx show hdd temp"
- "iproute2: inxi -i ip lan"
- "kmod: inxi -Ax,-Nx module version"
- "lm_sensors: inxi -s sensors output"
- "mesa-demos: inxi -G glx info"
- "net-tools: inxi -i ip lan-deprecated"
- "perl-io-socket-ssl: -U; -w,-W; -i (if dig not installed)"
- "perl-cpanel-json-xs: --output json - required for export"
- "perl-json-xs: --output json - required for export (legacy)"
- "perl-xml-dumper: --output xml - Crude and raw"
- "systemd-sysvcompat: inxi -I runlevel"
- "sudo: inxi -Dx hddtemp-user;-o file-user"
- "tree: --debugger 20,21 /sys tree"
- "usbutils: inxi -A usb audio;-N usb networking"
- "wmctrl: -S active window manager (not all wm)"
- "xorg-xdpyinfo: inxi -G multi screen resolution"
- "xorg-xprop: inxi -S desktop data"
- "xorg-xrandr: inxi -G single screen resolution"
+ "bluez-tools: bt-adapter: -E bluetooth data (if no hciconfig)"
+ "bluez-utils-compat: hciconfig: -E bluetooth HCI data"
+ "bind: -i wlan IP"
+ "dmidecode: inxi -M if no sys machine data"
+ "file: inxi -o unmounted file system"
+ "freeipmi: ipmi-sensors: -s IPMI sensors"
+ "hddtemp: inxi -Dx show hdd temp"
+ "iproute2: inxi -i ip lan"
+ "ipmitool: -s IPMI sensors"
+ "kmod: inxi -Ax,-Nx module version"
+ "lm_sensors: inxi -s sensors output"
+ "mesa-demos: inxi -G glx info"
+ "net-tools: inxi -i ip lan-deprecated"
+ "perl-io-socket-ssl: -U; -w,-W; -i (if dig not installed)"
+ "perl-cpanel-json-xs: --output json - required for export"
+ "perl-json-xs: --output json - required for export (legacy)"
+ "perl-xml-dumper: --output xml - Crude and raw"
+ "systemd-sysvcompat: inxi -I runlevel"
+ "sudo: inxi -Dx hddtemp-user;-o file-user"
+ "tree: --debugger 20,21 /sys tree"
+ "upower: -sx attached device battery info"
+ "usbutils: inxi -A usb audio;-N usb networking"
+ "wmctrl: -S active window manager (not all wm)"
+ "xorg-xdpyinfo: inxi -G multi screen resolution"
+ "xorg-xprop: inxi -S desktop data"
+ "xorg-xrandr: inxi -G single screen resolution"
)
source=("git+https://github.com/smxi/inxi.git#branch=inxi-perl")
sha256sums=('SKIP')