summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmmanuel Gil Peyrot2015-08-27 02:52:17 +0100
committerEmmanuel Gil Peyrot2015-12-03 20:05:22 +0000
commitd107c1cbf641c93cff2e8ed3112ffa72d08e9a1b (patch)
tree7c763f67454c67d3347ac9fb268b3b0f2e23ddcb
downloadaur-d107c1cbf641c93cff2e8ed3112ffa72d08e9a1b.tar.gz
Initial commit.
-rw-r--r--.SRCINFO34
-rw-r--r--PKGBUILD47
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ec80d62d6dab
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,34 @@
+pkgbase = swift-git
+ pkgver = 3.0beta2.r87.gd5f0735
+ pkgrel = 1
+ url = http://swift.im/
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = python2
+ makedepends = openssl
+ makedepends = boost
+ makedepends = qt5-base
+ makedepends = qt5-multimedia
+ makedepends = qt5-webkit
+ makedepends = qt5-x11extras
+ source = git://swift.im/swift
+ md5sums = SKIP
+
+pkgname = swift-im-git
+ pkgdesc = XMPP client written in C++ with Qt and Swiften
+ depends = swiften-git=3.0beta2.r87.gd5f0735
+ depends = qt5-base
+ depends = qt5-multimedia
+ depends = qt5-webkit
+ depends = qt5-x11extras
+ optdepends = qt5-svg: for SVG avatars
+ provides = swift-im=3.0
+ conflicts = swift-im
+
+pkgname = swiften-git
+ pkgdesc = XMPP library written in C++ with Boost
+ depends = boost-libs
+ provides = swiften=3.0
+ conflicts = swiften
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..59d1daafed55
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,47 @@
+# Maintainer: Emmanuel Gil Peyrot <linkmauve@linkmauve.fr>
+
+pkgbase='swift-git'
+pkgname=('swift-im-git' 'swiften-git')
+pkgver=3.0beta2.r87.gd5f0735
+pkgrel=1
+arch=('i686' 'x86_64')
+url="http://swift.im/"
+license=('GPL3')
+makedepends=('python2' 'openssl' 'boost' 'qt5-base' 'qt5-multimedia' 'qt5-webkit' 'qt5-x11extras')
+source=("git://swift.im/swift")
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/swift"
+ git describe --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^swift\.//'
+}
+
+# Those options need to be consistent between each scons invocation.
+_scons_options='qt5=1 max_jobs=1 optimize=1 debug=0 swiften_dll=1 cxxflags="-DBOOST_SIGNALS_NO_DEPRECATION_WARNING=1"'
+_directory='swift'
+
+build() {
+ cd "$srcdir/$_directory"
+ QTDIR=/usr ./scons $_scons_options Swift Swiften
+}
+
+package_swift-im-git() {
+ pkgdesc='XMPP client written in C++ with Qt and Swiften'
+ depends=("swiften-git=$pkgver" 'qt5-base' 'qt5-multimedia' 'qt5-webkit' 'qt5-x11extras')
+ optdepends=('qt5-svg: for SVG avatars')
+ provides=('swift-im=3.0')
+ conflicts=('swift-im')
+
+ cd "$srcdir/$_directory"
+ QTDIR=/usr ./scons $_scons_options SWIFT_INSTALLDIR="$pkgdir/usr/" "$pkgdir/usr/"
+}
+
+package_swiften-git() {
+ pkgdesc='XMPP library written in C++ with Boost'
+ depends=('boost-libs')
+ provides=('swiften=3.0')
+ conflicts=('swiften')
+
+ cd "$srcdir/$_directory"
+ QTDIR=/usr ./scons $_scons_options SWIFTEN_INSTALLDIR="$pkgdir/usr/" "$pkgdir/usr/"
+}