summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoryustin2024-01-02 22:51:33 +0100
committeryustin2024-01-02 22:51:33 +0100
commitd11465686dedfacf130ee3c0af11e1ab7b5a4276 (patch)
tree3a6cf0b70a07969da45ff0f43f343389860ccc9c
parentfd82f2120a8e02894c00555e092776e524b7cc6f (diff)
downloadaur-d11465686dedfacf130ee3c0af11e1ab7b5a4276.tar.gz
7.2.89
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD34
-rw-r--r--add-vstsdk-location-var.patch41
-rw-r--r--gcc13faust3.patch18
-rw-r--r--grep.patch64
-rw-r--r--sndfilexprt.patch8
6 files changed, 15 insertions, 167 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59279c66a4e0..c262c9e8f11c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = radium
pkgdesc = A graphical music editor. A next generation tracker.
- pkgver = 7.1.92
+ pkgver = 7.2.89
pkgrel = 1
url = https://users.notam02.no/~kjetism/radium
install = radium.install
@@ -13,7 +13,8 @@ pkgbase = radium
makedepends = libxinerama
makedepends = libxkbfile
makedepends = libxrandr
- makedepends = llvm
+ makedepends = llvm15
+ makedepends = clang15
makedepends = qt5-tools
makedepends = vst2sdk
depends = desktop-file-utils
@@ -60,21 +61,13 @@ pkgbase = radium
optdepends = ladspa-plugins: package group for plugins normally included in binary releases
optdepends = vst-plugins: more plugins
options = !strip
- source = radium-7.1.92.tar.gz::https://github.com/kmatheussen/radium/archive/7.1.92.tar.gz
- source = add-vstsdk-location-var.patch
+ source = radium-7.2.89.tar.gz::https://github.com/kmatheussen/radium/archive/7.2.89.tar.gz
source = build_libpds.patch
source = radium.install
- source = grep.patch
source = build_linux_common.patch
- source = sndfilexprt.patch
- source = gcc13faust3.patch
- sha256sums = 324ac3df6d18eae69e1dee0ed18b4b53065098ec8b3cad7be6c0c5944e7c9b9a
- sha256sums = ed456586a1f28eec9acd081a676e61145e13f07c1a6e967c0af1f7d08be4023e
+ sha256sums = b479a2e9a7a27464e83700f417fd1fddab2fe5326c456e4c65bc6ca351278713
sha256sums = 2f145e84c5940f4f82544ae68e668d5bd02ee7bce559d3354f60d12eaea1a548
sha256sums = f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14
- sha256sums = 7ccb4eb8c2924a5b6c610b4f35bc9ff22602cb2e131035d285bef87d813460b3
sha256sums = 0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4
- sha256sums = f0391d772111592ac249d990ed418f87b5e083e5aaeb6b50b9198f93403ed9ab
- sha256sums = eb1400e5ec180a10455ac4e300360dba718ec586719fcb73a591f4f6e58e1a42
pkgname = radium
diff --git a/PKGBUILD b/PKGBUILD
index bd62b93fe029..591b99e30599 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,8 +4,8 @@
# Contributor: Jakob Gahde <j5lx@fmail.co.uk>
pkgname=radium
-pkgver=7.1.92
-pkgrel=2
+pkgver=7.2.89
+pkgrel=1
pkgdesc='A graphical music editor. A next generation tracker.'
arch=(x86_64)
url=https://users.notam02.no/~kjetism/radium
@@ -72,22 +72,14 @@ optdepends=(
)
options=( !strip )
source=("$pkgname-$pkgver.tar.gz::https://github.com/kmatheussen/radium/archive/$pkgver.tar.gz"
- add-vstsdk-location-var.patch
build_libpds.patch
radium.install
- grep.patch
build_linux_common.patch
- sndfilexprt.patch
- gcc13faust3.patch
)
-sha256sums=('324ac3df6d18eae69e1dee0ed18b4b53065098ec8b3cad7be6c0c5944e7c9b9a'
- 'ed456586a1f28eec9acd081a676e61145e13f07c1a6e967c0af1f7d08be4023e'
+sha256sums=('b479a2e9a7a27464e83700f417fd1fddab2fe5326c456e4c65bc6ca351278713'
'2f145e84c5940f4f82544ae68e668d5bd02ee7bce559d3354f60d12eaea1a548'
'f627730ff7a819e8cc5ac5c2b5f1fb2f2237327db6ea5442c55a23c1ce82ef14'
- '7ccb4eb8c2924a5b6c610b4f35bc9ff22602cb2e131035d285bef87d813460b3'
'0decfc3adcba836004ac34d970a83d4d0b69743334a586f42be53b3de7bdd5a4'
- 'f0391d772111592ac249d990ed418f87b5e083e5aaeb6b50b9198f93403ed9ab'
- 'eb1400e5ec180a10455ac4e300360dba718ec586719fcb73a591f4f6e58e1a42'
)
install=radium.install
@@ -95,33 +87,25 @@ prepare() {
cd radium-$pkgver
# use llvm15 to compile
- #OPATH=$PATH
export PATH=$(pwd):$PATH
ln -sf /usr/lib/llvm15/bin/clang clang
ln -sf /usr/bin/llvm-config-15 llvm-config
- patch -p0 < "$srcdir/grep.patch"
-
- # Add VST2SDK env var so we can use VST2 headers from steinberg-vst36 in AUR
- patch -p1 < "$srcdir/add-vstsdk-location-var.patch"
-
# fix for binutils 2.40
patch -p0 < "$srcdir/build_linux_common.patch"
# This tweak edits new file template and demo songs to be compatible with chorus plugin from calf-ladspa package
+ # New Demosong also needs fixes for LADSPA-Plugins
# !! NOTE TO LMMS USERS !!
# !! Comment next line out if you have LMMS installed as it already comes with their own version of Calf plugins !!
for file in bin/sounds/*.rad; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
+ for file in bin/sounds/*.RAD; do sed -i -e 's/Calf MultiChorus LADSPA/Calf Multi Chorus LADSPA/g' "$file"; done
+ sed -ie "s/C\* Eq - 10-band equalizer/C\* Eq10 - 10-band equaliser/g" bin/sounds/ROMANCE2.RAD
# See comment on calf-ladspa AUR page then on how to let Radium load Calf from LMMS package
- # temp fix for soundfileexport
- patch -p0 < "$srcdir/sndfilexprt.patch"
-
cd bin/packages
- patch -p0 < "$srcdir/build_libpds.patch"
-
- # patch for faust3.patch gcc13
- patch -p0 < "$srcdir/gcc13faust3.patch"
+ # activate our former patch in build.sh
+ sed "/fsqrt/s/#//" -i build.sh
}
build() {
@@ -136,6 +120,8 @@ package() {
# Install radium and its packages to /opt
RADIUM_INSTALL_LIBXCB=0 ./install.sh "$pkgdir/opt"
+ # radium.install will link ladspa-path here so remove it
+ rm -rf $pkgdir/opt/radium/ladspa
# Create startup script according to bin/packages/README
mkdir -p "$pkgdir/usr/bin"
diff --git a/add-vstsdk-location-var.patch b/add-vstsdk-location-var.patch
deleted file mode 100644
index 9f4eb54d567a..000000000000
--- a/add-vstsdk-location-var.patch
+++ /dev/null
@@ -1,41 +0,0 @@
-diff -aur --no-dereference '--exclude=.git' radium-6.9.88.old/check_dependencies.sh radium-6.9.88.new/check_dependencies.sh
---- radium-6.9.88.old/check_dependencies.sh 2021-07-24 21:33:34.000000000 +0100
-+++ radium-6.9.88.new/check_dependencies.sh 2021-07-25 17:42:43.213233704 +0100
-@@ -246,13 +246,6 @@
- exit 5
- fi
-
--if [[ ! -f ~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/"VST3 SDK"/pluginterfaces/vst2.x/aeffect.h && ! -f ~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h ]] ; then
-- echo 'Steinberg VST headers not found. (Missing "~/SDKs/vstsdk2.4/pluginterfaces/vst2.x/aeffect.h or "~/SDKs/VST3 SDK/pluginterfaces/vst2.x/aeffect.h" or "~/SDKs/VST_SDK/VST2_SDK/pluginterfaces/vst2.x/aeffect.h")'
-- echo 'You should find these files in the "VST Audio Plug-Ins SDK" from http://www.steinberg.net/en/company/developers.html . Unless Steinberg has changed the directory structure again, it should enough to unzip the file into your ~/SDKs directory.'
-- exit 5
--fi
--
--
- if [[ $4 == "test_build" ]] ; then
- if [ `uname` == "Linux" ] ; then
- if [ ! -f bin/packages/deletemetorebuild ] ; then
-diff -aur --no-dereference '--exclude=.git' radium-6.9.88.old/Makefile.Qt radium-6.9.88.new/Makefile.Qt
---- radium-6.9.88.old/Makefile.Qt 2021-07-24 21:33:34.000000000 +0100
-+++ radium-6.9.88.new/Makefile.Qt 2021-07-25 17:42:43.219900395 +0100
-@@ -343,7 +343,7 @@
-
- FLAGOPTS = $(DEFINES) -DGUIISQT -DFULL_VERSION=$(FULL_VERSION) -DIS_LITTLE_ENDIAN=1 -DUSE_OPENGL=1 $(VISUAL) $(REQTYPE_TYPE) $(MENU_TYPE)
-
--COMMONOPT = -D__STDC_FORMAT_MACROS=1 -c `cat buildtype.opt` -I$(GCDIR)/include -I$(P) $(PYOPTS) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/vstsdk2.4/ -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers -Wnull-dereference -Wwrite-strings -DTHREADED_OPENGL=1
-+COMMONOPT = -D__STDC_FORMAT_MACROS=1 -c `cat buildtype.opt` -I$(GCDIR)/include -I$(P) $(PYOPTS) `cat flagopts.opt` $(MIDIINC) $(OS_OPTS) $(VST_OPTS) -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/vstsdk2.4/ -I${RADIUM_VST2SDK_PATH} -Wextra -Wno-unused-parameter -Wno-missing-field-initializers -Wno-unknown-pragmas -fno-strict-aliasing -Wmissing-field-initializers -Wnull-dereference -Wwrite-strings -DTHREADED_OPENGL=1
- #-fdelete-null-pointer-checks
- # -Werror
-
-diff -aur --no-dereference '--exclude=.git' radium-6.9.88.old/pluginhost/Builds/Linux/Makefile radium-6.9.88.new/pluginhost/Builds/Linux/Makefile
---- radium-6.9.88.old/pluginhost/Builds/Linux/Makefile 2021-07-24 21:33:34.000000000 +0100
-+++ radium-6.9.88.new/pluginhost/Builds/Linux/Makefile 2021-07-25 17:45:12.883773257 +0100
-@@ -17,7 +17,7 @@
-
- LV2FLAGS=-I$(JUCE_MODULES)juce_audio_processors/format_types/LV2_SDK -I$(JUCE_MODULES)juce_audio_processors/format_types/LV2_SDK/lv2 -I$(JUCE_MODULES)juce_audio_processors/format_types/LV2_SDK/lilv/src -I$(JUCE_MODULES)juce_audio_processors/format_types/LV2_SDK/lilv -I$(JUCE_MODULES)juce_audio_processors/format_types/LV2_SDK/sratom -I$(JUCE_MODULES)juce_audio_processors/format_types/LV2_SDK/sord/src -I$(JUCE_MODULES)juce_audio_processors/format_types/LV2_SDK/sord -I$(JUCE_MODULES)juce_audio_processors/format_types/LV2_SDK/serd -I$(JUCE_MODULES)juce_audio_processors/format_types/LV2_SDK/lv2 -I$(JUCE_MODULES)juce_audio_processors/format_types/LV2_SDK
-
--COMMONCPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" $(AVAILABLES) -I /usr/include -I /usr/include/freetype2 -I$(JUCE_MODULES)/.. -I$(JUCE_MODULES) -I$(JUCE_MODULES)juce_audio_processors/format_types/VST3_SDK $(LV2FLAGS) -I $(JUCE_MODULES)JuceLibraryCode -I $(JUCE_MODULES)JuceLibraryCode/modules -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\"" -mfpmath=sse -msse2 -DPLUGINHOST_BUILD_64BIT
-+COMMONCPPFLAGS := $(DEPFLAGS) -D "LINUX=1" -D "JUCE_CHECK_MEMORY_LEAKS=0" -D "JUCER_LINUX_MAKE_7346DA2A=1" -D "JUCE_APP_VERSION=1.0.0" -D "JUCE_APP_VERSION_HEX=0x10000" $(AVAILABLES) -I /usr/include -I /usr/include/freetype2 -I$(JUCE_MODULES)/.. -I$(JUCE_MODULES) -I$(JUCE_MODULES)juce_audio_processors/format_types/VST3_SDK $(LV2FLAGS) -I $(JUCE_MODULES)JuceLibraryCode -I $(JUCE_MODULES)JuceLibraryCode/modules -I$(RADIUM_VST2SDK_PATH) -I ~/SDKs/vstsdk2.4 -DJUCE_APP_CONFIG_HEADER="\"AppConfig.h\"" -mfpmath=sse -msse2 -DPLUGINHOST_BUILD_64BIT
-
- # -I~/SDKs/VST_SDK/VST3_SDK -I ~/SDKs/VST_SDK/VST2_SDK/ -I ~/SDKs/VST3\ SDK
-
diff --git a/gcc13faust3.patch b/gcc13faust3.patch
deleted file mode 100644
index 625058239891..000000000000
--- a/gcc13faust3.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- faust3.patch.orig 2023-04-06 10:33:40.000000000 +0200
-+++ faust3.patch 2023-05-13 23:45:51.727086087 +0200
-@@ -1,6 +1,12 @@
----- architecture/faust/dsp/dsp.h~ 2022-12-17 11:41:42.000000000 +0100
--+++ architecture/faust/dsp/dsp.h 2022-12-28 19:12:31.965902920 +0100
--@@ -34,8 +34,8 @@
-+--- architecture/faust/dsp/dsp.h 2023-05-13 23:37:17.053765247 +0200
-++++ architecture/faust/dsp/dsp.h 2023-05-13 23:37:51.057097756 +0200
-+@@ -29,13 +29,14 @@
-+ #include <vector>
-+
-+ #include "faust/export.h"
-++#include <cstdint>
-+
-+ #ifndef FAUSTFLOAT
- #define FAUSTFLOAT float
- #endif
-
diff --git a/grep.patch b/grep.patch
deleted file mode 100644
index 2f66ed60df8f..000000000000
--- a/grep.patch
+++ /dev/null
@@ -1,64 +0,0 @@
---- check_dependencies.sh.orig 2023-01-22 17:00:46.339891749 +0100
-+++ check_dependencies.sh 2023-01-22 20:25:11.527264810 +0100
-@@ -52,13 +52,13 @@
- exit 5
- fi
-
-- if $MOC -v 2>&1 |grep Qt\ 3 ; then
-+ if $MOC -v 2>&1 |grep "Qt 3" ; then
- echo $MOC "is for QT3. Need moc for QT$RADIUM_QT_VERSION. Make sure MOC is set correctly in the Makefile."
- echo
- exit 5
- fi
-
-- if $UIC -v 2>&1 |grep Qt\ 3 ; then
-+ if $UIC -v 2>&1 |grep "Qt 3" ; then
- echo $UIC "is for QT3. Need uic for QT$RADIUM_QT_VERSION. Make sure UIC is set correctly in the Makefile."
- echo
- exit 5
-@@ -72,7 +72,7 @@
- if [[ "$line" == \#* ]] ; then
- true
- else
-- if echo "$line" | grep -e "\ \*" ; then
-+ if echo "$line" | grep -e " \*" ; then
- echo "This line in api/protos.conf is wrongly formatted. Must use \"<type>*\", not \"<type> *\""
- echo
- exit 5
-@@ -81,31 +81,31 @@
- done < "$input"
-
-
--if grep int\ seqblockid api/protos.conf ; then
-+if grep "int seqblockid" api/protos.conf ; then
- echo "The above line(s) in api/protos.conf is/are wrong. seqblock id is 64 bit"
- echo
- exit 5
- fi
-
--if grep int\ seqblock_id api/protos.conf ; then
-+if grep "int seqblock_id" api/protos.conf ; then
- echo "The above line(s) in api/protos.conf is/are wrong. seqblock id is 64 bit"
- echo
- exit 5
- fi
-
--if grep int\ instrument_id api/protos.conf ; then
-+if grep "int instrument_id" api/protos.conf ; then
- echo "The above line(s) in api/protos.conf is/are wrong. instrument id is 64 bit"
- echo
- exit 5
- fi
-
--if grep int\ guinum api/protos.conf ; then
-+if grep "int guinum" api/protos.conf ; then
- echo "The above line(s) in api/protos.conf is/are wrong. guinum is 64 bit"
- echo
- exit 5
- fi
-
--if grep int\ id api/protos.conf ; then
-+if grep "int id" api/protos.conf ; then
- echo "The above line(s) in api/protos.conf is/are wrong. id has so far been 64 bit"
- echo
- exit 5
diff --git a/sndfilexprt.patch b/sndfilexprt.patch
deleted file mode 100644
index 2746b6ed251a..000000000000
--- a/sndfilexprt.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- bin/run_radium_linux.sh.orig 2023-04-23 01:12:04.122074816 +0200
-+++ bin/run_radium_linux.sh 2023-04-23 01:12:17.465407822 +0200
-@@ -26,4 +26,4 @@
- unset QT_QPA_PLATFORM
- unset QT_PLUGIN_PATH
-
--QT_QPA_PLATFORM="xcb" LD_LIBRARY_PATH="$LD_LIBRARY_PATH" "$THIS_DIR"/radium_linux.bin "$@"
-+LC_ALL=C QT_QPA_PLATFORM="xcb" LD_LIBRARY_PATH="$LD_LIBRARY_PATH" "$THIS_DIR"/radium_linux.bin "$@"