summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Sun2023-04-27 18:43:55 -0400
committerAndrew Sun2023-04-27 18:43:55 -0400
commitd11ba98f1ecc779ded325566cef8992da5211b56 (patch)
tree29f4cc03eaa3494e3ccf4c1c06fe1ad90c87aee8
parente60e86d213fab68ec748003529e2320f7dc5f972 (diff)
downloadaur-d11ba98f1ecc779ded325566cef8992da5211b56.tar.gz
0.27.6
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 87fbb20e937f..5d959078b436 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-lifelines
pkgdesc = Survival analysis in Python
- pkgver = 0.27.5
+ pkgver = 0.27.6
pkgrel = 1
url = https://github.com/CamDavidsonPilon/lifelines
arch = any
@@ -13,7 +13,7 @@ pkgbase = python-lifelines
depends = python-scikit-learn
depends = python-formulaic
options = !emptydirs
- source = lifelines-0.27.5.tar.gz::https://github.com/CamDavidsonPilon/lifelines/archive/refs/tags/v0.27.5.tar.gz
- sha256sums = 31b74719ca1dc3bb378f623ae5ab6539b49ddd2af2fc4af4b56a174d73fc59e0
+ source = lifelines-0.27.6.tar.gz::https://github.com/CamDavidsonPilon/lifelines/archive/230948c84b3f75c8de3b4b4d935276784256a34b.tar.gz
+ sha256sums = ac0bd52c26b674e2af4c2c609900af1cdee5c891fe39a5a589db95abb2415cad
pkgname = python-lifelines
diff --git a/PKGBUILD b/PKGBUILD
index 444eb80b33be..f218940fa54a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,8 @@
_pkgname=lifelines
pkgname=python-lifelines
-pkgver=0.27.5
+pkgver=0.27.6
+_pkgver=230948c84b3f75c8de3b4b4d935276784256a34b
pkgrel=1
pkgdesc="Survival analysis in Python"
url="https://github.com/CamDavidsonPilon/lifelines"
@@ -11,16 +12,16 @@ license=('MIT')
depends=('ipython' 'python-autograd-gamma' 'python-matplotlib' 'python-pandas' 'python-scikit-learn' 'python-formulaic')
makedepends=('python-setuptools')
options=(!emptydirs)
-source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/CamDavidsonPilon/lifelines/archive/refs/tags/v${pkgver}.tar.gz")
-sha256sums=('31b74719ca1dc3bb378f623ae5ab6539b49ddd2af2fc4af4b56a174d73fc59e0')
+source=("${_pkgname}-${pkgver}.tar.gz"::"https://github.com/CamDavidsonPilon/lifelines/archive/230948c84b3f75c8de3b4b4d935276784256a34b.tar.gz")
+sha256sums=('ac0bd52c26b674e2af4c2c609900af1cdee5c891fe39a5a589db95abb2415cad')
build() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
python setup.py build
}
package() {
- cd "${srcdir}/${_pkgname}-${pkgver}"
+ cd "${srcdir}/${_pkgname}-${_pkgver}"
python setup.py install --prefix=/usr --root="${pkgdir}" --optimize=1 --skip-build
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}