summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChih-Hsuan Yen2018-12-31 12:42:06 +0800
committerChih-Hsuan Yen2018-12-31 12:42:06 +0800
commitd12e1140045b68adf628d8a113cd0895aab9fc07 (patch)
treeb3ec49806e3a75ccec30f65d627be7c1645999a6
parenta143160cd52d96ed7042a0c7142e04699b652b78 (diff)
downloadaur-d12e1140045b68adf628d8a113cd0895aab9fc07.tar.gz
update and fix
Turns out that the AUR package has been disowned. Adopted. Changes: * Update to the latest commit * Switch to the git repo maintained by Debian * Fix building in case GNU make-specific flags in MAKEFLAGS of makepkg.conf * Don't specify _GNU_SOURCE manually - ./configure detects it
-rw-r--r--.SRCINFO9
-rw-r--r--LICENSE25
-rw-r--r--PKGBUILD47
3 files changed, 53 insertions, 28 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 46f9ddf97337..2ee1de4e76ac 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,18 @@
pkgbase = libnbcompat
pkgdesc = Portable NetBSD compatibility library
- pkgver = 20111103
+ pkgver = 20180822
pkgrel = 1
url = http://www.netbsd.org/
arch = i686
arch = x86_64
license = BSD
makedepends = bmake
- makedepends = cvs
+ makedepends = git
+ options = !makeflags
+ source = git+https://github.com/jgoerzen/libnbcompat#commit=be9f9298fd165ea01a0769c4ffa29a3ec0d22023
+ source = LICENSE
+ md5sums = SKIP
+ md5sums = beab088c74f4e3e456da604c0d62c2e3
pkgname = libnbcompat
diff --git a/LICENSE b/LICENSE
new file mode 100644
index 000000000000..ac25b9f57ecb
--- /dev/null
+++ b/LICENSE
@@ -0,0 +1,25 @@
+/*-
+ * Copyright (c) 2003 The NetBSD Foundation, Inc.
+ * All rights reserved.
+ *
+ * Redistribution and use in source and binary forms, with or without
+ * modification, are permitted provided that the following conditions
+ * are met:
+ * 1. Redistributions of source code must retain the above copyright
+ * notice, this list of conditions and the following disclaimer.
+ * 2. Redistributions in binary form must reproduce the above copyright
+ * notice, this list of conditions and the following disclaimer in the
+ * documentation and/or other materials provided with the distribution.
+ *
+ * THIS SOFTWARE IS PROVIDED BY THE NETBSD FOUNDATION, INC. AND CONTRIBUTORS
+ * ``AS IS'' AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED
+ * TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR
+ * PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE FOUNDATION OR CONTRIBUTORS
+ * BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR
+ * CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF
+ * SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
+ * INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN
+ * CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE)
+ * ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
+ * POSSIBILITY OF SUCH DAMAGE.
+ */
diff --git a/PKGBUILD b/PKGBUILD
index dc2134a6bd1a..9d0a9829d38c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,43 +1,38 @@
-# Maintainer: Timothy Redaelli <timothy.redaelli@gmail.com>
+# Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
+# Contributor: Timothy Redaelli <timothy.redaelli@gmail.com>
pkgname="libnbcompat"
-pkgver=20111103
+pkgver=20180822
+_commit=be9f9298fd165ea01a0769c4ffa29a3ec0d22023
pkgrel=1
pkgdesc="Portable NetBSD compatibility library"
arch=('i686' 'x86_64')
url="http://www.netbsd.org/"
license=('BSD')
-makedepends=('bmake' 'cvs')
-
-_cvsroot=":pserver:anoncvs@anoncvs.NetBSD.org:/cvsroot"
-_cvsmod="pkgsrc/pkgtools/$pkgname/files"
+# The git repo is maintained by Debian
+# LICENSE is extracted from nbcompat.h
+source=("git+https://github.com/jgoerzen/libnbcompat#commit=$_commit"
+ 'LICENSE')
+md5sums=('SKIP'
+ 'beab088c74f4e3e456da604c0d62c2e3')
+makedepends=('bmake' 'git')
+options=('!makeflags')
build() {
- cd "$srcdir"
- msg "Connecting to NetBSD CVS server...."
-
- if [[ -d "$_cvsmod/CVS" ]]; then
- cd "$_cvsmod"
- cvs -z3 update -d
- else
- cvs -z3 -d "$_cvsroot" co -D "$pkgver" -f "$_cvsmod"
- cd "$_cvsmod"
- fi
-
- msg "CVS checkout done or server timeout"
- msg "Starting build..."
+ cd libnbcompat
- rm -rf "$srcdir/$_cvsmod-build"
- cp -r "$srcdir/$_cvsmod" "$srcdir/$_cvsmod-build"
- cd "$srcdir/$_cvsmod-build"
-
- ./configure --prefix=/usr --enable-db --enable-bsd-getopt CPPFLAGS="${CPPFLAGS} -D_GNU_SOURCE"
+ ./configure \
+ --prefix=/usr \
+ --enable-db \
+ --enable-bsd-getopt
bmake
}
package() {
- cd "$srcdir/$_cvsmod-build"
+ cd libnbcompat
+
+ bmake install DESTDIR="$pkgdir"
- bmake install DESTDIR="$pkgdir/"
+ install -Dm644 ../LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname
}