summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorzocker-1602020-08-06 01:20:41 +0200
committerzocker-1602020-08-06 01:20:41 +0200
commitd137b0cee2e7361ec88f10e12323ebab67eef086 (patch)
treec7c2502b5b36d57d998cba237a718d5888fdbfc2
parenta69783e7d1b35163aa26eba3554d49b328775cb2 (diff)
downloadaur-d137b0cee2e7361ec88f10e12323ebab67eef086.tar.gz
cleanup
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD20
2 files changed, 8 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb5713bd6a18..5db51230ea03 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,17 @@
pkgbase = bless-git
pkgdesc = High-quality, full-featured hex editor (git version)
pkgver = r181.59aaaba
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/afrantzis/bless
arch = any
- license = GPL
+ license = GPL2
makedepends = libxslt
makedepends = meson
depends = gtk-sharp-2
depends = mono
conflicts = bless
source = git://github.com/afrantzis/bless.git
- source = bless_bin
sha256sums = SKIP
- sha256sums = b114dd9045c1fc2cfbaba5ff1aa02864429916a5356db71ed8b7e740d2352e07
pkgname = bless-git
+
diff --git a/PKGBUILD b/PKGBUILD
index 7f0de1dc423c..82037ee01bdb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,7 +8,7 @@
pkgname=bless-git
_gitname=bless
pkgver=r181.59aaaba
-pkgrel=2
+pkgrel=3
pkgdesc="High-quality, full-featured hex editor (git version)"
arch=('any')
url="https://github.com/afrantzis/bless"
@@ -16,10 +16,8 @@ license=('GPL2')
depends=('gtk-sharp-2' 'mono')
conflicts=('bless')
makedepends=('libxslt' 'meson')
-source=("git://github.com/afrantzis/bless.git"
- "bless_bin")
-sha256sums=('SKIP'
- 'b114dd9045c1fc2cfbaba5ff1aa02864429916a5356db71ed8b7e740d2352e07')
+source=("git://github.com/afrantzis/bless.git")
+sha256sums=('SKIP')
pkgver() {
cd ${srcdir}/${_gitname}/
@@ -28,7 +26,7 @@ pkgver() {
prepare() {
cd ${srcdir}/${_gitname}
- meson setup build -Dprefix=/usr -Dtests=false --buildtype=release
+ meson setup build -Dprefix=/usr -Dtests=false --buildtype=release
}
build() {
@@ -38,13 +36,5 @@ build() {
package() {
cd ${srcdir}/${_gitname}
- ninja -C build install
-
- rm "${pkgdir}/bin/bless"
- cp "${srcdir}/bless_bin" "${pkgdir}/bin/bless"
-
- mkdir "${pkgdir}/usr"
- mv "${pkgdir}/bin" "${pkgdir}/usr/bin"
- mv "${pkgdir}/lib" "${pkgdir}/usr/lib"
- mv "${pkgdir}/share" "${pkgdir}/usr/share"
+ DESTDIR="${pkgdir}" ninja -C build install
}