summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCaleb Maclennan2021-08-03 22:38:27 +0300
committerCaleb Maclennan2021-08-03 22:38:27 +0300
commitd13865097afbf6ece04c36250531d9cc96575742 (patch)
tree6283452c26241edb357fb9fb5e6055fec11f7097
parent9929f836d370fd7ef78202580299e1379e819f32 (diff)
downloadaur-d13865097afbf6ece04c36250531d9cc96575742.tar.gz
upgpkg: python-fonttools-git 4.26.1.r1.g032befd-1
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD28
2 files changed, 18 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1767f68d1e63..9bb878d20729 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = python-fonttools-git
pkgdesc = A library to manipulate font files from Python
- pkgver = 4.24.4.r1.gee2aa26
+ pkgver = 4.26.1.r1.g032befd
pkgrel = 1
url = https://github.com/fonttools/fonttools
arch = x86_64
@@ -14,16 +14,15 @@ pkgbase = python-fonttools-git
optdepends = python-lxml: faster backend for XML files reading/writing
optdepends = python-lz4: for graphite type tables in ttLib/tables
optdepends = python-matplotlib: for visualizing DesignSpaceDocument and resulting VariationModel
- optdepends = python-pyqt5: for drawing glyphs with Ql’s QPainterPath
+ optdepends = python-pyqt5: for drawing glyphs with Qt’s QPainterPath
optdepends = python-reportlab: to drawing glyphs as PNG images
optdepends = python-scipy: for finding wrong contour/component order between different masters
optdepends = python-sympy: for symbolic font statistics analysis
optdepends = python-unicodedata2: for displaying the Unicode character names when dumping the cmap table with ttx
optdepends = python-zopfli: faster backend fom WOFF 1.0 web fonts compression
- provides = python-fonttools=4.24.4.r1.gee2aa26
+ provides = python-fonttools=4.26.1.r1.g032befd
conflicts = python-fonttools
source = python-fonttools-git::git+https://github.com/fonttools/fonttools.git
sha256sums = SKIP
pkgname = python-fonttools-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 0a6e1a129ccf..769def7cb9d4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,20 +1,22 @@
# Maintainer: Caleb Maclennan <caleb@alerque.com>
pkgname=python-fonttools-git
-pkgver=4.24.4.r1.gee2aa26
+pkgver=4.26.1.r1.g032befd
pkgrel=1
pkgdesc='A library to manipulate font files from Python'
url='https://github.com/fonttools/fonttools'
license=(MIT)
arch=(x86_64)
depends=(python)
-makedepends=(cython git python-setuptools)
+makedepends=(cython
+ git
+ python-setuptools)
optdepends=('python-brotli: to compress/decompress WOFF 2.0 web fonts'
'python-fs: to read/write UFO source files'
'python-lxml: faster backend for XML files reading/writing'
'python-lz4: for graphite type tables in ttLib/tables'
'python-matplotlib: for visualizing DesignSpaceDocument and resulting VariationModel'
- 'python-pyqt5: for drawing glyphs with Ql’s QPainterPath'
+ 'python-pyqt5: for drawing glyphs with Qt’s QPainterPath'
'python-reportlab: to drawing glyphs as PNG images'
'python-scipy: for finding wrong contour/component order between different masters'
'python-sympy: for symbolic font statistics analysis'
@@ -26,20 +28,20 @@ source=("$pkgname::git+$url.git")
sha256sums=('SKIP')
pkgver() {
- cd "$pkgname"
- git describe --long --tags --abbrev=7 HEAD |
- sed 's/\([^-]*-g\)/r\1/;s/-/./g'
+ cd "$pkgname"
+ git describe --long --tags --abbrev=7 HEAD |
+ sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}
build() {
- cd "$pkgname"
- python setup.py build_ext --inplace
- python setup.py build
+ cd "$pkgname"
+ export PYTHONHASHSEED=0
+ python setup.py build_ext --inplace
+ python setup.py build
}
package() {
- cd "$pkgname"
- python setup.py install --skip-build --root="$pkgdir" --optimize=1
- install -Dpm755 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
+ cd "$pkgname"
+ python setup.py install --root="$pkgdir" --optimize=1 --skip-build
+ install -Dm0755 -t "$pkgdir/usr/share/licenses/$pkgname/" LICENSE
}
-