summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormyself6002023-01-17 13:40:02 +0100
committermyself6002023-01-17 13:40:02 +0100
commitd186f44bf138a6f0e0c0a532512d48e1164b36e5 (patch)
tree2a1d75c6a558e056456067b7b31b5a57a8705ccb
parentf49a5951c297c48e9e6c3f9336ea97feccfcb9bc (diff)
downloadaur-d186f44bf138a6f0e0c0a532512d48e1164b36e5.tar.gz
Rewrite from scratch
-rw-r--r--.SRCINFO33
-rw-r--r--GTAVC.desktop6
-rw-r--r--PKGBUILD78
-rw-r--r--launch.sh2
-rwxr-xr-xreVC.desktop7
-rw-r--r--revc-git.install7
-rw-r--r--revc.install3
7 files changed, 45 insertions, 91 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b9ff45886799..f6089da1c5b3 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,32 +1,19 @@
pkgbase = revc-git
- pkgdesc = Grand Theft Auto Vice City reverse engineered
- pkgver = 1
+ pkgdesc = Grand Theft Auto: Vice City reverse engineered
+ pkgver = 1.0+r870.a16fcd8d
pkgrel = 1
- install = revc-git.install
+ url = https://github.com/td512/re3/tree/miami
+ install = revc.install
arch = x86_64
- license = none
- makedepends = git
+ arch = aarch64
+ license = custom:none
makedepends = cmake
- makedepends = premake
+ depends = librw-git
depends = openal
- depends = glew
- depends = glfw
- depends = libsndfile
depends = mpg123
- provides = revc
- source = git+https://github.com/erorcun/re3.git#branch=miami
- source = git+https://github.com/aap/librw.git
- source = git+https://github.com/xiph/ogg.git
- source = git+https://github.com/xiph/opus.git
- source = git+https://github.com/xiph/opusfile.git
- source = launch.sh
- source = GTAVC.desktop
+ source = git+https://github.com/td512/re3.git#branch=miami
+ source = reVC.desktop
md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = SKIP
- md5sums = 9eb2aff2687f8cc735ea93e0460f07e0
- md5sums = 2991b7cf6751274bfdccc7b6f0272129
+ md5sums = a7cd29fced93db056a84486f166f1ecc
pkgname = revc-git
diff --git a/GTAVC.desktop b/GTAVC.desktop
deleted file mode 100644
index 8cfd1e3ce3d7..000000000000
--- a/GTAVC.desktop
+++ /dev/null
@@ -1,6 +0,0 @@
-[Desktop Entry]
-Name=Grand Theft Auto Vice City
-Exec=/opt/reVC/launch.sh
-Icon=~/.local/share/gtavc/Icons/app.ico
-Type=Application
-Categories=Games;
diff --git a/PKGBUILD b/PKGBUILD
index 29e810f18d9c..320482ec62c4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,60 +1,32 @@
pkgname=revc-git
-pkgver=1
+pkgver=1.0+r870.a16fcd8d
pkgrel=1
-pkgdesc="Grand Theft Auto Vice City reverse engineered"
-arch=('x86_64')
-depends=('openal' 'glew' 'glfw' 'libsndfile' 'mpg123')
-makedepends=('git' 'cmake' 'premake')
-provides=('revc')
-license=('none')
-
-install=$pkgname.install
+pkgdesc="Grand Theft Auto: Vice City reverse engineered"
+arch=(x86_64 aarch64)
+url=https://github.com/td512/re3/tree/miami
+license=(custom:none)
+depends=(librw-git openal mpg123)
+makedepends=(cmake)
+install=revc.install
source=(
- 'git+https://github.com/erorcun/re3.git#branch=miami'
- 'git+https://github.com/aap/librw.git'
- 'git+https://github.com/xiph/ogg.git'
- 'git+https://github.com/xiph/opus.git'
- 'git+https://github.com/xiph/opusfile.git'
- 'launch.sh'
- 'GTAVC.desktop')
+ git+https://github.com/td512/re3.git#branch=miami
+ reVC.desktop)
md5sums=(
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- 'SKIP'
- '9eb2aff2687f8cc735ea93e0460f07e0'
- '2991b7cf6751274bfdccc7b6f0272129')
-
-pkgver() {
- cd "$srcdir/re3"
- printf "%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ SKIP
+ a7cd29fced93db056a84486f166f1ecc)
+pkgver(){
+ cd re3
+ git describe --tags|sed 's/.*_//;s/-\(.*\)-g/+r\1./'
}
-
-prepare() {
- cd "$srcdir/re3"
-
- git submodule init
- for submod in librw ogg opus opusfile
- do
- git config "submodule.vendor/$submod.url" "../$submod"
- done
- git submodule update
+build(){
+ cd re3
+ cmake -DREVC_VENDORED_LIBRW= .
+ make
}
-
-build() {
- cd "$srcdir/re3"
-
- premake5 --with-librw gmake2
- cd "build"
- "./../printHash.sh" "./../src/extras/GitSHA1.cpp"
- make O=. config=release_linux-amd64-librw_gl3_glfw-oal
-}
-
-package() {
- cd "$srcdir/re3/bin/linux-amd64-librw_gl3_glfw-oal/Release"
- install -d $pkgdir/opt/reVC
- install -m755 reVC $pkgdir/opt/reVC/
- install -m755 $srcdir/launch.sh $pkgdir/opt/reVC/
- install -D -m644 $srcdir/GTAVC.desktop $pkgdir/usr/share/applications/GTAVC.desktop
+package(){
+ cd re3
+ install src/reVC -Dt "$pkgdir"/usr/bin
+ install -D {res/images/logo,"$pkgdir"/usr/share/pixmaps/reVC}.svg
+ install ../reVC.desktop -Dt "$pkgdir"/usr/share/applications
+ cp -r gamefiles "$pkgdir"/usr/share/reVC
}
diff --git a/launch.sh b/launch.sh
deleted file mode 100644
index a4fe31bbf00d..000000000000
--- a/launch.sh
+++ /dev/null
@@ -1,2 +0,0 @@
-cd ~/.local/share/gtavc
-/opt/reVC/reVC
diff --git a/reVC.desktop b/reVC.desktop
new file mode 100755
index 000000000000..bf593b5cb60a
--- /dev/null
+++ b/reVC.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Type=Application
+Name=Grand Theft Auto: Vice City (reVC)
+Exec=reVC
+Path=.reVC
+Icon=reVC
+Categories=Game
diff --git a/revc-git.install b/revc-git.install
deleted file mode 100644
index 68e2fea9385a..000000000000
--- a/revc-git.install
+++ /dev/null
@@ -1,7 +0,0 @@
-post_install() {
- cat <<EOF
-In order to play this game you need the data files from steam or retail version of GTA VC
-Copy the game directory to ~/.local/share/gtavc
-EOF
-}
-
diff --git a/revc.install b/revc.install
new file mode 100644
index 000000000000..9b0a18a74985
--- /dev/null
+++ b/revc.install
@@ -0,0 +1,3 @@
+post_install(){
+ echo -e '\e[93mPlace your game data into ~/.reVC folder and run "cp -r /usr/share/reVC/* ~/.reVC"\e[m'
+}