summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-08-25 20:47:40 -0300
committerDaniel Bermond2017-08-25 20:47:40 -0300
commitd1a7d11dda3c156e5f6d2f2a464d9bd342f97fa9 (patch)
tree951da9ddc9c9e0337af38dfbb226905f7e8c1aea
parentd5a20957c4c5a38c8b99805a222f79874296b96c (diff)
downloadaur-d1a7d11dda3c156e5f6d2f2a464d9bd342f97fa9.tar.gz
Match changes in official package
-rw-r--r--.SRCINFO12
-rw-r--r--[-rwxr-xr-x]PKGBUILD28
2 files changed, 21 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4c1b3fe0c652..74c5af20b225 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,18 @@
# Generated by mksrcinfo v8
-# Sun Apr 30 17:08:04 UTC 2017
+# Fri Aug 25 23:47:33 UTC 2017
pkgbase = frei0r-plugins-git
pkgdesc = A minimalistic plugin API for video effects (git version)
pkgver = 1.6.0.r5.gdfd4475
- pkgrel = 2
+ pkgrel = 3
url = https://www.dyne.org/software/frei0r/
arch = i686
arch = x86_64
- license = GPL2
+ license = GPL
makedepends = git
- depends = gcc-libs
- depends = gavl
+ makedepends = opencv
depends = cairo
- depends = opencv
+ depends = gavl
+ optdepends = opencv: for facebl0r and facedetect plugins
provides = frei0r-plugins
conflicts = frei0r-plugins
source = frei0r-plugins-git::git+https://github.com/dyne/frei0r.git
diff --git a/PKGBUILD b/PKGBUILD
index b7ef86f2daca..8b78ae151b80 100755..100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,13 +2,14 @@
pkgname=frei0r-plugins-git
pkgver=1.6.0.r5.gdfd4475
-pkgrel=2
-pkgdesc="A minimalistic plugin API for video effects (git version)"
+pkgrel=3
+pkgdesc='A minimalistic plugin API for video effects (git version)'
arch=('i686' 'x86_64')
-url="https://www.dyne.org/software/frei0r/"
-license=('GPL2')
-depends=('gcc-libs' 'gavl' 'cairo' 'opencv')
-makedepends=('git')
+url='https://www.dyne.org/software/frei0r/'
+license=('GPL')
+depends=('cairo' 'gavl')
+makedepends=('git' 'opencv')
+optdepends=('opencv: for facebl0r and facedetect plugins')
provides=('frei0r-plugins')
conflicts=('frei0r-plugins')
source=("$pkgname"::'git+https://github.com/dyne/frei0r.git')
@@ -16,20 +17,21 @@ sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
-
- # git, tags available
- printf "%s" "$(git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//')"
+ printf '%s' "$(git describe --tags --long | sed 's/\([^-]*-g\)/r\1/;s/-/./g;s/^v//')"
}
build() {
cd "$pkgname"
+
./autogen.sh
+
./configure \
- --prefix=/usr \
- --enable-static=no \
- --enable-shared=yes \
- --enable-fast-install=yes \
+ --prefix='/usr' \
+ --enable-static='no' \
+ --enable-shared='yes' \
+ --enable-fast-install='yes' \
--enable-cpuflags
+
make
}