summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDarvin Delgado2023-06-25 12:51:22 -0400
committerDarvin Delgado2023-06-25 12:51:22 -0400
commitd1b00efbfd62ae8b29bad11ed57e5dfe9b8431fb (patch)
tree210febfa67175aa896b2fee35de2f75f9eb8d41f
parent5b0429a54a6130143c80e0f29f367c01344d55d5 (diff)
downloadaur-d1b00efbfd62ae8b29bad11ed57e5dfe9b8431fb.tar.gz
remove mangoapp
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD14
2 files changed, 7 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 110b926ab200..65dd04e9be6e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,13 @@
pkgbase = mangohud-git
pkgdesc = A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more.
- pkgver = 0.6.9.1.r79.g30748bd
- pkgrel = 2
+ pkgver = 0.6.9.1.r84.gbc8acf9
+ pkgrel = 1
url = https://github.com/flightlessmango/MangoHud
arch = x86_64
license = MIT
makedepends = git
makedepends = appstream
makedepends = cmocka
- makedepends = glfw-x11
makedepends = glslang
makedepends = libxnvctrl
makedepends = meson
@@ -26,8 +25,6 @@ pkgbase = mangohud-git
depends = spdlog
depends = vulkan-icd-loader
optdepends = libxnvctrl: NVIDIA GPU stats by XNVCtrl
- optdepends = glfw-x11: Required for MangoApp
- optdepends = gamescope: Use MangoApp as an overlay within gamescope
provides = mangohud
provides = mangoapp
conflicts = mangohud
diff --git a/PKGBUILD b/PKGBUILD
index 32c424d7050a..fd01e783c8e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,17 +1,15 @@
# Maintainer: Darvin Delgado <dnmodder at gmail dot com>
pkgname=mangohud-git
-pkgver=0.6.9.1.r79.g30748bd
-pkgrel=2
+pkgver=0.6.9.1.r84.gbc8acf9
+pkgrel=1
pkgdesc="A Vulkan overlay layer for monitoring FPS, temperatures, CPU/GPU load and more."
url='https://github.com/flightlessmango/MangoHud'
license=('MIT')
arch=('x86_64')
-makedepends=('git' 'appstream' 'cmocka' 'glfw-x11' 'glslang' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako')
+makedepends=('git' 'appstream' 'cmocka' 'glslang' 'libxnvctrl' 'meson' 'nlohmann-json' 'python-mako')
depends=('dbus' 'fmt' 'gcc-libs' 'glew' 'hicolor-icon-theme' 'libglvnd' 'libx11' 'python-matplotlib' 'python-numpy' 'spdlog' 'vulkan-icd-loader')
-optdepends=('libxnvctrl: NVIDIA GPU stats by XNVCtrl'
- 'glfw-x11: Required for MangoApp'
- 'gamescope: Use MangoApp as an overlay within gamescope')
+optdepends=('libxnvctrl: NVIDIA GPU stats by XNVCtrl')
provides=('mangohud' 'mangoapp')
conflicts=('mangohud' 'mangoapp' 'mangohud-common-git')
source=("$pkgname::git+$url")
@@ -25,9 +23,7 @@ pkgver() {
build() {
local meson_options=(
--wrap-mode=nofallback
- -Dmangoapp=true
- -Dmangohudctl=true
- -Dmangoapp_layer=true
+ -Dwith_wayland=enabled
$pkgname
)
arch-meson "${meson_options[@]}" build