summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwhoizit2022-06-24 16:03:03 +0300
committerwhoizit2022-06-24 16:04:02 +0300
commitd1d9a13fd3249041816460b616f80f7582b48495 (patch)
treeb116fac3f885e6ebe9aa58ff302db2ae3c206b35
parent2b352cd8a1e838acde3f175af8d569a1712f2435 (diff)
downloadaur-d1d9a13fd3249041816460b616f80f7582b48495.tar.gz
remove unneeded patch
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD12
-rw-r--r--uit_dl.c.patch29
3 files changed, 2 insertions, 41 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 955c2e0972bd..2ab284694bb5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,10 +14,8 @@ pkgbase = ncdc
depends = libmaxminddb
source = http://dev.yorhel.nl/download/ncdc-1.23.tar.gz
source = http://dev.yorhel.nl/download/ncdc-1.23.tar.gz.asc
- source = uit_dl.c.patch
validpgpkeys = 74460D32B80810EBA9AFA2E962394C698C2739FA
sha512sums = c1b2098df517631a64b24efaeb328a796ed716dca08b61248bb39bba866055ce1e017f33cc594197824476ec65ada53b13bfb56878b5b8aa330288017ad15df2
sha512sums = SKIP
- sha512sums = 8a4f10ecb9da5793fa4c705360b8a8e92206ac3b327507387bc4f22290bc2c77b4291f258d196d6bc63358324979b642e0ec579dff92405a5b209b2921b33f35
pkgname = ncdc
diff --git a/PKGBUILD b/PKGBUILD
index 09ab19488fe2..7e1985cfafe3 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,22 +6,15 @@
pkgname=ncdc
pkgver=1.23
-pkgrel=1
+pkgrel=2
pkgdesc='Modern and lightweight direct connect client with a friendly ncurses interface'
arch=('i686' 'x86_64' 'arm' 'armv6h')
url='http://dev.yorhel.nl/ncdc'
license=('MIT')
depends=('gnutls' 'sqlite' 'glib2' 'libmaxminddb')
-source=(
- "http://dev.yorhel.nl/download/$pkgname-$pkgver.tar.gz"{,.asc}
- uit_dl.c.patch
-)
+source=("http://dev.yorhel.nl/download/$pkgname-$pkgver.tar.gz"{,.asc})
validpgpkeys=('74460D32B80810EBA9AFA2E962394C698C2739FA') # Yoran Heling, only used for releases
-prepare() {
- patch --directory="$pkgname-$pkgver" --forward --strip=1 --input="${srcdir}/uit_dl.c.patch"
-}
-
build() {
cd "$srcdir/$pkgname-$pkgver"
./configure --prefix=/usr --with-geoip
@@ -37,5 +30,4 @@ package() {
sha512sums=(
'c1b2098df517631a64b24efaeb328a796ed716dca08b61248bb39bba866055ce1e017f33cc594197824476ec65ada53b13bfb56878b5b8aa330288017ad15df2'
'SKIP'
- '8a4f10ecb9da5793fa4c705360b8a8e92206ac3b327507387bc4f22290bc2c77b4291f258d196d6bc63358324979b642e0ec579dff92405a5b209b2921b33f35'
)
diff --git a/uit_dl.c.patch b/uit_dl.c.patch
deleted file mode 100644
index e740150a5126..000000000000
--- a/uit_dl.c.patch
+++ /dev/null
@@ -1,29 +0,0 @@
-From 4126dd51e90deb9e22dfd139cc4518a7812fcad6 Mon Sep 17 00:00:00 2001
-From: Yorhel <git@yorhel.nl>
-Date: Fri, 29 Oct 2021 14:29:45 +0200
-Subject: uit_dl.c: Use mvaddstr() instead of mvprintw() for dynamic string
-
-Trips up on Debian: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=997167
-
-Not actually a bug in this case, the given string cannot contain printf
-formatting codes.
----
- src/uit_dl.c | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/src/uit_dl.c b/src/uit_dl.c
-index 2012b49..dd75144 100644
---- a/src/uit_dl.c
-+++ b/src/uit_dl.c
-@@ -224,7 +224,7 @@ static void t_draw(ui_tab_t *tab) {
- if(sel) {
- char hash[40] = {};
- base32_encode(sel->hash, hash);
-- mvprintw(bottom, 0, hash);
-+ mvaddstr(bottom, 0, hash);
- } else
- mvaddstr(bottom, 0, "Nothing selected.");
- mvprintw(bottom, wincols-19, "%5d files - %3d%%", g_hash_table_size(dl_queue), pos);
---
-cgit v1.2.3
-