summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2017-05-15 00:23:40 -0400
committerKyle Sferrazza2017-05-15 00:23:40 -0400
commitd1e82d4bcf09a97a9c3d477763122756e76bdf79 (patch)
tree82fe36c1fb43ff043133ea1d2fab6196b34a549a
parent8b4baf3a54fdfb008db1700b16131213da0c6a42 (diff)
downloadaur-d1e82d4bcf09a97a9c3d477763122756e76bdf79.tar.gz
oh wow it works
-rw-r--r--.SRCINFO7
-rw-r--r--PKGBUILD17
-rwxr-xr-xbuild.sh20
3 files changed, 10 insertions, 34 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6acf5aa9f696..19ce11a7c1c1 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = powershell
pkgdesc = A cross-platform automation and configuration tool/framework
pkgver = 6.0.0.alpha.18
- pkgrel = 2
+ pkgrel = 1
url = https://github.com/PowerShell/PowerShell
arch = x86_64
license = MIT
@@ -9,21 +9,18 @@ pkgbase = powershell
makedepends = cmake
makedepends = proot
makedepends = dotnet
- makedepends = dotnet-cli
makedepends = dotnet-sdk
depends = bash
- depends = icu55
+ depends = icu
conflicts = powershell-git
source = powershell::git+https://github.com/PowerShell/PowerShell.git#tag=v6.0.0-alpha.18
source = pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
source = googletest::git+https://github.com/google/googletest.git
source = os-release
- source = build.sh
md5sums = SKIP
md5sums = SKIP
md5sums = SKIP
md5sums = f5841baa62b1322c07f9394940cec818
- md5sums = d20378ea8504200919c65de6592f0b24
pkgname = powershell
diff --git a/PKGBUILD b/PKGBUILD
index 711b7530e102..c4c1e9d45050 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,24 +3,22 @@
pkgname=powershell
_pkgver=6.0.0-alpha.18
pkgver=${_pkgver/-/.}
-pkgrel=2
+pkgrel=1
pkgdesc="A cross-platform automation and configuration tool/framework"
arch=('x86_64')
url="https://github.com/PowerShell/PowerShell"
license=('MIT')
-makedepends=('git' 'cmake' 'proot' 'dotnet' 'dotnet-cli' 'dotnet-sdk')
-depends=('bash' 'icu55')
+makedepends=('git' 'cmake' 'proot' 'dotnet' 'dotnet-sdk')
+depends=('bash' 'icu')
conflicts=('powershell-git')
source=($pkgname::git+https://github.com/PowerShell/PowerShell.git#tag=v$_pkgver
pester::git+https://github.com/PowerShell/psl-pester.git#branch=develop
googletest::git+https://github.com/google/googletest.git
- os-release
- build.sh)
+ os-release)
md5sums=('SKIP'
'SKIP'
'SKIP'
- 'f5841baa62b1322c07f9394940cec818'
- 'd20378ea8504200919c65de6592f0b24')
+ 'f5841baa62b1322c07f9394940cec818')
prepare() {
cd $pkgname
@@ -42,7 +40,7 @@ build() {
popd
PROOT_NO_SECCOMP=1 \
- proot -b "$srcdir"/os-release:/etc/os-release "$srcdir"/build.sh
+ proot -b "$srcdir"/os-release:/etc/os-release "$srcdir"/powershell/build.sh
}
check() {
@@ -59,10 +57,11 @@ package() {
mkdir -p "$pkgdir"/usr/lib/$pkgname
cp -a bin/Linux/netcoreapp*/ubuntu.16.04-x64 "$pkgdir"/usr/lib/$pkgname
+ chmod +x "$pkgdir"/usr/lib/$pkgname
mkdir -p "$pkgdir"/usr/share/licenses/$pkgname
cp ../../LICENSE.txt "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
mkdir -p "$pkgdir"/usr/bin
- ln -s /usr/lib/$pkgname/ubuntu.16.04-x64/powershell "$pkgdir"/usr/bin/powershell
+ ln -s "$pkgdir"/usr/lib/$pkgname/ubuntu.16.04-x64/powershell "$pkgdir"/usr/bin/powershell
}
diff --git a/build.sh b/build.sh
deleted file mode 100755
index de97396b2159..000000000000
--- a/build.sh
+++ /dev/null
@@ -1,20 +0,0 @@
-#!/usr/bin/env bash
-
-dotnet restore
-
-pushd src/ResGen
-dotnet run -c Linux
-popd
-
-pushd src/TypeCatalogParser
-dotnet run -c Linux
-popd
-
-pushd src/TypeCatalogGen
-dotnet run -c Linux ../Microsoft.PowerShell.CoreCLR.AssemblyLoadContext/CorePsTypeCatalog.cs powershell.inc
-popd
-
-cd src/powershell-unix
-dotnet build -c Linux && dotnet publish --no-build -c Linux
-
-# vim:set ts=2 sw=2 et: