summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorWill Adams2015-07-27 20:06:29 -0400
committerWill Adams2015-07-27 20:06:29 -0400
commitd231f99512649bddc681d0b8b36b1f28b1dbcef8 (patch)
treeb3198c12db37af2aa4712e946ddbcad38f825748
downloadaur-d231f99512649bddc681d0b8b36b1f28b1dbcef8.tar.gz
Initial commit
-rw-r--r--.SRCINFO32
-rw-r--r--PKGBUILD41
-rw-r--r--firefox-esr-safe.desktop13
-rw-r--r--firefox-esr.desktop13
-rw-r--r--firefox-esr.install12
5 files changed, 111 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6e916b528f70
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,32 @@
+pkgbase = firefox-esr-bin
+ pkgdesc = Standalone web browser from mozilla.org - Extended Support Release
+ pkgver = 38.1.0
+ pkgrel = 1
+ url = http://www.mozilla.org/en-US/firefox/organizations/
+ install = firefox-esr.install
+ arch = i686
+ arch = x86_64
+ license = MPL
+ license = GPL
+ license = LGPL
+ depends = gtk2
+ depends = dbus-glib
+ depends = desktop-file-utils
+ depends = libxt
+ depends = mime-types
+ depends = nss
+ depends = shared-mime-info
+ depends = gconf
+ optdepends = libgnome: fixes file association/default browser issues on GNOME desktops.
+ optdepends = gstreamer0.10: HTML5 video
+ optdepends = gstreamer0.10-good-plugins: h.264 video
+ provides = firefox=38
+ source = http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/38.1.0esr/linux-/en-US/firefox-38.1.0esr.tar.bz2
+ source = firefox-esr.desktop
+ source = firefox-esr-safe.desktop
+ sha512sums = 7d0881a1d5c5d96ac14cce535258127ce4a02591d6cb8020b825889a0b988cfcd55fbe5716ee681e7e4598f1f30f2e80339b91fedb92da90319c0b9a7af817cd
+ sha512sums = 2c2c70cb48202d47e7d3b376b8181e7398b23bb83f5da7724f6290709fe1ff3dca9d9c5666310982569beeeba39ec2d55a4372819f9914c79c6583de7eec06ba
+ sha512sums = 8942b11a7cb3761de1185491397185743adf49daa27a2806d14a328a2be8e2cb566c71dc6449016549cb3bd0d328cfe15944490be749a4add213194f6153c3d0
+
+pkgname = firefox-esr-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..de0d8fa1ed9b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Will Adams <info at clementlumber dot com>
+# Previous Maintainer: T. Jameson Little <t.jameson.little at gmail dot com>
+# Previous Maintainer: Stephen Michael <ihateseptictanks at gmail dot com>
+# Previous Maintainer: Simon Tunnat <simon+aur@tunn.at>
+# Contributor: Bartlomiej Piotrowski <nospam@bpiotrowski.pl>
+
+pkgname=firefox-esr-bin
+_pkgname=${pkgname/-bin/}
+pkgver=38.1.0
+pkgrel=1
+pkgdesc='Standalone web browser from mozilla.org - Extended Support Release'
+url='http://www.mozilla.org/en-US/firefox/organizations/'
+arch=('i686' 'x86_64')
+depends=('gtk2' 'dbus-glib' 'desktop-file-utils' 'libxt' 'mime-types' 'nss' 'shared-mime-info' 'gconf')
+optdepends=('libgnome: fixes file association/default browser issues on GNOME desktops.'
+ 'gstreamer0.10: HTML5 video'
+ 'gstreamer0.10-good-plugins: h.264 video'
+ )
+provides=('firefox=38')
+
+license=('MPL' 'GPL' 'LGPL')
+install=$_pkgname.install
+source=(http://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${pkgver}esr/linux-$CARCH/en-US/firefox-${pkgver}esr.tar.bz2
+ $_pkgname.desktop
+ $_pkgname-safe.desktop)
+sha512sums=('7d0881a1d5c5d96ac14cce535258127ce4a02591d6cb8020b825889a0b988cfcd55fbe5716ee681e7e4598f1f30f2e80339b91fedb92da90319c0b9a7af817cd'
+ '2c2c70cb48202d47e7d3b376b8181e7398b23bb83f5da7724f6290709fe1ff3dca9d9c5666310982569beeeba39ec2d55a4372819f9914c79c6583de7eec06ba'
+ '8942b11a7cb3761de1185491397185743adf49daa27a2806d14a328a2be8e2cb566c71dc6449016549cb3bd0d328cfe15944490be749a4add213194f6153c3d0')
+[ "$CARCH" == "i686" ] && sha512sums[0]='5c18f8dfbcb22d6f3a53e30fe6cd066f836057722aa274b8bb925770d6bc82f4e121d236da3de5c465a9f40f057ad350f5ea4ff46633e1934b9e090eee852596'
+
+
+package() {
+ cd $srcdir
+
+ install -d $pkgdir/{usr/{bin,share/{applications,pixmaps}},opt}
+ cp -r firefox/ $pkgdir/opt/$_pkgname
+
+ ln -s /opt/$_pkgname/firefox $pkgdir/usr/bin/$_pkgname
+ install -m644 $srcdir/{$_pkgname.desktop,$_pkgname-safe.desktop} $pkgdir/usr/share/applications/
+ install -m644 $srcdir/firefox/browser/icons/mozicon128.png $pkgdir/usr/share/pixmaps/$_pkgname.png
+}
diff --git a/firefox-esr-safe.desktop b/firefox-esr-safe.desktop
new file mode 100644
index 000000000000..3cf9914787c7
--- /dev/null
+++ b/firefox-esr-safe.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=Firefox ESR - Safe Mode
+GenericName=Web Browser - Safe Mode
+Icon=firefox-esr
+Type=Application
+Categories=Application;Network;
+MimeType=text/html
+Encoding=UTF-8
+Exec=firefox-esr -safe-mode %u
+Terminal=false
+MultipleArgs=false
+StartupNotify=false
+StartupWMClass=Firefox
diff --git a/firefox-esr.desktop b/firefox-esr.desktop
new file mode 100644
index 000000000000..e07dc7a852af
--- /dev/null
+++ b/firefox-esr.desktop
@@ -0,0 +1,13 @@
+[Desktop Entry]
+Name=Firefox ESR
+GenericName=Web Browser
+Icon=firefox-esr
+Type=Application
+Categories=Application;Network;
+MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;
+Encoding=UTF-8
+Exec=firefox-esr %u
+Terminal=false
+MultipleArgs=false
+StartupNotify=false
+StartupWMClass=Firefox
diff --git a/firefox-esr.install b/firefox-esr.install
new file mode 100644
index 000000000000..c317fbaca442
--- /dev/null
+++ b/firefox-esr.install
@@ -0,0 +1,12 @@
+post_install() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_upgrade() {
+ post_install
+}
+
+post_remove() {
+ post_install
+}