summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHomer Xing2021-12-18 19:48:28 -0800
committerHomer Xing2021-12-18 19:51:32 -0800
commitd2386af7e4f7da6a7f47d5153d519a0ad9e64ffd (patch)
tree2b8771c4a2ccebc667e02fda64ca4d801d02a000
parent6108ca730def03de1053b48bc697bae45cf11dda (diff)
downloadaur-d2386af7e4f7da6a7f47d5153d519a0ad9e64ffd.tar.gz
update package build file
update description update homepage URL use upstream's markdown changelog file build package with "release" mode update maintainer list
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore3
-rw-r--r--PKGBUILD37
-rw-r--r--zsxd.changelog.md (renamed from zsxd.changelog)53
4 files changed, 58 insertions, 44 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 41c144d89271..cec09c103eed 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,9 +1,9 @@
pkgbase = zsxd
- pkgdesc = The Legend of Zelda XD: Mystery of Solarus - Parodic fangame
+ pkgdesc = Zelda: Mystery of Solarus XD - an open-source parodic fangame
pkgver = 1.12.2
- pkgrel = 3
- url = http://www.zelda-solarus.com/
- changelog = zsxd.changelog
+ pkgrel = 4
+ url = https://https://www.solarus-games.org/en/games/the-legend-of-zelda-mystery-of-solarus-xd
+ changelog = zsxd.changelog.md
arch = any
license = GPL3
license = custom
@@ -14,4 +14,3 @@ pkgbase = zsxd
b2sums = 1cba628a427cae10e0b08498690b95ef5a60f62531b1b4c7635ccbd561201ff54511b5c32e8e5e3251625e08276466ef2faa81f62eb2b67669cc001b00b7f215
pkgname = zsxd
-
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..8d87ae630b2f
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,3 @@
+src/
+pkg/
+zsxd* \ No newline at end of file
diff --git a/PKGBUILD b/PKGBUILD
index 76099caf23a9..a9b2bf794a49 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Qontinuum <qontinuum.dev@protonmail.ch>
+# Maintainer: Homer Xing <homer dot hsing @t gmail dot com>
+# Contributor: Qontinuum <qontinuum dot dev @t protonmail dot ch>
# Contributor: BenObiWan <benobiwan @t gmail dot com>
# Contributor: Sam101 <zoetrem @t gmail dot com>
# Contributor: BenObiWan <benobiwan @t gmail dot com>
@@ -6,27 +7,37 @@
pkgname=zsxd
pkgver=1.12.2
-pkgrel=3
-pkgdesc="The Legend of Zelda XD: Mystery of Solarus - Parodic fangame"
+pkgrel=4
+epoch=
+pkgdesc="Zelda: Mystery of Solarus XD - an open-source parodic fangame"
arch=('any')
-url="http://www.zelda-solarus.com/"
+url="https://www.solarus-games.org/en/games/the-legend-of-zelda-mystery-of-solarus-xd"
license=('GPL3' 'custom')
+groups=()
depends=('solarus>=1.6.0')
makedepends=('cmake' 'zip')
-changelog="$pkgname.changelog"
-source=("https://gitlab.com/solarus-games/$pkgname/-/archive/v$pkgver/$pkgname-v$pkgver.tar.gz")
+checkdepends=()
+optdepends=()
+provides=()
+conflicts=()
+replaces=()
+backup=()
+options=()
+install=
+changelog="${pkgname}.changelog.md"
+source=("https://gitlab.com/solarus-games/${pkgname}/-/archive/v${pkgver}/${pkgname}-v${pkgver}.tar.gz")
+noextract=()
+validpgpkeys=()
b2sums=('1cba628a427cae10e0b08498690b95ef5a60f62531b1b4c7635ccbd561201ff54511b5c32e8e5e3251625e08276466ef2faa81f62eb2b67669cc001b00b7f215')
build() {
- cd "${pkgname}-v${pkgver}"
- cmake -DCMAKE_INSTALL_PREFIX="/usr" .
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+ cmake -D CMAKE_INSTALL_PREFIX=/usr -D CMAKE_BUILD_TYPE=Release .
make
}
package() {
- cd "${pkgname}-v${pkgver}"
- make DESTDIR="${pkgdir}/" install
- install -Dm644 license.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
+ cd "${srcdir}/${pkgname}-v${pkgver}"
+ make DESTDIR="${pkgdir}/" PREFIX=/usr install
+ install -Dm644 license.txt "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}
-
-
diff --git a/zsxd.changelog b/zsxd.changelog.md
index 3778a2f9a5eb..e5acad54ecec 100644
--- a/zsxd.changelog
+++ b/zsxd.changelog.md
@@ -1,55 +1,57 @@
-Zelda Mystery of Solarus XD 1.12.2 (2019-08-15)
+# Changelog
+
+## Zelda Mystery of Solarus XD 1.12.2 (2019-08-15)
* Fix freaking cave teletransporters broken in 1.6.1.
-Zelda Mystery of Solarus XD 1.12.1 (2019-08-10)
+## Zelda Mystery of Solarus XD 1.12.1 (2019-08-10)
* Fix torch displayed above the hero in dungeon 1 (#55).
-Zelda Mystery of Solarus XD 1.12.0 (2018-12-22)
+## Zelda Mystery of Solarus XD 1.12.0 (2018-12-22)
* Upgrade to Solarus 1.6.
* Add the Solarus team logo.
* Change the sound of the Solarus logo.
* Slightly improve English dialogs
-Zelda Mystery of Solarus XD 1.11.1 (in progress)
+## Zelda Mystery of Solarus XD 1.11.1 (in progress)
* Fix font size in the options pause menu (#44).
-Zelda Mystery of Solarus XD 1.11.0 (2016-07-27)
+## Zelda Mystery of Solarus XD 1.11.0 (2016-07-27)
* Upgrade to Solarus 1.5.0.
* Fix typo in French dialogs.
-Zelda Mystery of Solarus XD 1.10.3 (2015-12-20)
+## Zelda Mystery of Solarus XD 1.10.3 (2015-12-20)
* Fix game-over stopped sometimes using a workaround.
* Fix dialog cursor drawn at wrong position after successive questions.
-Zelda Mystery of Solarus XD 1.10.2 (2015-11-22)
+## Zelda Mystery of Solarus XD 1.10.2 (2015-11-22)
* Upgrade to Solarus 1.4.5.
* Make fairies play a sound when restoring life even when already full.
* Fix dialog cursor drawn at wrong position after successive questions.
-Zelda Mystery of Solarus XD 1.10.1 (2015-05-09)
+## Zelda Mystery of Solarus XD 1.10.1 (2015-05-09)
* Upgrade to Solarus 1.4.1.
-Zelda Mystery of Solarus XD 1.10.0 (2015-05-02)
+## Zelda Mystery of Solarus XD 1.10.0 (2015-05-02)
* Upgrade to Solarus 1.4.0.
* Fix fairy only restoring 1/4 heart in cursed cave (#40).
-Zelda Mystery of Solarus XD 1.9.0 (2014-08-21)
+## Zelda Mystery of Solarus XD 1.9.0 (2014-08-21)
* Use Solarus 1.3.0.
* Make cmake paths more modifiable. By hasufell.
* Fix direction of vertical movement on joypad in menus.
* Clarify license of some files.
-Zelda Mystery of Solarus XD 1.8.0 (2014-05-06)
+## Zelda Mystery of Solarus XD 1.8.0 (2014-05-06)
* Use solarus 1.2.0.
* Spanish translation (beta). Thanks Xexio!
@@ -59,14 +61,14 @@ Zelda Mystery of Solarus XD 1.8.0 (2014-05-06)
* Fix a typo in French dialogs.
* Fix the position of some diagonal jumpers.
-Zelda Mystery of Solarus XD 1.7.1 (2013-12-01)
+## Zelda Mystery of Solarus XD 1.7.1 (2013-12-01)
* Use Solarus 1.1.1.
* Fix Creepers never exploding after they are hurt (#16).
* Fix a typo in English dialogs.
* Fix the debugging console no longer working after using F1, F2 or F3.
-Zelda Mystery of Solarus XD 1.7.0 (2013-10-13)
+## Zelda Mystery of Solarus XD 1.7.0 (2013-10-13)
* Use Solarus 1.1.0.
* Replace .spc musics by .it musics (faster) and remove unused ones.
@@ -76,18 +78,18 @@ Zelda Mystery of Solarus XD 1.7.0 (2013-10-13)
* Dungeon 1 3F: fix "attempt to compare number with nil" in counter 36 (#3).
* Dungeon 2 1F: fix an enemy not counting in WTF room.
-Zelda Mystery of Solarus XD 1.6.2 (2013-06-25)
+## Zelda Mystery of Solarus XD 1.6.2 (2013-06-25)
* Use solarus 1.0.4.
* Fix a crash due to a missing text in the French options pause menu.
* Fix a crash due to an invalid treasure in a pot of crazy house 1F.
* Fix a typo in the French inventory pause menu.
-Zelda Mystery of Solarus XD 1.6.1 (2013-06-25)
+## Zelda Mystery of Solarus XD 1.6.1 (2013-06-25)
* Use solarus 1.0.3.
-Zelda Mystery of Solarus XD 1.6 (2013-06-22)
+## Zelda Mystery of Solarus XD 1.6 (2013-06-22)
* Use solarus 1.0.2.
* Improve the English translation.
@@ -95,7 +97,7 @@ Zelda Mystery of Solarus XD 1.6 (2013-06-22)
* Fix all missing empty lines in dialogs.
* Add the Solarus engine logo at startup.
-Zelda Mystery of Solarus XD 1.5.3 (2013-05-08)
+## Zelda Mystery of Solarus XD 1.5.3 (2013-05-08)
* Use solarus 0.9.3.
* Dungeon 2: the piece of heart could be obtained very easily with the sword
@@ -104,42 +106,41 @@ Zelda Mystery of Solarus XD 1.5.3 (2013-05-08)
* Fix the CMake script that creates the zip archive.
* Make creepers appear earlier in the game (#1).
-Zelda Mystery of Solarus XD 1.5.2 (2012-03-31)
+## Zelda Mystery of Solarus XD 1.5.2 (2012-03-31)
* Fix missing empty lines in the credits dialogs
-Zelda Mystery of Solarus XD 1.5.1 (2012-03-31)
+## Zelda Mystery of Solarus XD 1.5.1 (2012-03-31)
* Fix a crash during a dialog, introduced by zsxd 1.5
-Zelda Mystery of Solarus XD 1.5 (2012-02-12)
+## Zelda Mystery of Solarus XD 1.5 (2012-02-12)
* Use solarus-0.9.1
* Fix a typo in a dialog
* Change the color of the splash sprites when plunging into lava
-Zelda Mystery of Solarus XD 1.4 (2011-12-23)
+## Zelda Mystery of Solarus XD 1.4 (2011-12-23)
* Use solarus-0.9.0 (changelogs of solarus and zsxd will now be separated)
* Includes all improvements and bug fixes of solarus since zsxd-1.3
* Fix a duplicate heart container
-Zelda Mystery of Solarus XD 1.3 (2011-08-12)
+## Zelda Mystery of Solarus XD 1.3 (2011-08-12)
* Add the English translation
* Fix a precision bug with sensors
-Zelda Mystery of Solarus XD 1.2 (2011-04-23)
+## Zelda Mystery of Solarus XD 1.2 (2011-04-23)
* Fix a Windows issue with mono sound effects
-Zelda Mystery of Solarus XD 1.1 (2011-04-02)
+## Zelda Mystery of Solarus XD 1.1 (2011-04-02)
* Use libvorbisfile instead of libsndfile for sound effects
* Replace the last sword by a new rupee bag
* Various minor improvements
-Zelda Mystery of Solarus XD 1.0 (2011-04-01)
+## Zelda Mystery of Solarus XD 1.0 (2011-04-01)
* Initial release of Zelda Mystery of Solarus XD
-