summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMāris Vilks2022-04-29 13:39:25 +0300
committerMāris Vilks2022-04-29 13:39:25 +0300
commitd23927d3ca264a6abd1c945a51379631a9cddb73 (patch)
tree42fe63777ff7180f0203172a68047ab420d049f1
parent8db680e880776a293a415d3f0208a1a537394652 (diff)
downloadaur-d23927d3ca264a6abd1c945a51379631a9cddb73.tar.gz
Patched pintool path; added notes on PKCS#11 module installation
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD12
-rw-r--r--middleware.install14
-rw-r--r--pintool.patch11
4 files changed, 38 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 9a539fb4f88b..bf83bf501084 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = latvia-eid-middleware
pkgdesc = Middleware for using Latvia-eid smart cards
pkgver = 2.0.10
- pkgrel = 1
+ pkgrel = 2
url = https://www.eparaksts.lv
install = middleware.install
arch = x86_64
@@ -12,7 +12,10 @@ pkgbase = latvia-eid-middleware
depends = libsm
depends = pcsclite
depends = glu
+ optdepends = nss: modutil tool for installing PKCS#11 module
source = https://www.eparaksts.lv/files/ep3updates/debian/pool/eparaksts/l/latvia-eid-middleware/latvia-eid-middleware_2.0.10-1_amd64.deb
+ source = pintool.patch
sha512sums = 6a93c0f564dab7fc03e4eae8c31c63f08385dcffcc0c9d852fc6a847595252e60262f14c675456ab2d59596c4f6a1ca5305566342ca93cf6feb408a786e2cc6e
+ sha512sums = ff5513539072adf213105b473e7509c23ace523aa9d7cd536244ec76dd2afa28bc9494e321c35311d465c73cc1c1ca76eaa7d46c774f24d413b35abe2f54d3d8
pkgname = latvia-eid-middleware
diff --git a/PKGBUILD b/PKGBUILD
index 7d5f83b373d1..7cf3934082dc 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,19 +1,25 @@
# Maintainer: Māris Vilks <kaaposc@gmail.com>
pkgname=latvia-eid-middleware
pkgver=2.0.10
-pkgrel=1
+pkgrel=2
pkgdesc="Middleware for using Latvia-eid smart cards"
arch=('x86_64')
url="https://www.eparaksts.lv"
license=('LGPL')
groups=('eparaksts')
depends=('gtk2' 'openssl-1.0' 'libsm' 'pcsclite' 'glu')
+optdepends=('nss: modutil tool for installing PKCS#11 module')
install='middleware.install'
-source=("https://www.eparaksts.lv/files/ep3updates/debian/pool/eparaksts/l/${pkgname}/${pkgname}_${pkgver}-1_amd64.deb")
-sha512sums=('6a93c0f564dab7fc03e4eae8c31c63f08385dcffcc0c9d852fc6a847595252e60262f14c675456ab2d59596c4f6a1ca5305566342ca93cf6feb408a786e2cc6e')
+source=("https://www.eparaksts.lv/files/ep3updates/debian/pool/eparaksts/l/${pkgname}/${pkgname}_${pkgver}-1_amd64.deb"
+ "pintool.patch")
+sha512sums=('6a93c0f564dab7fc03e4eae8c31c63f08385dcffcc0c9d852fc6a847595252e60262f14c675456ab2d59596c4f6a1ca5305566342ca93cf6feb408a786e2cc6e'
+ 'ff5513539072adf213105b473e7509c23ace523aa9d7cd536244ec76dd2afa28bc9494e321c35311d465c73cc1c1ca76eaa7d46c774f24d413b35abe2f54d3d8')
package() {
tar --no-same-owner -xJf data.tar.xz -C "${pkgdir}"
+ cd "${pkgdir}"
+ patch --forward --strip=1 < "${srcdir}/pintool.patch"
+
}
diff --git a/middleware.install b/middleware.install
index d3cb885c1dd8..819d0cffac68 100644
--- a/middleware.install
+++ b/middleware.install
@@ -26,6 +26,20 @@ post_install() {
/sbin/ldconfig /opt/latvia-eid/lib
/sbin/ldconfig /usr/lib/pkcs11
/sbin/ldconfig
+
+ printf "$(tput setaf 4)NOTE: $(tput sgr0)To start using eID cards in browser either follow Mozilla docs:\n"
+ printf "$(tput setaf 2) https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/pkcs11\n"
+ printf "$(tput sgr0) or use $(tput setaf 2)modutil $(tput sgr0)tool from $(tput setaf 2)nss $(tput sgr0)package:\n"
+ printf "$(tput setaf 2) https://linuxkamarada.com/en/2019/09/26/setting-up-smart-card-authentication-on-google-chrome-chromium/\n"
+ printf "$(tput sgr0) using $(tput setaf 2)/opt/latvia-eid/lib/eidlv-pkcs11.so $(tput sgr0)library in both cases.\n"
+}
+
+post_upgrade() {
+ printf "$(tput setaf 4)NOTE: $(tput sgr0)To start using eID cards in browser either follow Mozilla docs:\n"
+ printf "$(tput setaf 2) https://developer.mozilla.org/en-US/docs/Mozilla/Add-ons/WebExtensions/API/pkcs11\n"
+ printf "$(tput sgr0) or use $(tput setaf 2)modutil $(tput sgr0)(from $(tput setaf 2)nss $(tput sgr0)package):\n"
+ printf "$(tput setaf 2) https://linuxkamarada.com/en/2019/09/26/setting-up-smart-card-authentication-on-google-chrome-chromium/\n"
+ printf "$(tput sgr0) using $(tput setaf 2)/opt/latvia-eid/lib/eidlv-pkcs11.so $(tput sgr0)library in both cases.\n"
}
pre_remove() {
diff --git a/pintool.patch b/pintool.patch
new file mode 100644
index 000000000000..45097706765b
--- /dev/null
+++ b/pintool.patch
@@ -0,0 +1,11 @@
+--- ./opt.back/latvia-eid/share/doc/latvia-eid/eidlv-pintool.desktop 2022-04-29 10:44:27.789165968 +0300
++++ ./opt/latvia-eid/share/doc/latvia-eid/eidlv-pintool.desktop 2022-04-29 10:46:52.372324610 +0300
+@@ -4,7 +4,7 @@
+ Name[lv]=Latvija-eID PinTool
+ Comment=Manage your Latvia-eID smart card
+ Comment[lv]=Pārvaldīt savu Latvija-eID viedkarti
+-Exec=otlv-pintool
++Exec=eidlv-pintool
+ Terminal=false
+ Type=Application
+ StartupNotify=false \ No newline at end of file