summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorRichard Mathot2017-10-26 17:19:39 +0200
committerRichard Mathot2017-10-26 17:21:13 +0200
commitd242ca551972a61cf0416183b21b9b2c4c1fc2df (patch)
treea2a09a780c6989e38fd22916eceaf2975cdcec2f
downloadaur-d242ca551972a61cf0416183b21b9b2c4c1fc2df.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..758a18cebe62
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = brother-dcpl2560dw-cups
+ pkgdesc = Brother DCP-L2560DW CUPS drivers.
+ pkgver = 3.2.0_1
+ pkgrel = 1
+ url = http://support.brother.com/g/b/downloadend.aspx?c=us&lang=en&prod=dcpl2540dw_us_as&os=127&dlid=dlf101716_000&flang=4&type3=560
+ arch = any
+ license = GPL2
+ license = custom:brother
+ depends = brother-dcpl2560dw-lpr
+ depends = cups
+ optdepends = brscan4: scanner support.
+ source = http://download.brother.com/welcome/dlf101766/dcpl2560dwcupswrapper-3.2.0-1.i386.rpm
+ md5sums = 15fa66efa16fb3a5b67554385dfe8d4d
+
+pkgname = brother-dcpl2560dw-cups
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ae921b760bbf
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Richard Mathot <rim@odoo.com>
+pkgname=brother-dcpl2560dw-cups
+pkgver=3.2.0_1
+pkgrel=1
+pkgdesc="Brother DCP-L2560DW CUPS drivers."
+arch=('any')
+url="http://support.brother.com/g/b/downloadend.aspx?c=gb&lang=en&prod=dcpl2560dw_eu&os=127&dlid=dlf101766_000&flang=4&type3=560"
+license=('GPL2' 'custom:brother')
+depends=('brother-dcpl2560dw-lpr' 'cups')
+optdepends=('brscan4: scanner support.')
+source=("http://download.brother.com/welcome/dlf101766/dcpl2560dwcupswrapper-${pkgver/_/-}.i386.rpm")
+md5sums=('15fa66efa16fb3a5b67554385dfe8d4d')
+
+prepare() {
+ sed -ie '47,53c my $basedir = "/opt/brother/Printers/DCPL2560DW";' \
+ ${srcdir}/opt/brother/Printers/DCPL2560DW/cupswrapper/brother_lpdwrapper_DCPL2560DW
+
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/share/cups/model/Brother
+ mkdir -p ${pkgdir}/usr/lib/cups/filter
+ cp ${srcdir}/opt/brother/Printers/DCPL2560DW/cupswrapper/brother-DCPL2560DW-cups-en.ppd ${pkgdir}/usr/share/cups/model/Brother
+ cp ${srcdir}/opt/brother/Printers/DCPL2560DW/cupswrapper/brother_lpdwrapper_DCPL2560DW ${pkgdir}/usr/lib/cups/filter
+}
+