summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorUniversebenzene2020-09-18 20:05:58 +0800
committerUniversebenzene2020-09-18 20:05:58 +0800
commitd25c8e779ff62bc9d38c0f60647c6a4e9086d878 (patch)
tree645f77caf0948873585bae94f6769a3156e2cc91
parenta3a400d5cd91ea91baa02ebe55817f73313a759d (diff)
downloadaur-d25c8e779ff62bc9d38c0f60647c6a4e9086d878.tar.gz
correct doc versioning
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD2
-rw-r--r--fix_doc_version.patch14
3 files changed, 6 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 62187de1cc81..2ddbf664b0de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -19,7 +19,7 @@ pkgbase = python-spectral-cube
source = https://files.pythonhosted.org/packages/source/s/spectral-cube/spectral-cube-0.5.0.tar.gz
source = fix_doc_version.patch
md5sums = fd3f45419a4b029887f3187929a321ec
- md5sums = 724c19919a17ff4be5ff5a7747ee6307
+ md5sums = 0c7fdbb48c8e090e6b29b4d03e6af0bb
pkgname = python-spectral-cube
depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 467f1b4f808c..a734e40cd3c8 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,7 +13,7 @@ checkdepends=('python-pytest-astropy-header' 'python-joblib' 'python-reproject'
source=("https://files.pythonhosted.org/packages/source/${_pyname:0:1}/${_pyname}/${_pyname}-${pkgver}.tar.gz"
'fix_doc_version.patch')
md5sums=('fd3f45419a4b029887f3187929a321ec'
- '724c19919a17ff4be5ff5a7747ee6307')
+ '0c7fdbb48c8e090e6b29b4d03e6af0bb')
prepare() {
cd ${srcdir}/${_pyname}-${pkgver}
diff --git a/fix_doc_version.patch b/fix_doc_version.patch
index bf7d316858bb..38e34b8b94ae 100644
--- a/fix_doc_version.patch
+++ b/fix_doc_version.patch
@@ -1,19 +1,13 @@
--- a/docs/conf.py 2020-09-18 04:29:50.000000000 +0800
-+++ b/docs/conf.py 2020-09-18 16:05:29.462123649 +0800
-@@ -76,8 +76,14 @@
++++ b/docs/conf.py 2020-09-18 19:54:11.025457472 +0800
+@@ -76,8 +76,8 @@
# |version| and |release|, also used in various other places throughout the
# built documents.
-from pkg_resources import get_distribution
-version = release = get_distribution(setup_cfg['name']).version
-+from pkg_resources import get_distribution, DistributionNotFound
-+try:
-+ __version__ = get_distribution(__name__)
-+except DistributionNotFound:
-+ __version__ = 'unknown'
-+
-+version = __version__
-+release = __version__
++from spectral_cube import __version__
++version = release = __version__
# -- Options for HTML output --------------------------------------------------