summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormeongbego2015-08-16 05:12:30 +0800
committermeongbego2015-08-16 05:12:30 +0800
commitd267f86c6717bbf67b6c31510bd22e3578e79ef8 (patch)
tree059c2d6c2a5e63b02e7458fb6f4c116a95158ca0
downloadaur-d267f86c6717bbf67b6c31510bd22e3578e79ef8.tar.gz
IGNSDK IOT For Raspberry Pi 2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
-rw-r--r--ignsdk.install14
3 files changed, 71 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b8e5f66ac294
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = ignsdk
+ pkgdesc = IGN Software Development Kit IOT For Raspberry Pi type 2
+ pkgver = 0.1.3
+ pkgrel = 160815
+ url = https://github.com/anak10thn/ignsdk-qt
+ install = ignsdk.install
+ arch = armv7h
+ license = BSD
+ depends = qt5-base
+ depends = qt5-webkit
+ depends = qt5-websockets
+ depends = qt5-serialport
+ options = !strip
+ options = !emptydirs
+ source = https://github.com/anak10thn/ignsdk-iot/archive/0.1.3.tar.gz
+ md5sums = SKIP
+
+pkgname = ignsdk
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..594fa49f90a0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+##Author##
+#Eka Tresna Irawan/Ibnu Yahya (anak10thn@gmail.com)
+#PKGBUILD
+#Sofyan Saputra/Iank (meongbego@gmail.com)
+
+pkgname=ignsdk
+pkgver=0.1.3
+pkgrel=160815
+pkgdesc="IGN Software Development Kit IOT For Raspberry Pi type 2"
+url="https://github.com/anak10thn/ignsdk-qt"
+arch=('armv7h')
+license=('BSD')
+depends=('qt5-base' 'qt5-webkit' 'qt5-websockets' 'qt5-serialport')
+options=('!strip' '!emptydirs')
+source=('https://github.com/anak10thn/ignsdk-iot/archive/0.1.3.tar.gz')
+md5sums=('SKIP')
+_gourl=github.com/anak10thn/ignsdk-qt
+install='ignsdk.install'
+
+build() {
+ cd ignsdk-iot-0.1.3
+ qmake
+ make -j4
+}
+
+package() {
+ cd ignsdk-iot-0.1.3
+ mkdir -p $pkgdir/usr/bin/
+ mkdir -p $pkgdir/etc/ignsdk/board
+
+ install -Dm 755 bin/ignsdk-iot $pkgdir/usr/bin/
+ install -Dm 755 config/rpi2.json $pkgdir/etc/ignsdk/board
+
+ rm -rf *.o
+
+}
+
+
diff --git a/ignsdk.install b/ignsdk.install
new file mode 100644
index 000000000000..65467a5cd853
--- /dev/null
+++ b/ignsdk.install
@@ -0,0 +1,14 @@
+post_install(){
+ echo -e "see the following users guides"
+ echo -e "man -u -a ignsdk"
+ echo -e "man -u -a ignsdk-app-creator"
+ echo -e "man -u -a ignsdk-app-builder"
+
+ echo -e "Thank You For Installations"
+}
+
+post_remove(){
+ echo -e "thanks for your installations\n"
+ echo -e "good bye"
+}
+