summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormutantmonkey2013-03-02 17:53:31 -0500
committermutantmonkey2013-03-02 17:53:31 -0500
commitd2bd7590d9e9b274bc5bb1027dbd80b6becf8809 (patch)
tree42e855f5a7cf753a783d775b01cc23d2e823bc6d
downloadaur-d2bd7590d9e9b274bc5bb1027dbd80b6becf8809.tar.gz
import my AUR packages into git
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD20
2 files changed, 39 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..315cca5923f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = whatmp3
+ pkgdesc = A small Python script that accepts a list of directories containing FLAC files as arguments and converts them to MP3 with the specified options. It can optionally create a torrent file.
+ pkgver = 3.5.3
+ pkgrel = 1
+ url = http://logik.li/projects/whatmp3/
+ arch = any
+ license = MIT
+ depends = python
+ depends = mktorrent
+ depends = flac
+ depends = lame
+ optdepends = vorbis-tools: OGG Vorbis support
+ optdepends = neroaacenc: AAC support
+ optdepends = neroaactag: AAC support
+ source = http://logik.li/projects/whatmp3/whatmp3-3.5.3.tar.gz
+ sha256sums = 2856215a99eefb8cb1eccbbaa0e7b06e8c97509b499d13cbd5392598bd2384ae
+
+pkgname = whatmp3
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..01835b84f544
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Contributor: mutantmonkey <mutantmonkey@gmail.com>
+pkgname=whatmp3
+pkgver=3.5.1
+pkgrel=1
+pkgdesc="A small Python script that accepts a list of directories containing FLAC files as arguments and converts them to MP3 with the specified options. It can optionally create a torrent file."
+url="http://logik.li/projects/whatmp3/"
+arch=('any')
+license=('MIT')
+depends=('python' 'mktorrent' 'flac' 'lame')
+optdepends=('vorbis-tools: OGG Vorbis support'
+ 'neroaacenc: AAC support'
+ 'neroaactag: AAC support')
+source=("http://logik.li/projects/${pkgname}/${pkgname}-${pkgver}.tar.gz")
+md5sums=('f3a71fe0b0d85df681f868e7ede871de')
+sha256sums=('0dd9018e845c25fc7155394c2f08d3163f5f009db50d108364258d2cecdd1bad')
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ install -D whatmp3 ${pkgdir}/usr/bin/whatmp3
+}