summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Wojdyła2023-08-21 23:22:25 +0200
committerMichał Wojdyła2023-08-21 23:22:25 +0200
commitd2bf0d4f19f09f83d0d6292f9f6441e443ac225d (patch)
tree59b09aebe4d4ebe62bcdfb612a5f07fca6f75e99
parent3cdb507d7ea893baa4fe905182b6c3e45247d1b1 (diff)
downloadaur-d2bf0d4f19f09f83d0d6292f9f6441e443ac225d.tar.gz
Update package
add which dependency fix missing include (not sure if upstream problem or not) remove circular dependency, should improve package handling for AUR helpers
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD17
-rw-r--r--patch.patch10
3 files changed, 25 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c6f8bc9ee480..43b269689ea6 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = 0ad-git
pkgdesc = Cross-platform, 3D and historically-based real-time strategy game - built from git development version.
- pkgver = A26.r63.g43444ea887
+ pkgver = A26.r920.gc4a0ae4ff
pkgrel = 1
epoch = 1
url = http://play0ad.com/
@@ -15,7 +15,6 @@ pkgbase = 0ad-git
makedepends = libsm
makedepends = rust
makedepends = python
- makedepends = clang
makedepends = git
makedepends = enet
makedepends = fmt
@@ -34,10 +33,12 @@ pkgbase = 0ad-git
makedepends = wxwidgets-gtk3
options = !lto
source = git+https://github.com/0ad/0ad.git
+ source = patch.patch
md5sums = SKIP
+ md5sums = dcbd62e1fb4669c24318c8fe66143c4f
pkgname = 0ad-git
- depends = 0ad-data-git
+ depends = 0ad-data
depends = binutils
depends = boost-libs
depends = curl
@@ -59,11 +60,11 @@ pkgname = 0ad-git
depends = icu
depends = nspr
depends = libsodium
+ depends = which
provides = 0ad
conflicts = 0ad
pkgname = 0ad-data-git
pkgdesc = Data package for 0ad built from git development version.
- depends = 0ad-git
provides = 0ad-data
conflicts = 0ad-data
diff --git a/PKGBUILD b/PKGBUILD
index 031e95dfb1d0..acbb4ebc5f08 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -7,19 +7,19 @@
pkgname=('0ad-git' '0ad-data-git')
_pkgname=0ad
epoch=1
-pkgver=A26.r63.g43444ea887
+pkgver=A26.r920.gc4a0ae4ff
pkgrel=1
pkgdesc="Cross-platform, 3D and historically-based real-time strategy game - built from git development version."
arch=('i686' 'x86_64')
url="http://play0ad.com/"
license=('GPL2' 'CCPL')
-makedepends=('boost' 'cmake' 'mesa' 'zip' 'libsm' 'rust' 'python' 'clang' 'git'
+makedepends=('boost' 'cmake' 'mesa' 'zip' 'libsm' 'rust' 'python' 'git'
'enet' 'fmt' 'gloox' 'glu' 'libgl' 'libminiupnpc.so' 'libogg'
'libpng' 'libsodium' 'libvorbis' 'miniupnpc' 'nspr' 'openal'
'sdl2' 'wxwidgets-gtk3')
options=('!lto') # breaks spidermonkey linking (https://bugs.gentoo.org/746947)
-source=("git+https://github.com/0ad/0ad.git")
-md5sums=('SKIP')
+source=("git+https://github.com/0ad/0ad.git" "patch.patch")
+md5sums=('SKIP' 'dcbd62e1fb4669c24318c8fe66143c4f')
pkgver() {
cd ${_pkgname}
@@ -28,6 +28,10 @@ pkgver() {
prepare() {
cd "$srcdir/${_pkgname}"
+ # fix for error:
+ # source/ps/Util.cpp:27:1: note: ‘std::setfill’ is defined in header ‘<iomanip>’; did you forget to ‘#include <iomanip>’?
+ patch -p1 -i ../patch.patch
+
}
build() {
@@ -57,9 +61,9 @@ build() {
}
package_0ad-git() {
- depends=('0ad-data-git' 'binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
+ depends=('0ad-data' 'binutils' 'boost-libs' 'curl' 'enet' 'libogg' 'libpng' 'libvorbis'
'libxml2' 'openal' 'sdl2' 'wxwidgets-gtk3' 'zlib' 'libgl' 'glu' 'fmt'
- 'gloox' 'miniupnpc' 'libminiupnpc.so' 'icu' 'nspr' 'libsodium')
+ 'gloox' 'miniupnpc' 'libminiupnpc.so' 'icu' 'nspr' 'libsodium' 'which')
conflicts=('0ad')
provides=('0ad')
@@ -81,7 +85,6 @@ package_0ad-git() {
package_0ad-data-git() {
pkgdesc="Data package for 0ad built from git development version."
- depends=('0ad-git')
conflicts=('0ad-data')
provides=('0ad-data')
mkdir -p ${pkgdir}/usr/share/${_pkgname}-git
diff --git a/patch.patch b/patch.patch
new file mode 100644
index 000000000000..6e8121a3d311
--- /dev/null
+++ b/patch.patch
@@ -0,0 +1,10 @@
+--- a/source/ps/Util.cpp
++++ b/source/ps/Util.cpp
+@@ -24,6 +24,7 @@
+ #include "ps/CLogger.h"
+ #include "ps/Filesystem.h"
+ #include "ps/Pyrogenesis.h"
++#include <iomanip>
+
+ // not thread-safe!
+ static const wchar_t* HardcodedErrorString(int err)