summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2020-11-08 08:20:37 -0700
committerMark Wagie2020-11-08 08:20:37 -0700
commitd2ce1b9793a228920c92633d6f06275f225459ec (patch)
tree6c160a690eb275d68fe1e35cdd2ae8ce95d5a768
parent5c590a40d948c1ce502f1da1127261095a3d7ad2 (diff)
downloadaur-d2ce1b9793a228920c92633d6f06275f225459ec.tar.gz
PKGBUILD rewrite
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD37
3 files changed, 26 insertions, 27 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cb16959cb64c..2cf38a4bc96f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,16 @@
pkgbase = cover-thumbnailer-git
- pkgdesc = A Python script which generates folder thumbnails for various file browser on Linux. It displays music album covers, preview of pictures which are in a folder and more.
- pkgver = r82.c82d816
+ pkgdesc = Generates folder thumbnails for various file browsers
+ pkgver = 0.10.0.r8.gefb375d
pkgrel = 1
url = https://github.com/flozz/cover-thumbnailer
- arch = i686
arch = x86_64
license = GPL3
+ makedepends = git
depends = python-pillow
+ depends = python-gobject
provides = cover-thumbnailer
conflicts = cover-thumbnailer
- source = cover-thumbnailer::git+https://github.com/flozz/cover-thumbnailer
+ source = git+https://github.com/flozz/cover-thumbnailer.git
sha256sums = SKIP
pkgname = cover-thumbnailer-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..4dab8d6386e3
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+# Ignore everything
+*
+
+# But not these files...
+!.gitignore
+!PKGBUILD
+!.SRCINFO
diff --git a/PKGBUILD b/PKGBUILD
index 82ddff3f2143..fdef5b220c8b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,34 +1,25 @@
-# Maintainer: ValHue <vhuelamo at gmail dot com>
-#
+# Maintainer: Mark Wagie <mark dot wagie at tutanota dot com>
# Contributor: ValHue <vhuelamo at gmail dot com>
-#
-_pkgname="cover-thumbnailer"
-pkgname="${_pkgname}-git"
-pkgver=r82.c82d816
+pkgname=cover-thumbnailer-git
+pkgver=0.10.0.r8.gefb375d
pkgrel=1
-pkgdesc="A Python script which generates folder thumbnails for various file browser on Linux. It displays music album covers, preview of pictures which are in a folder and more."
-arch=('i686' 'x86_64')
+pkgdesc="Generates folder thumbnails for various file browsers"
+arch=('x86_64')
url="https://github.com/flozz/cover-thumbnailer"
license=('GPL3')
-depends=('python-pillow')
-conflicts=("${_pkgname}")
-provides=("${_pkgname}")
-source=("${_pkgname}::git+${url}")
+depends=('python-pillow' 'python-gobject')
+makedepends=('git')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=('git+https://github.com/flozz/cover-thumbnailer.git')
sha256sums=('SKIP')
pkgver() {
- cd "${_pkgname}"
- ( set -o pipefail
- git describe --long 2>/dev/null | sed 's/\([^-]*-g\)/r\1/;s/-/./g' ||
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
- )
+ cd "$srcdir/${pkgname%-git}"
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
}
package() {
- cd "${_pkgname}"
- ./install.sh -p ${pkgdir}
-
- install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${_pkgname}/LICENSE"
+ cd "$srcdir/${pkgname%-git}"
+ ./install.sh -p "$pkgdir"
}
-
-# vim: set ts=4 sw=4 et syn=sh ft=sh: