summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBlair Bonnett2021-11-06 09:57:26 +0100
committerBlair Bonnett2021-11-06 09:57:26 +0100
commitd2f6cbf780cb4a6497b7bdb5907610678c5309c6 (patch)
tree899d6bccd5d3e19b0b4aa5595313dc19d47c7312
parent85ecb95256b78c68d7c5e6061ecf6d524fdb2e32 (diff)
downloadaur-d2f6cbf780cb4a6497b7bdb5907610678c5309c6.tar.gz
Upgrade to 0.20.1
* Now builds against PROJ8 so the patch to use the AUR proj6 package can be removed.
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD44
-rw-r--r--use-proj6.patch24
3 files changed, 33 insertions, 59 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fd7b0b4fb5db..12e9805313a0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = python-cartopy
pkgdesc = A cartographic Python library with Matplotlib support for visualisation
- pkgver = 0.19.0
+ pkgver = 0.20.1
pkgrel = 1
- url = https://scitools.org.uk/cartopy/docs/latest/
+ url = https://scitools.org.uk/cartopy/
arch = x86_64
license = LGPL3
checkdepends = python-pytest
@@ -10,23 +10,23 @@ pkgbase = python-cartopy
makedepends = python-setuptools
makedepends = cython
makedepends = python-setuptools-scm
- depends = python-numpy
- depends = python-six
- depends = python-shapely
- depends = python-pyshp
- depends = proj6
depends = geos
+ depends = proj
+ depends = python-certifi
depends = python-matplotlib
+ depends = python-numpy
depends = python-pillow
+ depends = python-pyproj
+ depends = python-pyshp
depends = python-scipy
+ depends = python-shapely
+ depends = python-six
optdepends = python-fiona: faster shapefile reading
optdepends = python-gdal: for use with SRTM data
optdepends = python-pyepsg: interface to https://epsg.io
+ optdepends = python-pykdtree: faster warping of images
optdepends = python-owslib: access OGC clients
- source = cartopy-v0.19.0.tar.gz::https://files.pythonhosted.org/packages/source/c/cartopy/Cartopy-0.19.0.post1.tar.gz
- source = use-proj6.patch
- sha256sums = 4b8b4773a98ed7009fe17d9b6ec87ac3ac62b7d14634d7768c190eadc647d576
- sha256sums = f0367e38237739fe4c4700353eeae34f892a102a16ff43012b4758fcba564e9b
+ source = https://files.pythonhosted.org/packages/source/c/cartopy/Cartopy-0.20.1.tar.gz
+ sha256sums = 91f87b130e2574547a20cd634498df97d797abd12dcfd0235bc0cdbcec8b05e3
pkgname = python-cartopy
-
diff --git a/PKGBUILD b/PKGBUILD
index 7713f443c1ba..ae06d801598a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,51 +3,49 @@
# Contributor: Rich Li <rich@dranek.com>
pkgname=python-cartopy
-pkgver=0.19.0
+pkgver=0.20.1
pkgrel=1
pkgdesc="A cartographic Python library with Matplotlib support for visualisation"
-url="https://scitools.org.uk/cartopy/docs/latest/"
-depends=('python-numpy' 'python-six' 'python-shapely' 'python-pyshp' 'proj6'
- 'geos' 'python-matplotlib' 'python-pillow' 'python-scipy')
-optdepends=('python-fiona: faster shapefile reading'
- 'python-gdal: for use with SRTM data'
- 'python-pyepsg: interface to https://epsg.io'
- 'python-owslib: access OGC clients')
+url="https://scitools.org.uk/cartopy/"
+depends=(
+ 'geos' 'proj' 'python-certifi' 'python-matplotlib' 'python-numpy' 'python-pillow'
+ 'python-pyproj' 'python-pyshp' 'python-scipy' 'python-shapely' 'python-six'
+)
+optdepends=(
+ 'python-fiona: faster shapefile reading'
+ 'python-gdal: for use with SRTM data'
+ 'python-pyepsg: interface to https://epsg.io'
+ 'python-pykdtree: faster warping of images'
+ 'python-owslib: access OGC clients'
+)
makedepends=('python-setuptools' 'cython' 'python-setuptools-scm')
checkdepends=('python-pytest' 'python-flufl-lock')
license=('LGPL3')
arch=('x86_64')
source=(
- "cartopy-v$pkgver.tar.gz::https://files.pythonhosted.org/packages/source/c/cartopy/Cartopy-$pkgver.post1.tar.gz"
- 'use-proj6.patch'
+ "https://files.pythonhosted.org/packages/source/c/cartopy/Cartopy-$pkgver.tar.gz"
)
sha256sums=(
- '4b8b4773a98ed7009fe17d9b6ec87ac3ac62b7d14634d7768c190eadc647d576'
- 'f0367e38237739fe4c4700353eeae34f892a102a16ff43012b4758fcba564e9b'
+ '91f87b130e2574547a20cd634498df97d797abd12dcfd0235bc0cdbcec8b05e3'
)
-prepare() {
- cd "$srcdir/Cartopy-${pkgver}.post1"
- patch -p0 -i "$srcdir/use-proj6.patch"
-}
-
build() {
- cd "$srcdir/Cartopy-${pkgver}.post1"
+ cd "$srcdir/Cartopy-${pkgver}"
FORCE_CYTHON=1 python setup.py build
}
check() {
- cd "$srcdir/Cartopy-${pkgver}.post1"
+ local PYVER=$(python -c 'import sys; print("{}.{}".format(*sys.version_info[:2]))')
+ cd "$srcdir/Cartopy-${pkgver}/build/lib.linux-$CARCH-$PYVER"
# The deselected tests fail an image comparison due to small changes in the
# size and position of text labels.
- PYVER=$(python -c 'import sys; print("{}.{}".format(*sys.version_info[:2]))')
- PYTHONDONTWRITEBYTECODE=1 pytest \
+ PYTHONDONTWRITEBYTECODE=1 PYTHONPATH=. pytest cartopy \
-k "not test_gridliner and not test_contour_label" \
- "build/lib.linux-${CARCH}-${PYVER}/cartopy"
+ --ignore-glob="*mpl/test_ticks.py"
}
package() {
- cd "$srcdir/Cartopy-${pkgver}.post1"
+ cd "$srcdir/Cartopy-${pkgver}"
python setup.py install --root="$pkgdir" --prefix=/usr --optimize=1 --skip-build
}
diff --git a/use-proj6.patch b/use-proj6.patch
deleted file mode 100644
index 000a243a529f..000000000000
--- a/use-proj6.patch
+++ /dev/null
@@ -1,24 +0,0 @@
---- setup.py
-+++ setup.py
-
-@@ -143,5 +143,5 @@
- # Proj
- def find_proj_version_by_program(conda=None):
-- proj = find_executable('proj')
-+ proj = find_executable('proj6')
- if proj is None:
- print(
-
---- setup.py
-+++ setup.py
-
-@@ -288,6 +288,9 @@
- extra_extension_args["define_macros"].append(
- ('CYTHON_TRACE_NOGIL', '1')
- )
-
-+proj_includes = ["/usr/include/proj6"]
-+proj_libraries = ["proj6"]
-+
- extensions = [
- Extension(