summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrea Feletto2020-07-27 14:13:35 +0200
committerAndrea Feletto2020-07-27 14:13:35 +0200
commitd2fe0f2b6b468e68419313f70d7dc53e6f543fe3 (patch)
tree4a41f028c8bd3771a62fb2390a2103369013f20d
downloadaur-d2fe0f2b6b468e68419313f70d7dc53e6f543fe3.tar.gz
version 0.4.0
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD26
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9cc39c0a1216
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = heliocron-bin
+ pkgdesc = Execute tasks relative to sunset, sunrise and other solar events.
+ pkgver = 0.4.0
+ pkgrel = 1
+ url = https://github.com/mfreeborn/heliocron
+ arch = x86_64
+ license = Apache
+ license = MIT
+ provides = heliocron
+ source = https://github.com/mfreeborn/heliocron/releases/download/v0.4.0/heliocron-v0.4.0-x86_64-unknown-linux-gnu.tar.gz
+ sha256sums = 83cd3d97d0b32a624069f16a82991ad7ee01826ee9532d124cce6eff4aea6b0d
+
+pkgname = heliocron-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..55e51d170a6a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Heliocron
+
+# Maintainer: Andrea Feletto <andrea@andreafeletto.com>
+
+pkgname=heliocron-bin
+_pkgname=${pkgname%-*}
+pkgver=0.4.0
+pkgrel=1
+pkgdesc='Execute tasks relative to sunset, sunrise and other solar events.'
+arch=('x86_64')
+url='https://github.com/mfreeborn/heliocron'
+license=('Apache' 'MIT')
+provides=('heliocron')
+source=(
+ "https://github.com/mfreeborn/$_pkgname/releases/download/v$pkgver/$_pkgname-v$pkgver-x86_64-unknown-linux-gnu.tar.gz"
+)
+sha256sums=(
+ '83cd3d97d0b32a624069f16a82991ad7ee01826ee9532d124cce6eff4aea6b0d'
+)
+
+package() {
+ install -d "$pkgdir/usr/bin"
+ cd "$srcdir/$_pkgname-v$pkgver-x86_64-unknown-linux-gnu"
+ mv "$_pkgname" "$pkgdir/usr/bin"
+}
+