summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorTwoFinger2023-06-30 15:07:40 +0800
committerTwoFinger2023-06-30 15:09:50 +0800
commitd304245e913b183b98038b768d83f4a530c8b99a (patch)
treedffd55ff2b25eee889313c8d178028096a87056f
parent104d8dac1a1f857d4f667452e694376913e1f945 (diff)
downloadaur-d304245e913b183b98038b768d83f4a530c8b99a.tar.gz
fix namcap warning - lacks FULL RELRO
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 9 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 37688cc04b8f..2eefe7a8b3ec 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = picolisp
pkgdesc = Fast and tiny 64-bit Lisp interpreter: OO, dynamic and functional (database, prolog, coroutines).
pkgver = 23.6
- pkgrel = 1
+ pkgrel = 2
url = http://www.picolisp.com
arch = x86_64
license = MIT
diff --git a/PKGBUILD b/PKGBUILD
index d53755c75943..7c32116f54c2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: taij33n <bwbuiz@gmail.com>
pkgname=picolisp
pkgver=23.6
-pkgrel=1
+pkgrel=2
pkgdesc="Fast and tiny 64-bit Lisp interpreter: OO, dynamic and functional (database, prolog, coroutines)."
url="http://www.picolisp.com"
arch=('x86_64')
@@ -12,6 +12,13 @@ makedepends=('clang' 'llvm')
source=("https://software-lab.de/picoLisp-$pkgver.tgz")
md5sums=("70e78abfb9999ad133f0fdabfb6c9f1d")
+prepare() {
+ MAKEFILE="$srcdir/pil21/src/Makefile"
+ LDFLAGS=-Wl,-z,relro,-z,now
+ sed -i "s/SHARED =\|MAIN =/& $LDFLAGS/" "$MAKEFILE"
+ sed -i "/CC.\+balance\|CC.\+ssl\|CC.\+httpGate/ s/$/ $LDFLAGS/" "$MAKEFILE"
+}
+
build() {
cd "$srcdir/pil21/src"
make