summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-12-26 10:40:41 -0800
committerHurricanePootis2023-12-26 10:40:41 -0800
commitd3395c3ae77e1cdd4fbf1dcdfd3e19753fd65e3c (patch)
tree588c9b64c7fa765be893c6b14bf61fba049cb722
parent6dbccfd15b08fa695b9d4c1f55db8ced807bf64f (diff)
downloadaur-d3395c3ae77e1cdd4fbf1dcdfd3e19753fd65e3c.tar.gz
fix some things
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD17
-rwxr-xr-xsteamcmd6
3 files changed, 19 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 233942b1b962..32199e175ba0 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = steamcmd
pkgdesc = Steam Command Line Tools
pkgver = latest
- pkgrel = 3
+ pkgrel = 4
url = http://developer.valvesoftware.com/wiki/SteamCMD
install = steamcmd.install
arch = i686
@@ -10,8 +10,12 @@ pkgbase = steamcmd
source = https://steamcdn-a.akamaihd.net/client/installer/steamcmd_linux.tar.gz
source = steamcmd
md5sums = 70a38a1c8688d170c48b7f4990782c7a
- md5sums = 5de1fddd114f10ff5d2a8fbeee044a8f
+ md5sums = f344bc28c473a75d68021c4cf5cd019c
+ depends_i686 = gcc-libs
+ depends_i686 = sdl2
+ depends_i686 = dbus
depends_x86_64 = lib32-gcc-libs
+ depends_x86_64 = lib32-sdl2
+ depends_x86_64 = lib32-dbus
pkgname = steamcmd
-
diff --git a/PKGBUILD b/PKGBUILD
index ac36b24d512d..ae1b116217d1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,27 +2,28 @@
pkgname=steamcmd
pkgver=latest
-pkgrel=3
+pkgrel=4
pkgdesc="Steam Command Line Tools"
arch=('i686' 'x86_64')
license=('custom')
url=http://developer.valvesoftware.com/wiki/SteamCMD
source=(https://steamcdn-a.akamaihd.net/client/installer/steamcmd_linux.tar.gz steamcmd)
md5sums=('70a38a1c8688d170c48b7f4990782c7a'
- '5de1fddd114f10ff5d2a8fbeee044a8f')
+ 'f344bc28c473a75d68021c4cf5cd019c')
install='steamcmd.install'
-depends_x86_64=('lib32-gcc-libs')
+depends_x86_64=('lib32-gcc-libs' 'lib32-sdl2' 'lib32-dbus')
+depends_i686=('gcc-libs' 'sdl2' 'dbus')
package() {
# sh script
install -D -m755 "${srcdir}/steamcmd" "${pkgdir}/usr/bin/steamcmd"
# in base folder
- install -D -m755 "${srcdir}/steamcmd.sh" "${pkgdir}/usr/share/steamcmd/steamcmd.sh"
+ install -D -m755 "${srcdir}/steamcmd.sh" "${pkgdir}/usr/lib/steamcmd/steamcmd.sh"
# in linux32 folder
- install -D -m755 "${srcdir}/linux32/crashhandler.so" "${pkgdir}/usr/share/steamcmd/linux32/crashhandler.so"
- install -D -m755 "${srcdir}/linux32/libstdc++.so.6" "${pkgdir}/usr/share/steamcmd/linux32/libstdc++.so.6"
- install -D -m755 "${srcdir}/linux32/steamcmd" "${pkgdir}/usr/share/steamcmd/linux32/steamcmd"
- install -D -m755 "${srcdir}/linux32/steamerrorreporter" "${pkgdir}/usr/share/steamcmd/linux32/steamerrorreporter"
+ install -D -m755 "${srcdir}/linux32/crashhandler.so" "${pkgdir}/usr/lib/steamcmd/linux32/crashhandler.so"
+ install -D -m755 "${srcdir}/linux32/libstdc++.so.6" "${pkgdir}/usr/lib/steamcmd/linux32/libstdc++.so.6"
+ install -D -m755 "${srcdir}/linux32/steamcmd" "${pkgdir}/usr/lib/steamcmd/linux32/steamcmd"
+ install -D -m755 "${srcdir}/linux32/steamerrorreporter" "${pkgdir}/usr/lib/steamcmd/linux32/steamerrorreporter"
}
diff --git a/steamcmd b/steamcmd
index 22a942cd7ec4..4a83a2d34a8a 100755
--- a/steamcmd
+++ b/steamcmd
@@ -18,7 +18,7 @@ if [ ! -e ~/.steam/steamcmd ]
then
mkdir -p ~/.steam/steamcmd/linux32
# steamcmd will replace these files with newer ones itself on first run
- cp /usr/share/steamcmd/steamcmd.sh ~/.steam/steamcmd/steamcmd.sh
- cp /usr/share/steamcmd/linux32/steamcmd ~/.steam/steamcmd/linux32/steamcmd
+ cp /usr/lib/steamcmd/steamcmd.sh ~/.steam/steamcmd/steamcmd.sh
+ cp /usr/lib/steamcmd/linux32/steamcmd ~/.steam/steamcmd/linux32/steamcmd
fi
-exec ~/.steam/steamcmd/steamcmd.sh $@
+exec ~/.steam/steamcmd/steamcmd.sh "$@"