summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMark Wagie2023-11-07 13:06:39 -0700
committerMark Wagie2023-11-07 13:06:39 -0700
commitd3427478936e824e264fd39e2c3ab3802dabc737 (patch)
treed60bbba69518713bef4a04d91787734431440a3c
parentd0761db7f6645c500b008308507ba31cc72cfa0b (diff)
downloadaur-d3427478936e824e264fd39e2c3ab3802dabc737.tar.gz
remove unneded make dep, update Maintainers
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD15
2 files changed, 10 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d629556ddd52..b7c5aaca1d5c 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,22 @@
pkgbase = clight-git
pkgdesc = A C daemon that turns your webcam into a light sensor. It can also change display gamma temperature, dim your screen and set your dpms.
- pkgver = 4.10.r2.gc85b4aa
+ pkgver = 4.10.r5.g0d6d075
pkgrel = 1
url = https://github.com/FedeDP/Clight
install = clight.install
arch = x86_64
arch = aarch64
license = GPL3
- makedepends = git
makedepends = cmake
- makedepends = bash-completion
+ makedepends = git
depends = clightd-git
depends = gsl
depends = hicolor-icon-theme
depends = libconfig
depends = popt
+ optdepends = clight-gui-git: Clight GUI written in Qt.
optdepends = geoclue: to retrieve user location through geoclue.
optdepends = upower: to save energy by increasing timeouts between captures while on battery and to autocalibrate keyboard backlight.
- optdepends = bash-completion: to add support for bash automatic completion.
- optdepends = clight-gui-git: Clight GUI written in Qt.
provides = clight
conflicts = clight
backup = etc/clight/clight.conf
diff --git a/PKGBUILD b/PKGBUILD
index 6902ac6649bb..59c12339a897 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
-# Maintainer: Mark Wagie <mark dot wagie at tutantota dot com>
+# Maintainer: Mark Wagie <mark dot wagie at proton dot me>
# Contributor: Federico Di Pierro <nierro92@gmail.com>
pkgname=clight-git
-pkgver=4.10.r2.gc85b4aa
+pkgver=4.10.r5.g0d6d075
pkgrel=1
pkgdesc="A C daemon that turns your webcam into a light sensor. It can also change display
gamma temperature, dim your screen and set your dpms."
@@ -9,12 +9,11 @@ arch=('x86_64' 'aarch64')
url="https://github.com/FedeDP/Clight"
license=('GPL3')
depends=('clightd-git' 'gsl' 'hicolor-icon-theme' 'libconfig' 'popt')
-makedepends=('git' 'cmake' 'bash-completion')
-optdepends=('geoclue: to retrieve user location through geoclue.'
+makedepends=('cmake' 'git')
+optdepends=('clight-gui-git: Clight GUI written in Qt.'
+ 'geoclue: to retrieve user location through geoclue.'
'upower: to save energy by increasing timeouts between captures while on battery
- and to autocalibrate keyboard backlight.'
- 'bash-completion: to add support for bash automatic completion.'
- 'clight-gui-git: Clight GUI written in Qt.')
+ and to autocalibrate keyboard backlight.')
provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")
backup=("etc/${pkgname%-git}/${pkgname%-git}.conf"
@@ -24,7 +23,7 @@ source=('git+https://github.com/FedeDP/Clight.git')
sha256sums=('SKIP')
pkgver() {
- cd "$srcdir/Clight"
+ cd Clight
git describe --long --tags | sed 's/\([^-]*-g\)/r\1/;s/-/./g'
}