summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorsukanka2020-04-14 02:36:26 +0800
committersukanka2020-04-14 02:36:26 +0800
commitd358fb64211078ae4ae67d409ab1208b3d1509a8 (patch)
treed3c94d4ee04ad1ac760b5ec3d0b2186190a1d2d4
parent8546581fe52e186f37b4061e559bf5f170552f8f (diff)
downloadaur-d358fb64211078ae4ae67d409ab1208b3d1509a8.tar.gz
fix pkg_ver and add sha256sums
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD9
2 files changed, 4 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0263960511b0..468a48db4f40 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -16,7 +16,7 @@ pkgbase = bbswitch-ati-git
source = bbswitch-ati-git::git+https://github.com/Bumblebee-Project/bbswitch.git#branch=develop
source = https://www.qua-it.org/XFCE/shots/share-with-pclos/pclos/bbswitch-v0.8-proc_ops-struct.patch
sha256sums = SKIP
- sha256sums = SKIP
+ sha256sums = 3ebaf305628587fce64f64648f8ee6c1bc51e0eab855e1725538be995649a73c
pkgname = bbswitch-ati-git
diff --git a/PKGBUILD b/PKGBUILD
index 56061e343b9b..97c45e4e9a80 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=bbswitch-ati-git
-pkgver=v0.8.2.g9dd2270
+pkgver=0.8.2.g9dd2270
pkgrel=1
pkgdesc='kernel module allowing to switch also AMD integrated and Nvidia dedicated graphics card on Optimus laptops (Git version)'
arch=('i686' 'x86_64')
@@ -14,12 +14,12 @@ makedepends=('linux-headers' 'git')
source=("${pkgname}::git+https://github.com/Bumblebee-Project/bbswitch.git#branch=develop"
'https://www.qua-it.org/XFCE/shots/share-with-pclos/pclos/bbswitch-v0.8-proc_ops-struct.patch'
)
-sha256sums=('SKIP' 'SKIP')
+sha256sums=('SKIP' '3ebaf305628587fce64f64648f8ee6c1bc51e0eab855e1725538be995649a73c')
install=bbswitch-ati.install
pkgver () {
cd "${srcdir}/${pkgname}"
- git describe --always | sed 's|-|.|g'
+ git describe --always | sed 's|-|.|g' | sed 's/v//g'
}
build() {
@@ -28,11 +28,8 @@ build() {
cd "${srcdir}/${pkgname}"
if [ $kernel_ver > "5.6" ]; then
git apply "${srcdir}"/bbswitch-v0.8-proc_ops-struct.patch
- echo 12225555
fi
if [ "$cpu" = "AMD" ]; then
- echo "AMD integrated card detected"
- echo "${srcdir}/${pkgname}"/bbswitch.c
sed -i 's/PCI_VENDOR_ID_INTEL/PCI_VENDOR_ID_ATI/g' "${srcdir}/${pkgname}"/bbswitch.c
fi
make