summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorFilipp Andjelo2020-06-10 15:34:24 +0200
committerFilipp Andjelo2020-06-10 15:34:24 +0200
commitd3639875bbd37fc31a41109550cfb52485068685 (patch)
treeda33025a634d5e713b24ab831298991b53785cf5
downloadaur-d3639875bbd37fc31a41109550cfb52485068685.tar.gz
Initial commit of a package elgato-gchd-git
-rw-r--r--.SRCINFO23
-rw-r--r--80-elgato-gchd.rules2
-rw-r--r--PKGBUILD54
3 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..253a53c88a9d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = elgato-gchd-git
+ pkgdesc = Elgato Game Capture HD Driver
+ pkgver = r147.e5bc6b9
+ pkgrel = 1
+ url = https://github.com/tolga9009/elgato-gchd
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ makedepends = p7zip
+ depends = libusb
+ provides = elgato-gchd
+ conflicts = elgato-gchd
+ source = git+https://github.com/tolga9009/elgato-gchd.git
+ source = https://edge.elgato.com/egc/windows/egcw/3.70/final/GameCaptureSetup_3.70.43.3043_x64.msi
+ source = 80-elgato-gchd.rules
+ sha256sums = SKIP
+ sha256sums = 8f4a81e0e4cc794eaf1c9e33c2c8ade8b345de1e524369fc7e31d8dff3f83d5e
+ sha256sums = 02e903c82c4860fb78cf414cf507a57d611bcc357166f7292129a0538a5e1b39
+
+pkgname = elgato-gchd-git
+
diff --git a/80-elgato-gchd.rules b/80-elgato-gchd.rules
new file mode 100644
index 000000000000..290aa3c7a397
--- /dev/null
+++ b/80-elgato-gchd.rules
@@ -0,0 +1,2 @@
+SUBSYSTEMS=="usb", ATTRS{idVendor}=="0fd9", ATTRS{idProduct}=="0051", MODE="0660", GROUP="plugdev"
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..920433ec2f23
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,54 @@
+# Maintainer: Filipp Andjelo <filipp dot andjelo at gmail.com>
+
+pkgname=elgato-gchd-git
+pkgver=r147.e5bc6b9
+pkgrel=1
+pkgdesc="Elgato Game Capture HD Driver"
+arch=('i686' 'x86_64')
+url="https://github.com/tolga9009/elgato-gchd"
+license=('MIT')
+depends=('libusb')
+makedepends=('git' 'cmake' 'p7zip')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(
+ "git+${url}.git"
+ "https://edge.elgato.com/egc/windows/egcw/3.70/final/GameCaptureSetup_3.70.43.3043_x64.msi"
+ "80-elgato-gchd.rules"
+)
+sha256sums=(
+ 'SKIP'
+ '8f4a81e0e4cc794eaf1c9e33c2c8ade8b345de1e524369fc7e31d8dff3f83d5e'
+ '02e903c82c4860fb78cf414cf507a57d611bcc357166f7292129a0538a5e1b39'
+)
+
+pkgver() {
+ cd "${srcdir}/${pkgname%-git}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ mkdir -p "${srcdir}/firmware"
+ 7z e -aoa -o"${srcdir}" GameCaptureSetup_3.70.43.3043_x64.msi x86_yPushFile3.dll
+ 7z e -aoa -o"${srcdir}/firmware" -r "${srcdir}/x86_yPushFile3.dll" \
+ MB86H57_H58_IDLE \
+ MB86H57_H58_ENC_H \
+ MB86M01_ASSP_NSEC_IDLE \
+ MB86M01_ASSP_NSEC_ENC_H
+}
+
+build() {
+ cmake -B "${srcdir}/build" \
+ -S "$srcdir/${pkgname%-git}" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX="/usr"
+ cmake --build "${srcdir}/build"
+}
+
+package() {
+ DESTDIR="${pkgdir}" cmake --install "${srcdir}/build"
+ for f in ${srcdir}/firmware/*; do
+ install -D -m644 -t "${pkgdir}/usr/lib/firmware/gchd/" "$f"
+ done
+ install -D -m644 -t "${pkgdir}/etc/udev/rules.d/" 80-elgato-gchd.rules
+}