summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorpurofle2020-07-06 15:55:43 +0800
committerpurofle2020-07-06 15:55:43 +0800
commitd36683291a367c10d20cdd0e89eeb10cc6246e25 (patch)
treeabcdf143b00ead5f3aeb91971e1b1433947b1797
downloadaur-d36683291a367c10d20cdd0e89eeb10cc6246e25.tar.gz
miraiOK in aur!
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD22
2 files changed, 36 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2529c63af049
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = miraiok-bin
+ pkgdesc = miraiOK二进制文件的打包
+ pkgver = 0.5.2
+ pkgrel = 1
+ url = https://github.com/LXY1226/MiraiOKhttps://github.com/LXY1226/MiraiOK
+ arch = x86_64
+ license = AGPL3
+ depends = jdk8-openjdk
+ noextract = http://t.imlxy.net:64724/mirai/MiraiOK/miraiOK_linux_amd64
+ source = http://t.imlxy.net:64724/mirai/MiraiOK/miraiOK_linux_amd64
+ md5sums = 114eef36cea19e2846ecb149e88899ac
+
+pkgname = miraiok-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9919f392333c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,22 @@
+# Maintainer: purofle 3272912942@qq.com
+pkgname="miraiok-bin"
+pkgver="0.5.2"
+pkgrel=1
+pkgdesc="miraiOK二进制文件的打包"
+arch=("x86_64")
+url="https://github.com/LXY1226/MiraiOKhttps://github.com/LXY1226/MiraiOK"
+license=("AGPL3")
+depends=("jdk8-openjdk")
+source=("http://t.imlxy.net:64724/mirai/MiraiOK/miraiOK_linux_amd64")
+noextract=("${source[@]%%::*}")
+md5sums=('114eef36cea19e2846ecb149e88899ac')
+
+prepare() {
+ cd ${srcdir}
+ mv miraiOK_linux_amd64 miraiOK
+}
+
+package() {
+ mkdir -p ${pkgdir}/usr/bin
+ install -D -m 755 "${srcdir}/miraiOK" "${pkgdir}/usr/bin/miraiOK"
+}