summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDimitris Kiziridis2020-05-16 02:09:17 +0300
committerDimitris Kiziridis2020-05-16 02:09:17 +0300
commitd38990ba54256b20619adb18d0da46b365821755 (patch)
treec65b88ab4c6317e502eaf27fe9d3dd2df3098d93
parentc5668292920dea0224db65a52f5e9fb8700fbe66 (diff)
downloadaur-d38990ba54256b20619adb18d0da46b365821755.tar.gz
sanitize pkgbuild
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD8
2 files changed, 7 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b8d0898bd35a..be058e8a2019 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -4,10 +4,10 @@ pkgbase = zek-bin
pkgrel = 1
url = https://github.com/miku/zek
arch = x86_64
- license = GPL-3.0
+ license = GPL3
provides = zek
- source = https://github.com/miku/zek/releases/download/v0.1.9/zek_0.1.9_amd64.deb
- md5sums = 209edfd497230c80663165fca98ede05
+ source = zek-bin-0.1.9.deb::https://github.com/miku/zek/releases/download/v0.1.9/zek_0.1.9_amd64.deb
+ sha256sums = dd3e786ad5d741509ab3fca99de263ef15a4698323ee64d4c482e4546b004d7d
pkgname = zek-bin
diff --git a/PKGBUILD b/PKGBUILD
index 97e0f972f99c..995be038ce86 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@ pkgrel=1
pkgdesc="Generate a Go struct from XML"
arch=('x86_64')
url='https://github.com/miku/zek'
-license=('GPL-3.0')
+license=('GPL3')
provides=('zek')
-source=("https://github.com/miku/zek/releases/download/v${pkgver}/zek_${pkgver}_amd64.deb")
-md5sums=('209edfd497230c80663165fca98ede05')
+source=("${pkgname}-${pkgver}.deb::https://github.com/miku/zek/releases/download/v${pkgver}/zek_${pkgver}_amd64.deb")
+sha256sums=('dd3e786ad5d741509ab3fca99de263ef15a4698323ee64d4c482e4546b004d7d')
package() {
cd "${srcdir}"
- tar xf data.tar.xz -C "${pkgdir}"
+ tar xvf data.tar.xz -C "${pkgdir}"
cd ${pkgdir}/usr
mv sbin bin
chmod 755 bin/zek