summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorHurricanePootis2023-02-23 12:04:21 -0600
committerHurricanePootis2023-02-23 12:04:21 -0600
commitd38d078b1537ca9bc7f6ff4c36fb155a37ea1b43 (patch)
tree4ae6922ec29feb323dec0969b22f96fb711844bb
parentc0d255386576de39bd8d07414eb589d3aae5951d (diff)
downloadaur-d38d078b1537ca9bc7f6ff4c36fb155a37ea1b43.tar.gz
Fix deps thanks to namcap
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD11
2 files changed, 5 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5ae1e6b56174..78825a39594b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = vkquake
pkgdesc = A modern Quake 1 engine. Forked from Fitzquake. This version contains Vulkan API support.
pkgver = 1.22.3
- pkgrel = 2
+ pkgrel = 3
url = https://github.com/Novum/vkquake
install = vkquake.install
arch = x86_64
@@ -13,12 +13,8 @@ pkgbase = vkquake
makedepends = glslang
makedepends = spirv-tools
depends = flac
- depends = glibc
- depends = libgl
depends = libmad
- depends = libmikmod
depends = libvorbis
- depends = libx11
depends = opusfile
depends = sdl2
provides = vkquake
diff --git a/PKGBUILD b/PKGBUILD
index bcea0ebf588e..798793e313a4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,14 +6,14 @@
_quake=vkQuake
pkgname=vkquake
pkgver=1.22.3
-pkgrel=2
+pkgrel=3
pkgdesc="A modern Quake 1 engine. Forked from Fitzquake. This version contains Vulkan API support."
arch=('x86_64')
provides=('vkquake')
url="https://github.com/Novum/vkquake"
license=('GPL2')
-depends=('flac' 'glibc' 'libgl' 'libmad' 'libmikmod'
- 'libvorbis' 'libx11' 'opusfile' 'sdl2')
+depends=('flac' 'libmad'
+ 'libvorbis' 'opusfile' 'sdl2')
makedepends=('vulkan-validation-layers' 'meson' 'vulkan-headers' 'zopfli' 'glslang' 'spirv-tools')
install=$pkgname.install
source=("https://github.com/Novum/vkQuake/archive/${pkgver}.tar.gz"
@@ -29,10 +29,7 @@ sha512sums=('f69e4341cef53b7e72ce37283d2ffff574325aa0b898c923ee3074b92bb917dcbe7
build() {
cd "$srcdir/$_quake-$pkgver"
- if [[ -d build ]]
- then
- rm -rf build
- fi
+ [[ -d build ]] || rm -rf build
mkdir build && cd build
export CFLAGS="$CFLAGS -DDO_USERDIRS=1"