summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorCebtenzzre2023-05-17 22:12:40 -0400
committerCebtenzzre2023-05-18 00:23:11 -0400
commitd38ed2f70bd4b1d6927bbdafcfecdfc755f1b557 (patch)
tree8ed591e5d69140f8bc9a28b68ba1cb0c5ed4b139
parent74c6576c6dbf7b78584cb7a9878831e5435c1482 (diff)
downloadaur-d38ed2f70bd4b1d6927bbdafcfecdfc755f1b557.tar.gz
update to latest version, depend on older python
The v5.15.3-lts-lgpl tag isn't on any branch, so use the tag directly. Also, set the pkgver to a constant so it's clearer what version is installed. We can't use a simple `git describe` because it reports 5.11.2 for some reason. Depend on an older version of python, since the latest version is not compatible with this version of pyside2.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD19
2 files changed, 13 insertions, 15 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff9969224b7b..1716221fd467 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,12 +1,13 @@
pkgbase = pyside2-git
pkgdesc = Enables the use of Qt5 APIs in Python applications (git version)
- pkgver = r7237.d526f801c
+ pkgver = 5.15.3
pkgrel = 1
url = https://www.qt.io
arch = x86_64
license = LGPL
- makedepends = shiboken2
+ makedepends = shiboken2-git
makedepends = cmake
+ makedepends = python39
makedepends = git
makedepends = qt5-multimedia
makedepends = qt5-tools
@@ -25,7 +26,7 @@ pkgbase = pyside2-git
makedepends = qt5-serialport
makedepends = qt5-remoteobjects
makedepends = qt5-xmlpatterns
- depends = python-shiboken2
+ depends = python-shiboken2-git
depends = qt5-declarative
optdepends = qt5-svg: QtSvg bindings
optdepends = qt5-script: QtScript bindings
@@ -46,7 +47,7 @@ pkgbase = pyside2-git
provides = pyside2
conflicts = python-pyside2
conflicts = pyside2
- source = pyside2-git::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.15
+ source = pyside2-git::git+https://code.qt.io/pyside/pyside-setup.git#commit=72d32f66685fbb7fefc41eee629e63f4824cb10b
sha256sums = SKIP
pkgname = pyside2-git
diff --git a/PKGBUILD b/PKGBUILD
index d83c3834b546..f3fec63fa131 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,14 +8,14 @@
# Contributor: Jan-Erik Meyer-Luetgens <nyan at meyer-luetgens dot de>
pkgname=pyside2-git
-pkgver=r7237.d526f801c
+pkgver=5.15.3
pkgrel=1
arch=(x86_64)
url='https://www.qt.io'
license=(LGPL)
pkgdesc='Enables the use of Qt5 APIs in Python applications (git version)'
-depends=(python-shiboken2 qt5-declarative)
-makedepends=(shiboken2 cmake git
+depends=(python-shiboken2-git qt5-declarative)
+makedepends=(shiboken2-git cmake python39 git
qt5-multimedia qt5-tools qt5-sensors qt5-charts qt5-webengine qt5-datavis3d
qt5-websockets qt5-speech qt5-3d qt5-svg qt5-script qt5-scxml qt5-x11extras
qt5-quickcontrols2 qt5-serialport qt5-remoteobjects qt5-xmlpatterns)
@@ -36,28 +36,25 @@ optdepends=('qt5-svg: QtSvg bindings'
'qt5-quickcontrols2: QtQuickControls2 bindings')
conflicts=(python-pyside2 pyside2)
provides=(python-pyside2 pyside2)
-source=("$pkgname::git+https://code.qt.io/pyside/pyside-setup.git#branch=5.15")
+_commit=72d32f66685fbb7fefc41eee629e63f4824cb10b # tags/v5.15.3-lts-lgpl^0
+source=("$pkgname::git+https://code.qt.io/pyside/pyside-setup.git#commit=$_commit")
sha256sums=('SKIP')
-pkgver() {
- cd "${srcdir}/${pkgname}"
-
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
-
prepare() {
cd "${srcdir}/${pkgname}"
mkdir -p build
}
+_python=/usr/bin/python3.9
+
build() {
cd "${srcdir}/${pkgname}/build"
cmake ../sources/pyside2 \
-DCMAKE_INSTALL_PREFIX=/usr \
-DBUILD_TESTS=OFF \
- -DPYTHON_EXECUTABLE=/usr/bin/python
+ -DPYTHON_EXECUTABLE="$_python"
make
}