summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluspi2024-02-29 19:13:35 -0600
committerluspi2024-02-29 19:13:35 -0600
commitd3c82aa8f7ca81d1bd2ce262533fe0ab7b5dd6bd (patch)
treee76ddbc4b028837d9b5cbee1547d39c2cfeb04bf
parent1f20188d6e0045d5b1e8cde9803dbad1205ac6e6 (diff)
downloadaur-d3c82aa8f7ca81d1bd2ce262533fe0ab7b5dd6bd.tar.gz
update to 4.3
-rw-r--r--.SRCINFO7
-rwxr-xr-xPKGBUILD10
2 files changed, 9 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cacd7c230493..e26882f29aa5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = photoqt
pkgdesc = Fast and highly configurable image viewer with a simple and nice interface.
- pkgver = 4.2
+ pkgver = 4.3
pkgrel = 1
url = http://photoqt.org/
arch = x86_64
@@ -25,10 +25,11 @@ pkgbase = photoqt
depends = resvg
depends = python-pychromecast
depends = qt6-webengine
+ depends = zxing-cpp
optdepends = libqpsd-git: PSB/PSD support
optdepends = xcftools: XCF support
optdepends = poppler-qt6: PDF support
- source = https://photoqt.org/downloads/source/photoqt-4.2.tar.gz
- sha256sums = 394aaccaf9afe9c7090f371601e4b538e98ad9e5ce08480692dcfa184533a00f
+ source = https://photoqt.org/downloads/source/photoqt-4.3.tar.gz
+ sha256sums = 07466e6ef5881191670f6bfbe1ba4fbfeff0afbbda1d2f503f8ffff7f69f8f34
pkgname = photoqt
diff --git a/PKGBUILD b/PKGBUILD
index 178d69ff930c..b450c4465c94 100755
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,19 +2,19 @@
# Contributor: archtux <antonio dot arias99999 at gmail dot com>
pkgname=photoqt
-pkgver=4.2
+pkgver=4.3
pkgrel=1
pkgdesc="Fast and highly configurable image viewer with a simple and nice interface."
arch=('x86_64')
url="http://photoqt.org/"
license=('GPL2')
-depends=('exiv2' 'imagemagick' 'qt6-imageformats' 'qt6-multimedia' 'qt6-svg' 'qt6-declarative' 'qt6-location' 'qt6-positioning' 'libraw' 'hicolor-icon-theme' 'libarchive' 'kimageformats5' 'pugixml' 'mpv' 'resvg' 'python-pychromecast' 'qt6-webengine')
+depends=('exiv2' 'imagemagick' 'qt6-imageformats' 'qt6-multimedia' 'qt6-svg' 'qt6-declarative' 'qt6-location' 'qt6-positioning' 'libraw' 'hicolor-icon-theme' 'libarchive' 'kimageformats5' 'pugixml' 'mpv' 'resvg' 'python-pychromecast' 'qt6-webengine' 'zxing-cpp')
optdepends=('libqpsd-git: PSB/PSD support'
'xcftools: XCF support'
'poppler-qt6: PDF support')
makedepends=('cmake' 'qt6-tools' 'extra-cmake-modules')
source=(https://photoqt.org/downloads/source/$pkgname-$pkgver.tar.gz)
-sha256sums=('394aaccaf9afe9c7090f371601e4b538e98ad9e5ce08480692dcfa184533a00f')
+sha256sums=('07466e6ef5881191670f6bfbe1ba4fbfeff0afbbda1d2f503f8ffff7f69f8f34')
# NOTE
# To use GraphicsMagick instead of ImageMagick replace it in the depends array above and change
@@ -26,12 +26,12 @@ sha256sums=('394aaccaf9afe9c7090f371601e4b538e98ad9e5ce08480692dcfa184533a00f')
# NOTE
# These dependencies are currently disabled in the cmake call below:
-# 'freeimage' 'devil-ilut' 'poppler-qt5' 'libvips'
+# 'freeimage' 'devil-ilut' 'poppler-qt6' 'libvips'
prepare() {
cd $srcdir/$pkgname-$pkgver
- cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF -DPOPPLER=OFF -DQTPDF=ON -DIMAGEMAGICK=ON -DGRAPHICSMAGICK=OFF -DLIBVIPS=OFF -DVIDEO_MPV=ON -DCHROMECAST=ON -DRESVG=ON
+ cmake . -DCMAKE_INSTALL_PREFIX=/usr -DFREEIMAGE=OFF -DDEVIL=OFF -DPOPPLER=OFF -DQTPDF=ON -DIMAGEMAGICK=ON -DGRAPHICSMAGICK=OFF -DLIBVIPS=OFF -DVIDEO_MPV=ON -DCHROMECAST=ON -DRESVG=ON -DZXING=ON -DCMAKE_BUILD_TYPE=Release
}