summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrenton Horne2019-03-23 22:47:33 +1000
committerBrenton Horne2019-03-23 22:47:33 +1000
commitd3f19b6663bc9a39194cc6cda0ac4b2dcc580191 (patch)
treed275214f00ecae1ba3449325ff8ea20013667a25
downloadaur-d3f19b6663bc9a39194cc6cda0ac4b2dcc580191.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore5
-rwxr-xr-xPKGBUILD52
-rwxr-xr-xopenra-mw19
-rwxr-xr-xopenra-mw.appdata.xml37
-rwxr-xr-xopenra-mw.changes17
-rwxr-xr-xopenra-mw.desktop11
-rwxr-xr-xopenra-mw.install12
8 files changed, 189 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..d2dff7bba6cf
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = openra-mw-git
+ pkgdesc = An original mod of OpenRA depicting medieval warfare
+ pkgver = 267
+ pkgrel = 1
+ url = https://github.com/CombinE88/Medieval-Warfare
+ install = openra-mw.install
+ arch = any
+ license = GPL3
+ makedepends = dos2unix
+ makedepends = git
+ makedepends = unzip
+ depends = mono
+ depends = ttf-dejavu
+ depends = openal
+ depends = libgl
+ depends = freetype2
+ depends = sdl2
+ depends = lua51
+ depends = hicolor-icon-theme
+ depends = gtk-update-icon-cache
+ depends = desktop-file-utils
+ depends = xdg-utils
+ depends = zenity
+ provides = openra-mw
+ options = !strip
+ source = git+https://github.com/CombinE88/Medieval-Warfare.git
+ source = openra-mw
+ source = openra-mw.appdata.xml
+ source = openra-mw.desktop
+ md5sums = SKIP
+ md5sums = e0a97ba9134ed19d29cf61bf44c9b0ee
+ md5sums = 0f77c0a5b31dbcf523e985d27c438788
+ md5sums = 2410c10bc2fce972a940f734471db5a1
+
+pkgname = openra-mw-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..d344dd0ee4ca
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,5 @@
+*.xz
+Medieval-Warfare
+pkg
+src
+*.gz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100755
index 000000000000..4ca998d5225f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,52 @@
+pkgname=openra-mw-git
+_pkgname=openra-mw
+pkgver=267
+pkgrel=1
+pkgdesc="An original mod of OpenRA depicting medieval warfare"
+arch=('any')
+url="https://github.com/CombinE88/Medieval-Warfare"
+license=('GPL3')
+install=openra-mw.install
+depends=('mono' 'ttf-dejavu' 'openal' 'libgl' 'freetype2' 'sdl2' 'lua51' 'hicolor-icon-theme' 'gtk-update-icon-cache'
+ 'desktop-file-utils' 'xdg-utils' 'zenity')
+makedepends=('dos2unix' 'git' 'unzip')
+provides=('openra-mw')
+options=(!strip)
+source=("git+https://github.com/CombinE88/Medieval-Warfare.git"
+"openra-mw"
+"openra-mw.appdata.xml"
+"openra-mw.desktop")
+md5sums=('SKIP'
+ 'e0a97ba9134ed19d29cf61bf44c9b0ee'
+ '0f77c0a5b31dbcf523e985d27c438788'
+ '2410c10bc2fce972a940f734471db5a1')
+
+prepare() {
+ cd $srcdir/Medieval-Warfare
+ dos2unix *.md
+ make version VERSION="Master commit #${pkgver}"
+}
+
+build() {
+ cd $srcdir/Medieval-Warfare
+ make || (printf "make failed; please do not complain at the AUR about this, as this is an upstream issue.\n" && \
+ printf "So report this at https://github.com/MustaphaTR/Romanovs-Vengeance/issues/new, after checking\n" && \
+ printf "for existing issues.\n")
+}
+
+package() {
+ cd $srcdir/Medieval-Warfare
+ mkdir -p $pkgdir/usr/{lib/openra-mw/mods,bin,share/pixmaps,share/doc/packages/openra-mw,share/applications,share/appdata}
+ install -dm775 $pkgdir/var/games/openra-mw
+ cp -r engine/{glsl,lua,AUTHORS,COPYING,Eluant.dll*,FuzzyLogicLibrary.dll,GeoLite2-Country.mmdb.gz,'global mix database.dat',ICSharpCode.SharpZipLib.dll,launch-dedicated.sh,launch-game.sh,MaxMind.Db.dll,OpenAL-CS.dll,OpenAL-CS.dll.config,Open.Nat.dll,OpenRA.Game.exe,OpenRA.Platforms.Default.dll,OpenRA.Server.exe,OpenRA.Utility.exe,rix0rrr.BeaconLib.dll,SDL2-CS.dll,SDL2-CS.dll.config,SharpFont.dll,SharpFont.dll.config,VERSION} $pkgdir/usr/lib/openra-mw
+ cp -r mods/mw $pkgdir/usr/lib/openra-mw/mods
+ cp -r engine/mods/{common,modcontent} $pkgdir/usr/lib/openra-mw/mods
+ install -Dm755 $srcdir/openra-mw $pkgdir/usr/bin/openra-mw
+ cp -r $srcdir/openra-mw.appdata.xml $pkgdir/usr/share/appdata/openra-mw.appdata.xml
+ cp -r README.md $pkgdir/usr/share/doc/packages/openra-mw/README.md
+ cp -r mods/mw/icon.png $pkgdir/usr/share/pixmaps/openra-mw.png
+ install -Dm644 $srcdir/openra-mw.desktop $pkgdir/usr/share/applications/openra-mw.desktop
+ rm $pkgdir/usr/lib/openra-mw/*.sh
+}
+
+
diff --git a/openra-mw b/openra-mw
new file mode 100755
index 000000000000..c90c6f56b29b
--- /dev/null
+++ b/openra-mw
@@ -0,0 +1,19 @@
+#!/bin/sh
+cd "/usr/lib/openra-mw"
+
+# Run the game
+mono --debug OpenRA.Game.exe Game.Mod=mw Engine.LaunchPath="/usr/bin/openra-mw" "Engine.ModSearchPaths=/usr/lib/openra-mw/mods" "$@"
+
+# Show a crash dialog if something went wrong
+if [ $? != 0 ] && [ $? != 1 ]; then
+ ERROR_MESSAGE="OpenRA Medieval Warfare has encountered a fatal error.\nPlease refer to the crash logs and FAQ for more information.\n\nLog files are located in ~/.openra/Logs\nThe FAQ is available at http://wiki.openra.net/FAQ"
+ if command -v zenity > /dev/null; then
+ zenity --no-wrap --error --title "OpenRA Medieval Warfare" --text "${ERROR_MESSAGE}" 2> /dev/null
+ elif command -v kdialog > /dev/null; then
+ kdialog --title "OpenRA Medieval Warfare" --error "${ERROR_MESSAGE}"
+ else
+ printf "${ERROR_MESSAGE}\n"
+ fi
+ exit 1
+fi
+
diff --git a/openra-mw.appdata.xml b/openra-mw.appdata.xml
new file mode 100755
index 000000000000..043f391c14d5
--- /dev/null
+++ b/openra-mw.appdata.xml
@@ -0,0 +1,37 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<component type="desktop">
+ <id>openra-mw.desktop</id>
+ <metadata_license>CC0-1.0</metadata_license>
+ <project_license>GPL-3.0</project_license>
+ <name>OpenRA - Medieval Warfare</name>
+ <summary>An open-source game of medieval warfare</summary>
+ <description>
+ <p>
+ OpenRA Medieval Warfare is a project that uses the OpenRA game engine to create an original game of medieval warfare.
+ </p>
+ </description>
+ <url type="homepage">https://github.com/CombinE88/Medieval-Warfare</url>
+ <update_contact>https://github.com/CombinE88</update_contact>
+ <content_rating type="oars-1.0">
+ <content_attribute id="violence-cartoon">none</content_attribute>
+ <content_attribute id="violence-fantasy">none</content_attribute>
+ <content_attribute id="violence-realistic">moderate</content_attribute>
+ <content_attribute id="violence-bloodshed">moderate</content_attribute>
+ <content_attribute id="violence-sexual">none</content_attribute>
+ <content_attribute id="drugs-alcohol">none</content_attribute>
+ <content_attribute id="drugs-narcotics">none</content_attribute>
+ <content_attribute id="drugs-tobacco">none</content_attribute>
+ <content_attribute id="sex-nudity">none</content_attribute>
+ <content_attribute id="sex-themes">none</content_attribute>
+ <content_attribute id="language-profanity">mild</content_attribute>
+ <content_attribute id="language-humor">mild</content_attribute>
+ <content_attribute id="language-discrimination">none</content_attribute>
+ <content_attribute id="social-chat">intense</content_attribute>
+ <content_attribute id="social-info">none</content_attribute>
+ <content_attribute id="social-audio">none</content_attribute>
+ <content_attribute id="social-location">none</content_attribute>
+ <content_attribute id="social-contacts">none</content_attribute>
+ <content_attribute id="money-purchasing">none</content_attribute>
+ <content_attribute id="money-gambling">none</content_attribute>
+ </content_rating>
+</component>
diff --git a/openra-mw.changes b/openra-mw.changes
new file mode 100755
index 000000000000..60d8c2241f33
--- /dev/null
+++ b/openra-mw.changes
@@ -0,0 +1,17 @@
+-------------------------------------------------------------------
+Sun Aug 26 06:45:12 UTC 2018 - brentonhorne77@gmail.com
+
+- Oddly upstream now uses {DEV_VERSION} (latest git commit on bleed
+ branch as engine version), so fixing. See commit #5eeb3e7 for
+ my fix to mwup at my common-scripts git repo.
+
+-------------------------------------------------------------------
+Thu Jul 26 19:30:32 UTC 2018 - brentonhorne77@gmail.com
+
+- Rm libgdiplus-devel build dependency, as RPMLint is whinging
+ that rpm should detect it for itself.
+
+-------------------------------------------------------------------
+Thu Jul 26 18:47:06 UTC 2018 - brentonhorne77@gmail.com
+
+- Initial commit, version 152 (#e9fa8b2).
diff --git a/openra-mw.desktop b/openra-mw.desktop
new file mode 100755
index 000000000000..57c29bedc0a7
--- /dev/null
+++ b/openra-mw.desktop
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Type=Application
+Version=1.0
+Name=OpenRA - Medieval Warfare
+GenericName=Real Time Strategy Game
+GenericName[de]=Echtzeit-Strategiespiel
+Comment=An open-source game depicting medieval warfare
+Icon=openra-mw
+Exec=openra-mw
+Terminal=false
+Categories=Game;StrategyGame;X-RTS;X-RealTimeStrategy;X-RealTimeStrategyGame;
diff --git a/openra-mw.install b/openra-mw.install
new file mode 100755
index 000000000000..c68b4d92dffb
--- /dev/null
+++ b/openra-mw.install
@@ -0,0 +1,12 @@
+post_upgrade() {
+ update-desktop-database -q
+ gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
+}
+
+post_install() {
+ post_upgrade
+}
+
+post_remove() {
+ post_upgrade
+}